Login  •  Register


The time is now: Thu Oct 23, 2014 3:08 pm

Emaculation wiki  •  Delete all board cookies



Post new topic  Reply to topic Page 1 of 1 [ 19 posts ]
Print view Previous topic  |  Next topic
Author Message
PostPosted: Fri Jan 25, 2013 4:50 am 
Offline
Student Driver

Joined: Fri Jan 25, 2013 4:17 am
Posts: 12
Hello,
I have been trying to emulate an older version of mac os system,
either os x 10.6
os 9
just any DAMN MAC SYSTEM TO SUPPORT GOD DAMN POWER PC,
I have tried everything, and at all avenues, error, cannot install on this machine, cannot open application, missing CarbonLIB,
cannot update software to support this program,
for god sake can someone help me and put it into english!
as the instructions said on this page
http://www.emaculation.com/doku.php/she ... os_x_setup

i followed everything to the T, i get to the part where it says using disk image and the error i get is
The start up disk will not work on this macintosh model. Use the latest installer to update his disk for this model.



I have been at this for about 6 months! and i am extremely frustrated, as i updated to 10.7.5 and everything i had/have is now completely f'd!
Oh P.S i have tried
Virtual Box
Wineskin
BasaliskII (i think you need to be a programer to operate that)
and SheepShaver....nothing works!
Thankyou, and sorry for the moodiness!


Top
 Profile  
Post a reply  
PostPosted: Fri Jan 25, 2013 6:27 am 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 3422
Location: Sittard, The Netherlands
Hi,

Sorry to see you got so frustrated by following our guide. It was intended to limit frustration by explaining SheepShaver setup in detail ;-)

The guide states that you can only install up to Mac OS 9.0.4 in SheepShaver. This then explains why you got the error "can not install..." as you are trying to install Mac OS 9.2.1. When searching for a Mac OS install CD of Mac OS 9 you should take care it is universal install CD (or image of such CD), as CD that came with a specific Mac model will not work.
In order to check whether the rest of your SheepShaver setup is correct, you can download a demo disk image (it doesn't contain a full installation of OS 9) from the redundant robot site.

Any PowerPC Mac OS versions above Mac OS 9 should be installed using PearPC, which is dreadful because it is dead slow when ran in Mac OS X as host.

You should be able to install Mac OS 10.6, which should still give you Apple' own PowerPC emulator "Rosetta" in Virtual box, Parallels or Fusion. But only after "fixing" these programs. We, however, do not deal with that. Please refer to a site such as insanelymac for that.

Best,
Cat_7


Top
 Profile  
Post a reply  
PostPosted: Fri Jan 25, 2013 7:42 am 
Offline
Student Driver

Joined: Fri Jan 25, 2013 4:17 am
Posts: 12
Thankyou for your fast and hastey reply,

It is good to see that these forums are regularly monitored :)

but yes, after more investigating, i have come to realise that yes it was user error of trying to install over os 9.0.4,
i now backdated and am currently half way through the install of 9.0.4 which i am excited about,
i am still hoping that i can use some power PC applications as long as i have the updated CarbonLIB,
would you have much knowledge on carbon lib and os 9.0.4 ...
what am i talking about, you probably invented os 9.0.4 hahaha ;)


Top
 Profile  
Post a reply  
PostPosted: Fri Jan 25, 2013 8:49 am 
Offline
Student Driver

Joined: Fri Jan 25, 2013 4:17 am
Posts: 12
hmmm ok,
i have recently discovered that when i start to install os 9.0.4, it starts to install but the timer just gets longer and longer and longer,
is it meant take over an hour plus?
or is there something like a hang time going on?
thankyoy for your help!

oh this also comes up in console as well,
25/01/13 7:11:41.000 PM kernel: IOSurface: buffer allocation size is zero


Top
 Profile  
Post a reply  
PostPosted: Fri Jan 25, 2013 10:40 am 
Offline
Expert User
User avatar

Joined: Thu Feb 09, 2006 10:24 pm
Posts: 4012
Location: Amsterdam, Netherlands
It may be the stall that can happen while the installer tries to update the Apple hard disk drivers. See our setup guide, in the section about installing the system, the description and how to get around it.

Applications that need the latest CarbonLib for Mac OS extension (version 1.6) will run with it in Mac OS 9.0.4. Of course you cannot run applications that need any version of Mac OS X in SheepShaver.


Top
 Profile  
Post a reply  
PostPosted: Fri Jan 25, 2013 10:50 am 
Offline
Student Driver

Joined: Fri Jan 25, 2013 4:17 am
Posts: 12
thankyou, i will enquire and follow your instructions :)


Top
 Profile  
Post a reply  
PostPosted: Fri Jan 25, 2013 11:21 am 
Offline
Student Driver

Joined: Fri Jan 25, 2013 4:17 am
Posts: 12
After following the guide, and also the 'connecting to the internet guide,
i have finally got OS 9.0.4 working, no thanks to the help of you two fine gentleman,
but another problem has arrived
I have also succesfully updated carbon Lib to 1.6, after doing this, when i try open my program, i receive an error stating that the program cannot be run on this system, can only be run on os 8.6 or later,

this confuses me as i am running 9.0.4
thankyou


Top
 Profile  
Post a reply  
PostPosted: Fri Jan 25, 2013 2:55 pm 
Offline
Expert User
User avatar

Joined: Thu Feb 09, 2006 10:24 pm
Posts: 4012
Location: Amsterdam, Netherlands
That is strange indeed. Did you restart MacOS/SheepShaver after installing CarbonLib 1.6? The extension may be available only after a new startup.


Top
 Profile  
Post a reply  
PostPosted: Fri Jan 25, 2013 11:28 pm 
Offline
Student Driver

Joined: Fri Jan 25, 2013 4:17 am
Posts: 12
Yes, i not only restarted sheep shaver,
i also restated my actual mac, same error


Top
 Profile  
Post a reply  
PostPosted: Sat Jan 26, 2013 12:38 pm 
Offline
Expert User
User avatar

Joined: Thu Feb 09, 2006 10:24 pm
Posts: 4012
Location: Amsterdam, Netherlands
On your actual Mac this is also in 9.0.4 (or another 9.x.x)? Has the program ever run in a MacOS 9? Does/did it run in 8.6?


Top
 Profile  
Post a reply  
PostPosted: Sun Jan 27, 2013 3:25 am 
Offline
Student Driver

Joined: Fri Jan 25, 2013 4:17 am
Posts: 12
The host system is 10.7.5
the sheepshaver system is 9.0.4 and has only ever run 9.0.4
when i try the software updater, it says it cannot update, but i can surf the internet through IE explorer


Top
 Profile  
Post a reply  
PostPosted: Sun Jan 27, 2013 8:46 pm 
Offline
Expert User
User avatar

Joined: Thu Feb 09, 2006 10:24 pm
Posts: 4012
Location: Amsterdam, Netherlands
:?: Are we still talking about the same problem or is this a different problem?

I asked if your program (which program is that?), that apparently does not run in 9.0.4 although it is supposed to run in 8.6 and later, does run in 8.6. What has software updater to do with that? Have you ever tried the program in 8.6?

(The software updater in 9.0.4 (if it works) will only install a new version of the updater and next install CarbonLib 1.6. As you already installed CarbonLib 1.6, you do not need the updater.)


Top
 Profile  
Post a reply  
PostPosted: Mon Jan 28, 2013 8:24 am 
Offline
Student Driver

Joined: Fri Jan 25, 2013 4:17 am
Posts: 12
oh ok,

no i have never installed os 8.6, i have a 9.0.4 cd which installed successfully,
the updater within os 9.04 won't update and that's why i downloaded carbon lib 1.6,
the only problem is that all the applications i try to open, all state the same problem,
all the programs ask that i use os 8.6 or later


Top
 Profile  
Post a reply  
PostPosted: Mon Jan 28, 2013 10:16 am 
Offline
Expert User
User avatar

Joined: Thu Feb 09, 2006 10:24 pm
Posts: 4012
Location: Amsterdam, Netherlands
Literally "all" programs? Which applications are we talking about?

SheepShaver starts up from the installed 9.0.4 and CarbonLib 1.6 is installed in that system?


Top
 Profile  
Post a reply  
PostPosted: Mon Jan 28, 2013 10:49 pm 
Offline
Student Driver

Joined: Fri Jan 25, 2013 4:17 am
Posts: 12
all generic applications that came with the install od os9, work fine,
applications which i have imported through the share folder have problems,

i have also taken the programs from the shared folder and moved them into os9 desktop to see if that fixed the problem, didn't help

it's only third party programs and game applications that fail
appleworkd 5.0.3 fails to open with the same error


Top
 Profile  
Post a reply  
PostPosted: Mon Jan 28, 2013 11:09 pm 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 3422
Location: Sittard, The Netherlands
Ah,

Our guides state clearly that you should never run applications from the shared drive, nor move them to the OS 9 desktop. If you do, they actually stay on the shared disk.
You always need to copy them to the OS disk before running. You can make aliases on the desktop, but only when the original resides on the OS 9 disk.

Best,
Cat_7


Top
 Profile  
Post a reply  
PostPosted: Tue Jan 29, 2013 5:56 am 
Offline
Student Driver

Joined: Fri Jan 25, 2013 4:17 am
Posts: 12
thankyou


is that the .dsk file or the os9.iso?
and if it's the .dsk, how can i open the folder contents?

Edit:
I copied the files inside sheepshaver from shared onto the emulated HD, i still encounter the same error,
you need os 8.6 or later to run this application


Top
 Profile  
Post a reply  
PostPosted: Tue Jan 29, 2013 8:32 am 
Offline
Expert User
User avatar

Joined: Thu Feb 09, 2006 10:24 pm
Posts: 4012
Location: Amsterdam, Netherlands
Exactly which volumes do you use in SheepShaver? Is os9.iso the image of a system install CD? If it is and if you followed the guide, it should not be on your OS9 desktop anymore. Did you do an actual installation of OS9 and did you do that on the image you created?

As described in the guide, applications can be added using the shared folder/Unix disk and next be copied (dragged) directly from the Unix disk to another disk that is mounted on the SheepShaver desktop, usually the virtual HD you created, that you installed the system onto, and that is the boot volume for SheepShaver.

Is the CarbonLib 1.6 extension where it should be, in the Extensions folder in the System Folder?


Last edited by Ronald P. Regensburg on Tue Jan 29, 2013 8:34 am, edited 1 time in total.
 


Top
 Profile  
Post a reply  
PostPosted: Tue Jan 29, 2013 11:50 pm 
Offline
Student Driver

Joined: Fri Jan 25, 2013 4:17 am
Posts: 12
i figured it out,
once i copied the files through sheep shaver onto the actual os9 emulated HD, the application worked,

thankyou for your help and time :)


Top
 Profile  
Post a reply  
Display posts from previous:  Sort by  
Post new topic  Reply to topic Page 1 of 1 [ 19 posts ]


Who is online

Users browsing this forum: Yahoo [Bot] and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
 

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group