Switch to full style
About SheepShaver, a PPC Mac emulator for Windows, MacOSX, and Linux that can run System 7.5.3 through MacOS 9.0.4.
Post a reply

"WARNING: Cannot open /dev/dsp (Input/output error)" solved

Wed Dec 21, 2016 4:02 am

I've solved my problem, I just wanted to let other people know who might come across the same issue, because I couldn't find anything when I googled the error message.

If you're running SheepShaver from linux (where OSS is now replaced with pulseaudio) and you get a dialog box saying "Sheepshaver warning: No audio device found, audio output will be disabled" and in stderr it says:

WARNING: Cannot open /dev/dsp (Input/output error)
WARNING: Cannot open ESD connection

then try running "padsp SheepShaver" instead. I'm wondering if this should be part of the instructions for using SheepShaver on linux, because from what I've read, pulseaudio is pretty standard nowadays so although /dev/dsp exists, it won't work without the padsp wrapper.

Re: "WARNING: Cannot open /dev/dsp (Input/output error)" sol

Wed Dec 21, 2016 5:43 pm

Yes; good suggestion. PulseAudio is indeed the default on most major distros (followed by ALSA), so documenting that would be a good idea.

Re: "WARNING: Cannot open /dev/dsp (Input/output error)" sol

Fri Jun 16, 2017 6:18 pm

I agree. This solution should definitely be documented on that page because due to its absence, I wasted several days trying to get the audio to work on my Ubuntu host. For anyone else in the same position, you need to install the 'osspd' package:
Code:
sudo apt-get install osspd
, then run SheepShaver via the Terminal with the command:
Code:
padsp /usr/bin/SheepShaver
OR
Code:
padsp ./SheepShaver
as appropriate. It is also recommended to remove the Apple Audio Extension from within the MacOS and make sure 'Built-in' is selected in the sound control panel.

Is there a setting in SheepShaver that can be made so that it can be launched directly in the GUI, i.e. without having to type the above command? I tried /dev/padsp, /dev/osspd and /dev/pulseaudio in the 'Audio Output Device' field under the 'Graphics/Sound' tab, but neither make a difference.

Re: "WARNING: Cannot open /dev/dsp (Input/output error)" sol

Fri Jun 16, 2017 7:22 pm

I added your info in the guide for linux.

Thanks,
Cat_7

Re: "WARNING: Cannot open /dev/dsp (Input/output error)" sol

Wed Jun 28, 2017 12:37 pm

Hi guys, I've installed osspd and started SheepShaver as your instructions say
but I still have this error on raspbian
Any clue?

thanks!
Post a reply