Login  •  Register


The time is now: Mon Aug 21, 2017 6:28 am

Emaculation wiki  •  Delete all board cookies



Post new topic  Reply to topic Page 1 of 1 [ 9 posts ]
Print view Previous topic  |  Next topic
Author Message
PostPosted: Thu Jun 22, 2017 1:55 am 
Offline
Student Driver

Joined: Wed Mar 11, 2009 11:59 pm
Posts: 16
I am not able to connect to the internet with Sheepshaver on my Mac. I was wondering if it is possible, and if so, how to setup/configure.
I am a total noob to most of this, and need explicit instructins. I gather that some part of the fix might be the TCP/IP thing, but that is all I know.
My Mac is running OS 10.9.5, and I have it connected via an ethernet cable.
Any help is much appreciated.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Thu Jun 22, 2017 5:10 am 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 4156
Location: Sittard, The Netherlands
Hi,

Start SheepShaver and open the preferences editor. Go to the Miscellaneous tab. Make sure you have entered "slirp" (without quotes) in the field Internet Interface, and save the settings. Only restart SheepShaver if "slirp" was not already entered in that field.

Then go to the tcp/ip control panel and check that you have selected "DHCP" in the drop down list at the Configure option. Close and save the settings.

Restart SheepShaver and open an internet browser. You should now have internet access. The included browsers are very buggy. It is best to download Classilla on your host and install it in SheepShaver.

Best,
Cat_7


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Fri Jun 23, 2017 1:59 am 
Offline
Student Driver

Joined: Wed Mar 11, 2009 11:59 pm
Posts: 16
Thank you for your help, it worked perfectly. I am now able to connect to the internet with Sheepshaver.
When trying to get to a file on my Google drive, and my Gmail, it says 'Security Failure, a secure connection could not be established'.
When I tried to download the Classilla installer, it said 'Security Failure, the server reply is invalid'.
What to do about both of these? Also, another potential problem I could foresee, when I was looking at the Classilla installer, it said it was a stuffit file. Is there an extractor already in OS 9?
Then I downloaded the .sit file for Classilla, and the .dmg for stuffit expander, but I had to do both outside of Sheepshaver, so in my regular 10.9 workspace.
I don't know how I would get the Classilla into Sheepshaver and OS 9, assuming that is what we need to do.
Sorry for so many questions. Again, I am new and I appreciate your help, it has worked so far.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Fri Jun 23, 2017 4:25 am 
Offline
Forum All-Star
User avatar

Joined: Fri Nov 27, 2009 5:11 am
Posts: 1716
If you've got a full install of OS 9, it comes with Stuffit Expander by default. If you have the stripped down Redundant Robot image, you're going to be missing a bunch of stuff. Best idea is to create a blank disk image and use an installer image to install a full version of OS 9.04 on it.

As for getting Classilla in there, download it on your host and put it in your shared folder, then inside SheepShaver, open the Unix folder and copy the stuffit file to the local HD. From there, use Stuffit Expander to expand it and put Classilla in your Applications folder.

However, I'm not sure how up to date Classilla is right now; many servers (including all Google products) are moving to requiring a recent secure version of HTTPS be used for anything requiring an account. A few months ago there was a major security flaw found and patched in HTTPS, and so most sites no longer support older versions of the protocol. If Classilla hasn't been updated, it may no longer be able to connect to services like Google Drive.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Fri Jun 23, 2017 4:21 pm 
Offline
Student Driver

Joined: Wed Mar 11, 2009 11:59 pm
Posts: 16
I do have a full install of OS9, done with my CD.
I got that .sit file in through the shared folder as you said, and also as you said, there was an expander in OS 9
It extracted the pieces of Classilla, but trying to run it now I cannot. It says not enough memory.
I did a Get Info>Memory on it and the suggested is 82070. Minimum is around 16K, maximum is again that 82 number.
Any help in getting Classilla to run is appreciated.
In the meantime, now I can get files in and out using the shared folder as you suggested, many thanks for that tip.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Fri Jun 23, 2017 7:16 pm 
Offline
Expert User
User avatar

Joined: Thu Feb 09, 2006 10:24 pm
Posts: 4787
Location: Amsterdam, Netherlands
Where does the copy of Classilla reside inside SheepShaver?
The not enough memory warning will be seen when you try to run an application that exists on the 'Unix' volume (shared folder) or on the desktop of that volume (in classic MacOS each volume has its own desktop and the the Desktop you see is the combined desktops of all mounted volumes). Make sure the application is copied to the another volume, like the system volume.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Fri Jun 23, 2017 7:33 pm 
Offline
Student Driver

Joined: Wed Mar 11, 2009 11:59 pm
Posts: 16
Yes, it's on the desktop. I pulled the .sit file in from the Unix shared folder and put it on the desktop, then extracted it there. It placed the folder there.
How do I copy the application to the system volume?
Thank you for your help.
Also, any idea of how to remove the security failures I was getting in Internet Explorer 4.5? It would open Google, and a news site, but most sites said it was experiencing a security failure.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Fri Jun 23, 2017 9:12 pm 
Offline
Forum All-Star
User avatar

Joined: Fri Nov 27, 2009 5:11 am
Posts: 1716
"On the Desktop" means you've stuck it in the Desktop folder on the Unix volume. You'll have to actually copy it to an internal volume to make it work. I recommend putting it in the Applications folder.

You can't remove the security failures in IE 4.5 -- it was developed so long ago that it is insecure by modern standards. It is not safe to use for encrypted data.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Sat Jun 24, 2017 1:22 am 
Offline
Student Driver

Joined: Wed Mar 11, 2009 11:59 pm
Posts: 16
Got it! That worked, thank you for your help again.


Top
 Profile  
Reply with quote Post a reply  
Display posts from previous:  Sort by  
Post new topic  Reply to topic Page 1 of 1 [ 9 posts ]


Who is online

Users browsing this forum: No registered users and 13 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
 

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group