Login  •  Register


The time is now: Thu Jul 27, 2017 8:41 am

Emaculation wiki  •  Delete all board cookies



Post new topic  Reply to topic Page 1 of 1 [ 5 posts ]
Print view Previous topic  |  Next topic
Author Message
PostPosted: Mon Jul 10, 2017 7:51 pm 
Offline
Forum All-Star

Joined: Tue Oct 14, 2008 12:12 am
Posts: 696
This problem occurs in SheepShaver running 9.0.4. It does NOT occur in Qemu running 9.2.

When I work in Script Debugger (see another thread about that wonderful program), I can paste into a Script Debugger editing window, but I can't copy anything from the window. If I copy from the editing window, the clipboard reports that it contains styled text, but the clipboard is actually empty.

EDIT: See below for more detail. This is a problem with any application that copies styled text to the clipboard under SheepShaver.


Last edited by emendelson on Tue Jul 11, 2017 2:51 pm, edited 2 times in total.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Tue Jul 11, 2017 2:42 pm 
Offline
Forum All-Star

Joined: Tue Oct 14, 2008 12:12 am
Posts: 696
It turns out that this is a problem with any application running under SheepShaver that tries to copy "styled text" to the clipboard. If you format some text in ClarisWorks, for example, and copy it to the clipboard, you get an empty clipboard.

So it's a SheepShaver but that will presumably never be fixed, alas.

EDIT: There's a patch here for copying styled text to the HOST clipboard from SheepShaver/BasiliskII under BEOS, but it doesn't seem to apply to this issue:

https://github.com/cebix/macemu/commit/ ... 7fd96e85cd

EDIT: And the relevant patches already seem to be in the code that I've been building...


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Tue Jul 11, 2017 9:50 pm 
Offline
Expert User
User avatar

Joined: Thu Feb 09, 2006 10:24 pm
Posts: 4766
Location: Amsterdam, Netherlands
emendelson wrote:
It turns out that this is a problem with any application running under SheepShaver that tries to copy "styled text" to the clipboard. If you format some text in ClarisWorks, for example, and copy it to the clipboard, you get an empty clipboard.


I have been discussing this issue and similar clipboard oddities in SheepShaver years ago and at the time found some (convoluted) workarounds. But I forgot the specifics and I do not even remember where I had this discussion and with whom. Could have been here, or in cebix/macemu, or in the old B2-devel mailing list, or in an email exchange. When I have the time, I will try to recover the discussion. With a simple search here I cannot find it.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Tue Jul 11, 2017 9:52 pm 
Offline
Forum All-Star

Joined: Tue Oct 14, 2008 12:12 am
Posts: 696
Ronald P. Regensburg wrote:
emendelson wrote:
It turns out that this is a problem with any application running under SheepShaver that tries to copy "styled text" to the clipboard. If you format some text in ClarisWorks, for example, and copy it to the clipboard, you get an empty clipboard.


I have been discussing this issue and similar clipboard oddities in SheepShaver years ago and at the time found some (convoluted) workarounds. But I forgot the specifics and I do not even remember where I had this discussion and with whom. Could have been here, or in cebix/macemu, or in the old B2-devel mailing list, or in an email exchange. When I have the time, I will try to recover the discussion. With a simple search here I cannot find it.


Thank you for looking for this - I certainly haven't found anything here, and the only thing I found on cebix/macemu was the fix for BeOS. Anything you can find would be worth having.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Tue Jul 11, 2017 10:58 pm 
Offline
Forum All-Star
User avatar

Joined: Fri Nov 27, 2009 5:11 am
Posts: 1684
Ronald P. Regensburg wrote:
emendelson wrote:
It turns out that this is a problem with any application running under SheepShaver that tries to copy "styled text" to the clipboard. If you format some text in ClarisWorks, for example, and copy it to the clipboard, you get an empty clipboard.


I have been discussing this issue and similar clipboard oddities in SheepShaver years ago and at the time found some (convoluted) workarounds. But I forgot the specifics and I do not even remember where I had this discussion and with whom. Could have been here, or in cebix/macemu, or in the old B2-devel mailing list, or in an email exchange. When I have the time, I will try to recover the discussion. With a simple search here I cannot find it.



I think it was on the mailing list IIRC.


Top
 Profile  
Reply with quote Post a reply  
Display posts from previous:  Sort by  
Post new topic  Reply to topic Page 1 of 1 [ 5 posts ]


Who is online

Users browsing this forum: Google [Bot] and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
 

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group