Login  •  Register


The time is now: Wed Oct 18, 2017 12:08 am

Emaculation wiki  •  Delete all board cookies



Post new topic  Reply to topic Page 1 of 1 [ 19 posts ]
Print view Previous topic  |  Next topic
Author Message
PostPosted: Tue Aug 29, 2017 5:30 pm 
Offline
Student Driver

Joined: Tue Aug 29, 2017 5:21 pm
Posts: 14
I have sheepshaver running on a macbook pro 2016.
Very nice. I've been using Turbosynth succesfully.
I bought Sound designer 1.5 because you can make samples for many different samplers. Ive got MIRage I want to make sounds for, but sound designer is not working.
Maybe because it uses Midi?
I get this error upon opening
"This Window cannot be opened because SDTemp-708109321"
I can't open a sound file or make a new file to draw a sound. Nothing works.
Help , and Thank you

I should note that an early version of turbosynth also doesnt work


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Tue Aug 29, 2017 5:34 pm 
Offline
Forum All-Star
User avatar

Joined: Fri Nov 27, 2009 5:11 am
Posts: 1791
Sounds like Sound Designer is trying to write a temp file somewhere it doesn't have write permissions. Do you have it installed on the boot partition of your SheepShaver OS 9 image? If so, did you install a full OS 9 on the image, or just use the preinstalled image from Redundant Robot that doesn't contain most of the software needed to support audio and video?


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Tue Aug 29, 2017 7:14 pm 
Offline
Student Driver

Joined: Tue Aug 29, 2017 5:21 pm
Posts: 14
I followed this video
https://www.youtube.com/watch?v=XQAf7GII9NY

Funny thing. Turbosynth stopped working. UNTIL I turned bluetooth back on.


This is all in the latest sierra


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Tue Aug 29, 2017 7:19 pm 
Offline
Student Driver

Joined: Tue Aug 29, 2017 5:21 pm
Posts: 14
Im afraid to install sound designer again as I got Turbosynth going, after a redo. I have a g4 i can use SD with


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Tue Aug 29, 2017 7:25 pm 
Offline
Student Driver

Joined: Tue Aug 29, 2017 5:21 pm
Posts: 14
I did everything that kid did in the video. Works well. Except the SD problem

Only thing Ive done different is I moved the Sheepshaver folder to my applications folder in Sierra. but I installed turbosynth. (or unpacked it) via OS 9 sheepshaver


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Tue Aug 29, 2017 7:50 pm 
Offline
Forum All-Star
User avatar

Joined: Fri Nov 27, 2009 5:11 am
Posts: 1791
I think I may be confused about what you're trying to do here. Does this line up?

Host OS OS X 10.12 on 2016 MBP

Guest OS: Mac OS 9.0.4 (full install from CD image) on SheepShaver running in 32-bit mode.

Guest software: Sound Designer 1.5, installed in the Applications folder on the Mac OS 9.0.4 Macintosh HD volume.

Is this correct?

The MIDI functions will not work (MIDI does not work in SheepShaver) but the rest of SD should work.

Any reason you went with 1.5 instead of Sound Designer II?


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Fri Sep 01, 2017 12:49 am 
Offline
Student Driver

Joined: Tue Aug 29, 2017 5:21 pm
Posts: 14
yes OS 10.12.6

latest mac. touchbar. etc.
I know about the Midi thing. I chose 1.5 because it has it specifically supports hardware samplers . You can load up support for the Mirage and it's OS and save in the sampler format. I was going to transfer to my g4 and send over midi.

I dont know what you mean by Guest OS: Mac OS 9.0.4

I did exactly what that kid did in the video. Then I went into unix and dragged turbosynth in and installed that way.

I'll try SD one more time


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Fri Sep 01, 2017 12:52 am 
Offline
Student Driver

Joined: Tue Aug 29, 2017 5:21 pm
Posts: 14
Dragged the sd installer to Applications in OS 9 and get the same errors.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Fri Sep 01, 2017 1:06 am 
Offline
Student Driver

Joined: Tue Aug 29, 2017 5:21 pm
Posts: 14
Maybe it is trying to establish Midi?


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Fri Sep 01, 2017 1:15 am 
Offline
Student Driver

Joined: Tue Aug 29, 2017 5:21 pm
Posts: 14
yes, Guest OS: Mac OS 9.0.4

not sure about bit rate


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Fri Sep 01, 2017 1:29 am 
Offline
Student Driver

Joined: Tue Aug 29, 2017 5:21 pm
Posts: 14
Do I need to established shared folders?


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Fri Sep 01, 2017 1:38 am 
Offline
Student Driver

Joined: Tue Aug 29, 2017 5:21 pm
Posts: 14
Interesting. I have an early version of turbosynth and it also supports different samplers and has Midi support unlike the newer version im using. The older version is giving the same errors as SD!


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Fri Sep 01, 2017 3:33 pm 
Offline
Forum All-Star
User avatar

Joined: Fri Nov 27, 2009 5:11 am
Posts: 1791
Sounds like it's an issue with trying to initialize the serial port then :\

Is 1.5 old enough that it'd run under 7.5.3? You could try it in pce/macplus which has serial support....


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Fri Sep 01, 2017 5:34 pm 
Offline
Student Driver

Joined: Tue Aug 29, 2017 5:21 pm
Posts: 14
ill give it a shot. thanks


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Fri Sep 01, 2017 5:44 pm 
Offline
Student Driver

Joined: Tue Aug 29, 2017 5:21 pm
Posts: 14
is there a 7.5.3 w/ serial support emulation that runs in sierra OSX?


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Fri Sep 01, 2017 8:45 pm 
Offline
Forum All-Star
User avatar

Joined: Fri Nov 27, 2009 5:11 am
Posts: 1791
pce/macplus is the only one I know of. You'll have to compile it yourself though -- the web download is the Windows build plus the source.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Sun Sep 03, 2017 2:26 am 
Offline
Student Driver

Joined: Tue Aug 29, 2017 5:21 pm
Posts: 14
I got SD working with Basilisk II and OS 7.

Works. I wonder if I got a midi interfce for the macbook I could pass midi info.


Only negative is the mouse is a bit sluggish.

Even the old turbosynth works


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Sun Sep 03, 2017 12:20 pm 
Offline
Forum All-Star

Joined: Wed Nov 11, 2009 5:47 pm
Posts: 1025
Location: Germany
As SSW 7 seems to be the way to go, you might try SheepShaver with SSW 7.5.3 too.
There is a bootable image here: http://macintoshgarden.org/apps/macos-753-emulators
SheepShaver is way faster but is sharing the same limitation regarding MIDI.
There is no support for MIDI in the source code since their common ancestor ShapeShifter for Amiga.

FusionPC for DOS has basic MIDI support.
Alas Fusion needs some kind of DOS host and configuring MIDI in DOS plus routing to your MIDI box looks like a nightmare to me.
In theory some SCSI to MIDI solution may be possible as Fusion supports SCSI flawlessly.
Basilisk Build 142 for PC does support SCSi too, just a thought and a really long shot either way.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Sun Sep 03, 2017 6:31 pm 
Offline
Student Driver

Joined: Tue Aug 29, 2017 5:21 pm
Posts: 14
I have a g4 with a midi card. And SSD drive. Runs great. I just thought it oul be cool to put everything on a macbook.

SD on the G4 is giving me an error though..

"There is no unlocked disk which can hold a backup file."

Thanks for all he help. Its all a learning experience


Top
 Profile  
Reply with quote Post a reply  
Display posts from previous:  Sort by  
Post new topic  Reply to topic Page 1 of 1 [ 19 posts ]


Who is online

Users browsing this forum: Bing [Bot] and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
 

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group