Login  •  Register


The time is now: Mon Apr 24, 2017 9:09 pm

Emaculation wiki  •  Delete all board cookies



Post new topic  Reply to topic Page 1 of 1 [ 12 posts ]
Print view Previous topic  |  Next topic
Author Message
PostPosted: Wed Mar 15, 2017 5:39 pm 
Offline
Student Driver

Joined: Thu Oct 07, 2010 3:22 pm
Posts: 17
I installed both Basilisk II and Sheepshaver years ago on OS 10.8.x (it's been 10.8.5 since the beginning or soon after). I got them working at the time. I haven't used either of them since then. Now I've been trying again, but Basilisk II won't open at all (& just in case it can shed any light on the situation: Sheepshaver has a question-mark disk). Console shows this:

BasiliskII[268]: CPSSetForegroundOperationState(): This call is deprecated and should not be called anymore.

Should I be starting fresh from the beginning with installing? I've look around on the forum to see if there was something simple I'd forgotten over the years, but I haven't come across anything yet.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Wed Mar 15, 2017 7:21 pm 
Offline
Expert User
User avatar

Joined: Thu Feb 09, 2006 10:24 pm
Posts: 4707
Location: Amsterdam, Netherlands
Could it be that since you installed the emulators, some related files were moved or even removed? Are you still on 10.8.5? if nothing changed in the setup, everything should still work.

The warning about a deprecated call is "normal" and can be ignored


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Wed Mar 15, 2017 8:09 pm 
Offline
Student Driver

Joined: Thu Oct 07, 2010 3:22 pm
Posts: 17
Yes, I'm still on 10.8.5. Hmmmm. I can't think of anything that could have been moved, and I'm the only one with access. If I *had* installed Basilisk II (and Sheepshaver) on 10.8.something-earlier – 10.8 shipped with this computer – could that possibly have had an effect?

Thanks for the info about the deprecated call, in any case! That's one step forward.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Wed Mar 15, 2017 8:15 pm 
Offline
Student Driver

Joined: Thu Oct 07, 2010 3:22 pm
Posts: 17
Another possibility: The main difference between now and then is my internet setup. Back then it was ethernet; now it's wifi. I wouldn't *think* that would make a difference. Could this have an effect?


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Wed Mar 15, 2017 8:20 pm 
Offline
Expert User
User avatar

Joined: Thu Feb 09, 2006 10:24 pm
Posts: 4707
Location: Amsterdam, Netherlands
Regular updates to 10.8.5 from an earlier 10.8.x should not change anything.

This is the BasiliskII forum, so let us start with BasiliskII.

Open Terminal (in /Applications/Utilities) and type at the prompt
Code:
open ~/.basilisk_ii_prefs
followed by a return.

The prefs file will open in your default text editor. Select all content, copy and paste it here in your reply.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Wed Mar 15, 2017 8:32 pm 
Offline
Student Driver

Joined: Thu Oct 07, 2010 3:22 pm
Posts: 17
硥晴⁳ਯ敳楲污⁡搯癥振⹵求敵潴瑯⵨潍敤੭敳楲污⁢搯癥港汵੬摵瑰湵敮慦獬੥摵灰牯⁴〶㘶戊潯摴楲敶〠戊潯摴楲敶⁲ਰ慲獭穩⁥㌸㠸〶ਸ牦浡獥楫⁰ਸ਼潭敤楬⁤ਵ灣⁵ਲ਼灦⁵慦獬੥潮摣潲慦獬੥潮潳湵⁤慦獬੥潮汣灩潣癮牥楳湯映污敳渊杯極映污敳樊瑩映污敳樊瑩灦⁵慦獬੥楪摴扥杵映污敳樊瑩慣档獥穩⁥ਰ楪汴穡晹畬桳映污敳樊瑩湩楬敮映污敳權祥潢牡瑤灹⁥ਵ敫捹摯獥映污敳洊畯敳桷敥浬摯⁥਱潭獵睥敨汥楬敮⁳ਲ਼獤⁰搯癥搯灳洊硩牥⼠敤⽶業數ੲ杩潮敲敳癧映污敳椊汤睥楡⁴牴敵

It looks Chinese to me.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Wed Mar 15, 2017 8:37 pm 
Offline
Forum All-Star
User avatar

Joined: Fri Nov 27, 2009 5:11 am
Posts: 1554
That doesn't translate to anything that makes sense... possibly your prefs file got corrupted?


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Wed Mar 15, 2017 8:42 pm 
Offline
Student Driver

Joined: Thu Oct 07, 2010 3:22 pm
Posts: 17
That's what I was wondering. For comparison, replacing basilisk_ii with sheepshaver has similar results. If I just trash the prefs, would I have a "clean start"? – I don't remember the setup process, and maybe setting up prefs was part of that.


Added: And I'm wondering if it's possible to figure out what could have corrupted the prefs.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Wed Mar 15, 2017 8:59 pm 
Offline
Expert User
User avatar

Joined: Thu Feb 09, 2006 10:24 pm
Posts: 4707
Location: Amsterdam, Netherlands
Weird. I have never seen anything like this happen. Does everything else work normally on your machine?

Deleting the files will enable you to start again.

SheepShaver setup guide is here: http://www.emaculation.com/doku.php/she ... os_x_setup
BasiliskII setup guide is here: http://www.emaculation.com/doku.php/bas ... _osx_setup

You may be able to use rom files and disk images used with your previous setup.

(When you have questions about SheepShaver, please post in the SheepShaver forum.)


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Wed Mar 15, 2017 9:08 pm 
Offline
Student Driver

Joined: Thu Oct 07, 2010 3:22 pm
Posts: 17
Well, everything else *seems* to work normally. But I haven't been using most applications/files on the computer lately.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Wed Mar 15, 2017 11:20 pm 
Offline
Forum All-Star
User avatar

Joined: Fri Nov 27, 2009 5:11 am
Posts: 1554
You should probably run a disk check on the host; you might have other corrupted files too.

If BII is now working, you should be fine going forward with it :)


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Thu Mar 16, 2017 11:30 am 
Offline
Student Driver

Joined: Thu Oct 07, 2010 3:22 pm
Posts: 17
I did the built-in Mac OS verify/repair disk, but no problems were found through these checks. Maybe there are more checks possible? For me it's odd to think that both Basilisk II & Sheepshaver are messed up & everything else could be fine. Edit: Ok, there *were* disk permissions to be repaired.

Anyway, I will now start reinstalling the emulators & see how far that comes along.

And thank you guys for the all the tips and help last night!


Top
 Profile  
Reply with quote Post a reply  
Display posts from previous:  Sort by  
Post new topic  Reply to topic Page 1 of 1 [ 12 posts ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
 

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group