Login  •  Register


The time is now: Mon Oct 23, 2017 6:46 pm

Emaculation wiki  •  Delete all board cookies



Post new topic  Reply to topic Page 1 of 1 [ 5 posts ]
Print view Previous topic  |  Next topic
Author Message
PostPosted: Wed Dec 21, 2016 4:02 am 
Offline
Space Cadet

Joined: Wed Dec 21, 2016 3:42 am
Posts: 1
I've solved my problem, I just wanted to let other people know who might come across the same issue, because I couldn't find anything when I googled the error message.

If you're running SheepShaver from linux (where OSS is now replaced with pulseaudio) and you get a dialog box saying "Sheepshaver warning: No audio device found, audio output will be disabled" and in stderr it says:

WARNING: Cannot open /dev/dsp (Input/output error)
WARNING: Cannot open ESD connection

then try running "padsp SheepShaver" instead. I'm wondering if this should be part of the instructions for using SheepShaver on linux, because from what I've read, pulseaudio is pretty standard nowadays so although /dev/dsp exists, it won't work without the padsp wrapper.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Wed Dec 21, 2016 5:43 pm 
Offline
Forum All-Star
User avatar

Joined: Fri Nov 27, 2009 5:11 am
Posts: 1796
Yes; good suggestion. PulseAudio is indeed the default on most major distros (followed by ALSA), so documenting that would be a good idea.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Fri Jun 16, 2017 6:18 pm 
Offline
Space Cadet

Joined: Fri Jun 16, 2017 5:06 pm
Posts: 2
I agree. This solution should definitely be documented on that page because due to its absence, I wasted several days trying to get the audio to work on my Ubuntu host. For anyone else in the same position, you need to install the 'osspd' package:
Code:
sudo apt-get install osspd
, then run SheepShaver via the Terminal with the command:
Code:
padsp /usr/bin/SheepShaver
OR
Code:
padsp ./SheepShaver
as appropriate. It is also recommended to remove the Apple Audio Extension from within the MacOS and make sure 'Built-in' is selected in the sound control panel.

Is there a setting in SheepShaver that can be made so that it can be launched directly in the GUI, i.e. without having to type the above command? I tried /dev/padsp, /dev/osspd and /dev/pulseaudio in the 'Audio Output Device' field under the 'Graphics/Sound' tab, but neither make a difference.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Fri Jun 16, 2017 7:22 pm 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 4185
Location: Sittard, The Netherlands
I added your info in the guide for linux.

Thanks,
Cat_7


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Wed Jun 28, 2017 12:37 pm 
Offline
Space Cadet
User avatar

Joined: Wed Jun 28, 2017 12:31 pm
Posts: 1
Hi guys, I've installed osspd and started SheepShaver as your instructions say
but I still have this error on raspbian
Any clue?

thanks!


Top
 Profile  
Reply with quote Post a reply  
Display posts from previous:  Sort by  
Post new topic  Reply to topic Page 1 of 1 [ 5 posts ]


Who is online

Users browsing this forum: Google [Bot] and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
 

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group