Login  •  Register


The time is now: Tue Sep 02, 2014 9:06 am

Emaculation wiki  •  Delete all board cookies



Post new topic  Reply to topic Page 1 of 3 [ 56 posts ]    Go to page 1, 2, 3  Next
Print view Previous topic  |  Next topic
Author Message
 Post subject: BasiliskII for Linux
PostPosted: Tue Sep 14, 2010 7:33 pm 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 3383
Location: Sittard, The Netherlands
Hello,

As of 13_09_2010, two builds of BasiliskII for Linux are available. these are built on an OpenSuse 11.2 64 bit system

Supporting running full screen, but not windowed:
http://www.open.ou.nl/hsp/downloads/Bas ... 9_2010.zip

Supporting running windowed, but not full screen:
http://www.open.ou.nl/hsp/downloads/Bas ... 9_2010.zip
http://www.open.ou.nl/hsp/downloads/Bas ... No_ESD.zip

The ubuntu network driver is here:
http://www.open.ou.nl/hsp/downloads/sheep_net.ko.zip
The OpenSuse network driver is here:
http://www.open.ou.nl/hsp/downloads/she ... o_SUSE.zip
The Debian network driver is here (Thanks to our forum member bmc5311 ). Build on 64bit Debian Squeeze kernel 2.6.32-5-amd64
http://www.open.ou.nl/hsp/downloads/she ... Debian.zip


Best,
Cat_7


Last edited by Cat_7 on Tue Mar 05, 2013 5:55 pm, edited 3 times in total.
 


Top
 Profile  
Post a reply  
 Post subject: SUCCESS!
PostPosted: Wed Sep 15, 2010 10:58 am 
Offline
Forum All-Star

Joined: Wed Nov 11, 2009 5:47 pm
Posts: 758
Location: Germany
Cat, the SDL version did it for me, thats really great!
Many many thanks!
So fullscreen should be possible with SS too, at last.
Greetings!


Top
 Profile  
Post a reply  
 Post subject:
PostPosted: Wed Sep 15, 2010 11:12 am 
Offline
Site Admin
User avatar

Joined: Mon May 20, 2002 4:37 am
Posts: 3280
Location: Canada
Yes, full screen works! Do check the SheepShaver forum for Cat_7's SS builds!


Top
 Profile  
Post a reply  
 Post subject:
PostPosted: Wed Sep 15, 2010 11:44 am 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 3383
Location: Sittard, The Netherlands
Hi,

I got the impression that these BasiliskII builds seem to be more stable than the SheepShaver builds.
I will rebuild the SheepShaver_X and SDL builds on OpenSuse and see what that brings.

Best,
Cat_7


Top
 Profile  
Post a reply  
 Post subject:
PostPosted: Sun Sep 19, 2010 9:30 am 
Offline
Site Admin
User avatar

Joined: Mon May 20, 2002 4:37 am
Posts: 3280
Location: Canada
The Windowed build doesn't work for me. It just doesn't launch. The full-screen build seems to work fine.

Any thoughts?


Top
 Profile  
Post a reply  
 Post subject:
PostPosted: Sun Sep 19, 2010 9:35 am 
Offline
Site Admin
User avatar

Joined: Mon May 20, 2002 4:37 am
Posts: 3280
Location: Canada
Here's my error message from the terminal:

"./BasiliskII_X_Linux_13_09_2010: error while loading shared libraries: libXxf86dga.so.1: cannot open shared object file: No such file or directory"


Top
 Profile  
Post a reply  
 Post subject:
PostPosted: Sun Sep 19, 2010 10:11 am 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 3383
Location: Sittard, The Netherlands
Hi,

That might be due to the fact that I encountered problems when building with the naming of some header files. The links to the files were renamed by Christian Bauer some time ago from e.g. x86.... to xX86....(or the other way around) This doesn't work in OpenSuse, but does in (some) other distros. Perhaps compiling without support for the dga extensions helps, but I don't know.

I'll see what I can do, juggling/struggling to keep three host OS'ses in the air is taking it's toll.....;-)

Best,
Cat_7


Top
 Profile  
Post a reply  
 Post subject:
PostPosted: Sun Sep 19, 2010 4:24 pm 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 3383
Location: Sittard, The Netherlands
Hi,

Please try this build: http://www.open.ou.nl/hsp/downloads/She ... _noDGA.zip

Best,
Cat_7


Top
 Profile  
Post a reply  
 Post subject:
PostPosted: Mon Sep 20, 2010 10:49 am 
Offline
Site Admin
User avatar

Joined: Mon May 20, 2002 4:37 am
Posts: 3280
Location: Canada
That build works. But as you may know, it is a SheepShaver build, not a Basilisk II build...


Top
 Profile  
Post a reply  
 Post subject:
PostPosted: Mon Sep 20, 2010 11:18 am 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 3383
Location: Sittard, The Netherlands
:oops:

http://www.open.ou.nl/hsp/downloads/Bas ... _noDGA.zip

Better?

Cat_7

Edited by Ronald: Changed backslashes to slashes. :wink:


Top
 Profile  
Post a reply  
 Post subject:
PostPosted: Tue Sep 21, 2010 9:52 am 
Offline
Site Admin
User avatar

Joined: Mon May 20, 2002 4:37 am
Posts: 3280
Location: Canada
That one produces the following error:

"error while loading shared libraries: libesd.so.0: cannot open shared object file: No such file or directory"


Top
 Profile  
Post a reply  
 Post subject:
PostPosted: Tue Sep 21, 2010 10:18 am 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 3383
Location: Sittard, The Netherlands
Well, well, we are doing great. In a attempt to get sound running in SheepShaver for Linux, which doesn't allow selecting the built-in sound device when you use an old world rom (have you noticed that?), I installed the ESD development libraries. I then compiled and it seems that using ESD is the standard setting in the configuration phase. I will try to build a version without ESD support.

But first I need to wait for a torrent to download. I'm going to install Mac OS 10.2 or 10.3 on my old G3 266Mhz.

New try here: http://www.open.ou.nl/hsp/downloads/Bas ... No_ESD.zip

The JIT compiler was not activated in the earlier builds. It is in this one. Take care to set enough Memory on the Jit compiler tab, otherwise the compiler will be disabled or crash.

Best,
Cat_7


Top
 Profile  
Post a reply  
 Post subject:
PostPosted: Tue Sep 21, 2010 10:51 pm 
Offline
Site Admin
User avatar

Joined: Mon May 20, 2002 4:37 am
Posts: 3280
Location: Canada
And that one works!!


Top
 Profile  
Post a reply  
 Post subject: 4MB ROM
PostPosted: Fri Jan 07, 2011 1:24 pm 
Offline
Forum All-Star

Joined: Wed Nov 11, 2009 5:47 pm
Posts: 758
Location: Germany
You are doing great, for sure!
This may be the wrong thread, but SS for Linux does play sound for me with your latest builds.
I am always using the Old-World ROM for my hosts, if only for downward compatibility.
Maybe I am getting something wrong.


Top
 Profile  
Post a reply  
 Post subject:
PostPosted: Sun Jan 23, 2011 10:55 pm 
Offline
Student Driver

Joined: Wed Nov 19, 2008 4:58 pm
Posts: 24
Cat_7, is your (latest) Basilisk II source available somewhere?


Top
 Profile  
Post a reply  
 Post subject:
PostPosted: Mon Jan 24, 2011 7:54 am 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 3383
Location: Sittard, The Netherlands
Hi,

The source is freely available to everyone. It's not my source, I only build versions from it:

cvs -d :pserver:anoncvs@cvs.cebix.net:/home/cvs/cebix login
#password is "anoncvs"
cvs -d :pserver:anoncvs@cvs.cebix.net:/home/cvs/cebix checkout BasiliskII

if you also want SheepShaver, add this:
cvs -d :pserver:anoncvs@cvs.cebix.net:/home/cvs/cebix checkout SheepShaver

to build use:
cd BasiliskII/src/Unix
NO_CONFIGURE=1 ./autogen.sh
./configure --enable-jit-compiler=yes (check configuration options with ./configure --help, also see below for SDL options)
make
strip BasiliskII

If you want to use SDL, install the development packages first and use
--enable-sdl-video=yes and --enable-sdl-sound=yes with ./configure

Best,
Cat_7


Top
 Profile  
Post a reply  
 Post subject:
PostPosted: Mon Jan 24, 2011 1:57 pm 
Offline
Student Driver

Joined: Wed Nov 19, 2008 4:58 pm
Posts: 24
Thank you for the info, Cat_7.

Now how to get it to compile with all these autoconf errors...

Code:
checking xxxxxxxxxx.h usability... no
checking xxxxxxxxxx.h presence... yes
configure: WARNING: xxxxxxxxxx.h: present but cannot be compiled
configure: WARNING: xxxxxxxxxx.h:     check for missing prerequisite headers?
configure: WARNING: xxxxxxxxxx.h: see the Autoconf documentation
configure: WARNING: xxxxxxxxxx.h:     section "Present But Cannot Be Compiled"
configure: WARNING: xxxxxxxxxx.h: proceeding with the compiler's result
configure: WARNING:     ## ------------------------------------------- ##
configure: WARNING:     ## Report this to Christian.Bauer ( ) uni-mainz.de ##
configure: WARNING:     ## ------------------------------------------- ##
checking for xxxxxxxxxx.h... no

All usability checks reported "no" although most of the presence checks reported "yes".

I tried with Fedora 14 and Scientific Linux 6 beta 1, and both were installed as "software development workstations". I had no problems compiling from a 5 (?) year old source files with F14 or SL6b1. (I do not remember where I got the old source files.)


Top
 Profile  
Post a reply  
 Post subject:
PostPosted: Mon Jan 24, 2011 2:36 pm 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 3383
Location: Sittard, The Netherlands
Hi,

I have never compiled with any of the linux distro you mention, but I would suggest you are missing some development packages, and perhaps you are using the wrong version of the automake/autoconf tools (ver. 1.9?)

From memory, you need at least the development packages of:
X11-devel-headers
SDL 1.2.14-devel
Gnome-devel

and of course
GCC
G++

Best,
Cat_7


Top
 Profile  
Post a reply  
 Post subject:
PostPosted: Mon Jan 24, 2011 3:47 pm 
Offline
Student Driver

Joined: Wed Nov 19, 2008 4:58 pm
Posts: 24
Cat_7 wrote:
I have never compiled with any of the linux distro you mention, but I would suggest you are missing some development packages, and perhaps you are using the wrong version of the automake/autoconf tools (ver. 1.9?)

Fedora 14:
- automake (GNU Automake) 1.11.1
- autoconf (GNU Autoconf) 2.66

As I mentioned, Fedora 14 is installed as software development workstation so I think all the necessary and latest tools and libraries should be present. The <*.h> files are present but for some reason, they are not available (usability check returns no). However, they are available for the old Basilisk II source/config that I have.

I googled "Present But Cannot Be Compiled" for the right way to solve the problem but I do not fully understand what I have to do.

I'll download openSUSE (11.3)...


Top
 Profile  
Post a reply  
 Post subject:
PostPosted: Mon Jan 24, 2011 4:18 pm 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 3383
Location: Sittard, The Netherlands
Hi,

I think I know why your headers can't be compiled. Somehow, your build proces uses the wrong compiler. Please check that you have gcc and g++ as default compilers installed. Or use Suse, as you are planning.

See here, at example 4.1: http://www.flameeyes.eu/autotools-mythb ... nding.html

EDIT: I have just installed fedora 14 invmware and compiled basiliskII succesfully. It runs great. That strenghtens my conviction that something is wrong in your development chain of tools. I can't guide you through what you need to install, it is to complicated to remember and thus explain.

Best,
Cat_7


Top
 Profile  
Post a reply  
 Post subject:
PostPosted: Tue Jan 25, 2011 2:30 am 
Offline
Inquisitive Elf

Joined: Mon Feb 16, 2009 1:06 am
Posts: 38
I'm trying to do a 32-bit build for my old laptop running Fedora 14. Sadly, it seems that while the build appears to go well, things crash with an invalid pointer error as soon as I attempt to start emulation after finishing in the config screen.


Top
 Profile  
Post a reply  
 Post subject:
PostPosted: Tue Jan 25, 2011 7:21 am 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 3383
Location: Sittard, The Netherlands
Hi,

Did you not have an error during the configure phase saying that a program that needed to establish whether low memory could be mapped was stopped by selinux?

I had that, and added a rule to selinux (which was suggested in the notification I got) to allow the program to work.
After that, I configured basiliskII again, and built it with only the --enable-jit-compiler=yes option.
It now runs OK.

EDIT: this was the line to set a new rule in selinux: setsebool -P mmap_low_allowed 1


Best,
Cat_7


Top
 Profile  
Post a reply  
 Post subject:
PostPosted: Tue Jan 25, 2011 1:55 pm 
Offline
Inquisitive Elf

Joined: Mon Feb 16, 2009 1:06 am
Posts: 38
Cat_7 wrote:
Hi,

Did you not have an error during the configure phase saying that a program that needed to establish whether low memory could be mapped was stopped by selinux?

I had that, and added a rule to selinux (which was suggested in the notification I got) to allow the program to work.
After that, I configured basiliskII again, and built it with only the --enable-jit-compiler=yes option.
It now runs OK.

EDIT: this was the line to set a new rule in selinux: setsebool -P mmap_low_allowed 1


Best,
Cat_7

I'd already set that for Wine purposes...


Top
 Profile  
Post a reply  
 Post subject:
PostPosted: Tue Jan 25, 2011 7:27 pm 
Offline
Student Driver

Joined: Wed Nov 19, 2008 4:58 pm
Posts: 24
Cat_7 wrote:
EDIT: I have just installed fedora 14 invmware and compiled basiliskII succesfully. It runs great. That strenghtens my conviction that something is wrong in your development chain of tools. I can't guide you through what you need to install, it is to complicated to remember and thus explain.

Did you install Fedora as "Desktop" or "Software Development"?
If you installed as "Software Development", did you install additional tools or libraries?
Did you use a fresh BasiliskII folder? (I.e., one without a configure file so you have to run autogen.sh)

I came up with some kind of workaround: I did not run autogen.sh. Instead, I copied the configure and config.h.in files from an earlier source version. It is possible that some new features or tweaks are missing. But at least now running ./configure a "good" Makefile is produced and I can successfully compile and run BasiliskII.

So my problem is that the autogen.sh script does not produce a good configure file for me.

EDIT:
One step closer to solving the "Present But Cannot Be Compiled" problem (from my ./configure output):
Code:
checking whether we are using the GNU C compiler... no
 --- snip ---
checking whether we are using the GNU C++ compiler... no
But both the gcc and g++ are installed and do compile if the configure file is OK..The problem now is: how do I make autogen.sh (or configure) to find them?


Last edited by uhhu on Tue Jan 25, 2011 10:45 pm, edited 1 time in total.


Top
 Profile  
Post a reply  
 Post subject:
PostPosted: Tue Jan 25, 2011 9:56 pm 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 3383
Location: Sittard, The Netherlands
Hi,

I did a default install from a live cd, and then installed the development packages manually. That why I don't remember what I installed exactly.

I then downloaded the clean source and built it.

Best,
cat_7


Top
 Profile  
Post a reply  
Display posts from previous:  Sort by  
Post new topic  Reply to topic Page 1 of 3 [ 56 posts ]    Go to page 1, 2, 3  Next


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
 

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group