Search found 11 matches

by hyoenmadan
Thu Feb 09, 2017 3:18 am
Forum: QEMU
Topic: GSOC qemu Boot Mac OS >= 8.5 on PowerPC system
Replies: 2056
Views: 816644

Re: GSOC qemu Boot Mac OS >= 8.5 on PowerPC system

Normally,interrupt controller should be in /pci/mac-io.For mac99 it exists there and has some properties.But in g3beige dev tree it is missing.Which is not normal. From this commit to Linux Kernel PROM parser: https://ford.biologie.hu-berlin.de/matze/linux-m68k-atarinommu/commit/6f67f9d26fe5ced50f7...
by hyoenmadan
Wed Feb 08, 2017 2:40 am
Forum: QEMU
Topic: GSOC qemu Boot Mac OS >= 8.5 on PowerPC system
Replies: 2056
Views: 816644

Re: GSOC qemu Boot Mac OS >= 8.5 on PowerPC system

I guess you guys are confusing things again. No "Mac OS ROM" file, from any software revision, can boot Old World machines like the g3beige. Them don't have the necessary code to do it. I though this was clear enough from the last talk. If you really want a G3 class machine model which can boot the ...
by hyoenmadan
Tue Oct 18, 2016 2:01 am
Forum: QEMU
Topic: GSOC qemu Boot Mac OS >= 8.5 on PowerPC system
Replies: 2056
Views: 816644

Re: GSOC qemu Boot Mac OS >= 8.5 on PowerPC system

Again, is the same thing that we have commented before. Sawtooth will not do it for older MacOS versions than 9.1.x or 9.0.x with the special Sawtooth Mac OS ROM file "patch". For these older versions you really need a complete Gossamer g3beige emulated in QEMU (or the Yosemite G3 "blue&white", whic...
by hyoenmadan
Tue Sep 20, 2016 2:09 am
Forum: QEMU
Topic: GSOC qemu Boot Mac OS >= 8.5 on PowerPC system
Replies: 2056
Views: 816644

Re: GSOC qemu Boot Mac OS >= 8.5 on PowerPC system

I'm not entirely surprised. Mac99 is equivalent to a PowerMac G4, but I thought it would boot up with g3beige. You already know it will not work, because g3beige lacks OldWorld ROM loading, absolutely necessary to boot MacOS in g3beige OldWorld architecture (NewWorld boot isn't possible in OldWorld...
by hyoenmadan
Wed Aug 31, 2016 7:04 pm
Forum: QEMU
Topic: GSOC qemu Boot Mac OS >= 8.5 on PowerPC system
Replies: 2056
Views: 816644

Re: GSOC qemu Boot Mac OS >= 8.5 on PowerPC system

Has anyone told him about this? https://github.com/ksherlock/mpw 68k version only it seems. This needs to be updated for PowerPC. In any case, i heard that even Apple switched from MPW to Codewarrior for all their PowerPC development... Probably even if you get MPW running in OSX, you will not be a...
by hyoenmadan
Wed Aug 31, 2016 12:29 pm
Forum: QEMU
Topic: GSOC qemu Boot Mac OS >= 8.5 on PowerPC system
Replies: 2056
Views: 816644

Re: GSOC qemu Boot Mac OS >= 8.5 on PowerPC system

Heh, just thinking out loud.. I don't get all the fuss aboud Old World ROMs copyrights. Sure, they are copyrighted, but who cares? It was abandoned a long time ago, it is abandonware. As long as the ROMs are not in the codebase of the project, are not automatically downloaded or somehow copied into...
by hyoenmadan
Sat Aug 27, 2016 4:33 pm
Forum: QEMU
Topic: GSOC qemu Boot Mac OS >= 8.5 on PowerPC system
Replies: 2056
Views: 816644

Re: GSOC qemu Boot Mac OS >= 8.5 on PowerPC system

To make something work, we'd need to emulate the G3 graphics card, or inject an openfirmware driver for the qemu framebuffer. Injecting a driver would be the better, as we already have one for MacOS9/X in "mac99" profile. I see MoL also injects a sightly modified OF device tree (it has different ve...
by hyoenmadan
Sat Aug 27, 2016 12:49 pm
Forum: QEMU
Topic: GSOC qemu Boot Mac OS >= 8.5 on PowerPC system
Replies: 2056
Views: 816644

Re: GSOC qemu Boot Mac OS >= 8.5 on PowerPC system

0xf30130x0, as it stands, it's the address of the on-board ESCC uart. pointing the escc device at that address and adding a -serial stdio option to the command line, the openfirmware ">" prompt appears. but it's impossible to enter commands . Ofc. In OldWorld Macs you weren't supposed to see the ok...
by hyoenmadan
Thu Aug 25, 2016 9:24 pm
Forum: QEMU
Topic: GSOC qemu Boot Mac OS >= 8.5 on PowerPC system
Replies: 2056
Views: 816644

Re: GSOC qemu Boot Mac OS >= 8.5 on PowerPC system

Pardon me for asking, but wouldn't a Wallstreet/PDQ Powerbook G3 ROM also work with sol. 2 (with a couple of modifications), seeing as it's the only other Mac OS X 10.0+ compatible machine that has an old world ROM? (I know that the Wallstreet has it for sure, not sure about the PDQ.) Not necessary...
by hyoenmadan
Thu Aug 25, 2016 1:40 pm
Forum: QEMU
Topic: GSOC qemu Boot Mac OS >= 8.5 on PowerPC system
Replies: 2056
Views: 816644

Re: GSOC qemu Boot Mac OS >= 8.5 on PowerPC system

It seems to me that what's needed here is to create a New World wrapper that loads the Old World ROM and provides interfaces to it similar to what the OS would be using to access the toolbox. Theoretically, it should be possible; legally, I'm not sure. Clean room implementation would be really tric...
by hyoenmadan
Thu Aug 25, 2016 3:36 am
Forum: QEMU
Topic: GSOC qemu Boot Mac OS >= 8.5 on PowerPC system
Replies: 2056
Views: 816644

Re: GSOC qemu Boot Mac OS >= 8.5 on PowerPC system

:eek: This is just awesome :D I do hope Mac OS X Server 1.2v3 works at some point. I've always wanted to really use Rhapsody but never had the proper setup (on actual hardware). Which build of qemu are you using & what's are you using in the qemu.command file? That wouldn't be possible with the act...