Search found 10 matches

by awado
Sun Jul 26, 2020 12:34 pm
Forum: SheepShaver
Topic: Permissions or sandbox issue in Catalina 10.15.6
Replies: 21
Views: 2113

Re: Permissions or sandbox issue in Catalina 10.15.6

Unfortunately no change. :-(

Well, I think I'm fine with transparency turned on now. So, if it's only me, who's having trouble here, don't worry. Don't want to arouse too many sheeps. But nevertheless, I'm happy to stay for testing, if you want to iron that out.
by awado
Sun Jul 26, 2020 11:08 am
Forum: SheepShaver
Topic: Permissions or sandbox issue in Catalina 10.15.6
Replies: 21
Views: 2113

Re: Permissions or sandbox issue in Catalina 10.15.6

Thanks for this update. Tried the new version. Unfortunately no change here. But I could nail it down a bit further: Beach ball only occurs with an external retina display (28" Samsung). On the internal display everything works fine, no matter which GPU is used, with and without transparencies....
by awado
Thu Jul 23, 2020 6:49 pm
Forum: SheepShaver
Topic: Permissions or sandbox issue in Catalina 10.15.6
Replies: 21
Views: 2113

Re: Permissions or sandbox issue in Catalina 10.15.6

Got it!!! And it's an interesting point: In the accessibility settings I had enabled reduced transparency. As soon as I untick that, Sheepshaver runs. I can reproduce this on my test account. So it seems to be related to graphics driver stuff. (I have a MacBook Pro with a Radeon Pro 450.)
by awado
Thu Jul 23, 2020 8:30 am
Forum: SheepShaver
Topic: Permissions or sandbox issue in Catalina 10.15.6
Replies: 21
Views: 2113

Re: Permissions or sandbox issue in Catalina 10.15.6

Anyway, thank you for your help so far, though. Much appreciated. I'm not aware of anything that makes my account unique. Would Sheepshaver run in safe boot mode (pressing SHIFT at boot)?
by awado
Wed Jul 22, 2020 5:49 pm
Forum: SheepShaver
Topic: Permissions or sandbox issue in Catalina 10.15.6
Replies: 21
Views: 2113

Re: Permissions or sandbox issue in Catalina 10.15.6

Yes. Just saved a TextEdit file in my home folder.
by awado
Wed Jul 22, 2020 5:28 pm
Forum: SheepShaver
Topic: Permissions or sandbox issue in Catalina 10.15.6
Replies: 21
Views: 2113

Re: Permissions or sandbox issue in Catalina 10.15.6

Yes. Tried "xattr -cr" and no success. But interesting observation: I created another user "test" in Catalina and could successfully use Sheepshaver on its desktop. So I put this whole Sheepshaver folder from the desktop into the shared user folder. From the new test user I still...
by awado
Wed Jul 22, 2020 4:35 pm
Forum: SheepShaver
Topic: Permissions or sandbox issue in Catalina 10.15.6
Replies: 21
Views: 2113

Re: Permissions or sandbox issue in Catalina 10.15.6

Still no success. :sad:
by awado
Wed Jul 22, 2020 10:48 am
Forum: SheepShaver
Topic: Permissions or sandbox issue in Catalina 10.15.6
Replies: 21
Views: 2113

Re: Permissions or sandbox issue in Catalina 10.15.6

I get a beach ball. I did it exactly as you wrote. Made a folder on the desktop, moved the application in there and also ROM, dsk, iso. The prefs file was not created. Running it via sudo from there shows the vm instantly. Double clicking shows the beach ball.
by awado
Tue Jul 21, 2020 8:13 pm
Forum: SheepShaver
Topic: Permissions or sandbox issue in Catalina 10.15.6
Replies: 21
Views: 2113

Re: Permissions or sandbox issue in Catalina 10.15.6

Thanks for your answers. Home folder permissions are okay. I already tried Full Disk Access, but doesn't change anything. It was my first idea, too. On the second Mac access settings also where not set and it worked there. Must be something different. There's also no antivirus or application firewal...
by awado
Mon Jul 20, 2020 9:40 pm
Forum: SheepShaver
Topic: Permissions or sandbox issue in Catalina 10.15.6
Replies: 21
Views: 2113

Permissions or sandbox issue in Catalina 10.15.6

After hours of searching and hacking around in terminal I am at loss. I downloaded the latest build of Sheepshaver, unzipped it, placed a valid ROM beside and no matter what I do, it hangs on double clicking. Obviously it seems to be an access problem, because when I start it from terminal with sudo...