Login  •  Register


The time is now: Wed May 27, 2020 9:11 am

Emaculation wiki  •  Delete all board cookies



Post new topic  Reply to topic Page 1 of 1 [ 3 posts ]
Print view Previous topic  |  Next topic
Author Message
PostPosted: Fri May 08, 2020 6:06 pm 
Offline
Student Driver

Joined: Fri Apr 17, 2020 5:39 pm
Posts: 12
My company has some old Power PCs running a custom app developed decades ago. I have been trying to get our application running on an emulator (viewtopic.php?f=1&t=10593&e=0) running on Windows. But, three weeks in, I am at a dead end.

I believe that my company would be willing to pay someone to assist. If anyone is interested, we can renegotiate offline.

Here is the specific details of my project:
The application communicates serially using the SECS protocol (a protocol over serial). I have a laptop connected, running SECS protocol, and I see that the application has sent data to me. The simulator then replies, but the application does NOT seem to see the reply (it should immediately transmit more data upon receiving my reply). I suspect that there is something in the emulator that is buffering my data, or waiting on some kind of handshake/etc. If someone has the ability to build the code, then they may be able to add some log statements to clarify what is happening. I got deep into trying to build the code, but I just kept getting deeper into issues.

I would be able to provide the simulator for you to test against and a bootable HFV file with the application software. I believe that, if we can overcome the serial communication issue, that we would be in business.

Thanks!
Craig


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Wed May 13, 2020 7:42 pm 
Offline
Master Emulator

Joined: Fri Sep 17, 2004 4:22 am
Posts: 360
As I mentioned in your other thread, I would advise you to further investigate hardware problems before tearing your hair out looking for a software problem. See for instance https://superuser.com/questions/682984/ ... ol-support . See also https://www.windmill.co.uk/handshaking.html .

You may also consider an RS232 breakout box, such as https://www.amazon.com/RS232-DB25-BREAK ... B005H46XS2 .

Can I ask what part of the world you're located in?


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Thu May 14, 2020 8:59 am 
Offline
Forum All-Star
User avatar

Joined: Wed Nov 11, 2009 5:47 pm
Posts: 1371
Location: Germany
Good point Jorpho, that breakout box.
I did connect two PCs with built in COM1 ports via null-modem cable.
Mac side: Optiplex 755, Windows 10, Basilisk II B142. PC side: Portégé 7010CT, Windows 98SE.
From my few trials with EP-8000 in Basilisk II B142 and SECSIM in Windows 98SE there are two main obstacles.

1.) The app on the PC side is looking for a dongle plugged into LPT1 to get going.
There is a "unplug.com" to remove that dongle, but I don´t know what that does with the PC app.
2.) SECSIM.exe is looking for a cable device with loopback interface which a plain null modem cable does not offer.
Probably because of that custom cable, EP-8000 on the Mac side can not establish a link to SECSIM.
From the Mac side, there is an error message:
Equipment not responding to "Are you there?". The equipment is either off-line or the SECS-II cable is disconnected.

Thats what happens on my side.
Maybe others with better knowledge about COM interfaces have some advice for Craig.


Top
 Profile  
Reply with quote Post a reply  
Display posts from previous:  Sort by  
Post new topic  Reply to topic Page 1 of 1 [ 3 posts ]


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
 

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group