Switch to full style
About SheepShaver, a PPC Mac emulator for Windows, MacOSX, and Linux that can run System 7.5.3 through MacOS 9.0.4.
Post a reply

Sheepshaver in Mojave

Tue Feb 26, 2019 2:32 pm

I run Sheepshaver v. 2.420120715 (emulating Mac OS 9 v. 9.0.4) on an Intel Mac running High Sierra (MacOS v. 10.13.6). Can I expect SheepShaver to transfer successfully -- all files and other content intact and fully operable -- if I upgrade to Mojave (as Sheepshaver has done on all prior upgrades).

Re: Sheepshaver in Mojave

Tue Feb 26, 2019 3:18 pm

Yes; if it’s already installed, it’ll work.

However, you’ll get nag messages from time to time telling you it’s a 32-bit app. Upgrade to version 2.5 to fix that.

Re: Sheepshaver in Mojave

Tue Feb 26, 2019 3:32 pm

Your SheepShaver build is seven years old! Apparently you never upgraded to newer versions/builds.

As adespoton wrote, it will probably run in Mojave. But better replace it with the latest build before you upgrade the macOS.
See here for the latest 2.5 version build: viewtopic.php?f=20&t=7360

You can simply replace the application with the new application in your existing setup.
If you use the keycodes file, you will also need to replace that file with the new one: http://ronaldpr.home.xs4all.nl/sheepsha ... ycodes.zip

Re: Sheepshaver in Mojave

Tue Feb 26, 2019 3:53 pm

Great advice: I will upgrade asap, and then go to Mojave.
(Probably in a couple days, but I will let you know how it turns out.)
Many thanks!

Re: Sheepshaver in Mojave

Tue Feb 26, 2019 7:29 pm

There are also new options you can set in the prefs file that weren't available under 2.4, so you may want to read the wiki page on here to see if you want to use any of the new settings.
Post a reply