Login  •  Register


The time is now: Tue Jul 23, 2019 4:47 am

Emaculation wiki  •  Delete all board cookies



Post new topic  Reply to topic Page 1 of 1 [ 10 posts ]
Print view Previous topic  |  Next topic
Author Message
PostPosted: Thu Jun 13, 2019 9:33 pm 
Offline
Space Cadet

Joined: Thu Jun 13, 2019 9:20 pm
Posts: 5
I am pulling my hair out. I perused the forum, but don't see my problem discussed.

I am trying to SheepShaver on a MacBook Pro running 10.13.6.

I am using newworld86, and have renamed it Mac OS ROM. When I run sheepshaver, I get the screen with the questionmark disk. I go to preferences and add OS 9.0.4.toast, and click CD-ROM. I have set up a shared folder. I created a 100mb partition. I think...

When I control-escape out of the program and try to relaunch, it quits immediately just like it does when you haven't renamed the newworld86 ROM

I have a screenshot of the preferences page selections, but don't know how to load it to show you. In the screenshot, you can also see the contents of my sheepshaver folder and a copy of newworld86 so you can maybe see what I am missing.

So I guess could you start by telling me how to post the screenshot here?


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Thu Jun 13, 2019 10:08 pm 
Offline
Forum All-Star
User avatar

Joined: Fri Nov 27, 2009 5:11 am
Posts: 2645
Location: Emaculation.com
You need to post it to an image hosting service and reference it here. The forums don't host images themselves.

Are you using the default preferences location?


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Thu Jun 13, 2019 10:23 pm 
Offline
Space Cadet

Joined: Thu Jun 13, 2019 9:20 pm
Posts: 5
Thanks

https://flic.kr/p/2gdHQBK

I have set up the Sheepshaver folder in my downloads folder, didn't work. Then on the desktop, didn't work. Then in the applications folder. Didn't work.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Thu Jun 13, 2019 10:30 pm 
Offline
Forum All-Star
User avatar

Joined: Fri Nov 27, 2009 5:11 am
Posts: 2645
Location: Emaculation.com
The issue wouldn't be with where the application is, but with what's going on in the preferences file.

Go to Terminal.app and type
Code:
open ~/.sheepshaver_prefs

and your configuration will pop up (likely in TextEdit). Looking at your configuration there will likely pinpoint your problem.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Thu Jun 13, 2019 10:32 pm 
Offline
Space Cadet

Joined: Thu Jun 13, 2019 9:20 pm
Posts: 5
disk New.dsk
cdrom /dev/poll/cdrom
cdrom Mac_OS_9.0.4.toast
extfs /Users/Jeff/Desktop/Shared
screen win/1024/768
windowmodes 0
screenmodes 0
seriala
serialb /dev/null
rom Mac_OS_9.0.4.toast
bootdrive 0
bootdriver 0
ramsize 134217728
frameskip 0
gfxaccel true
nocdrom false
nonet false
nosound false
nogui false
noclipconversion false
ignoresegv false
ignoreillegal false
jit true
jit68k false
keyboardtype 5
hardcursor false
hotkey 0
scale_nearest false
scale_integer false
cpuclock 0
yearofs 0
dayofs 0
ether
keycodes false
keycodefile
mousewheelmode 0
mousewheellines 1
dsp /dev/dsp
mixer /dev/mixer
ignoresegv false
idlewait true


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Fri Jun 14, 2019 3:54 am 
Offline
Forum All-Star
User avatar

Joined: Fri Nov 27, 2009 5:11 am
Posts: 2645
Location: Emaculation.com
Gere's your problem:
Quote:
rom Mac_OS_9.0.4.toast


Change that back to Mac OS ROM and you should be good to go!


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Sat Jun 15, 2019 1:05 am 
Offline
Space Cadet

Joined: Thu Jun 13, 2019 9:20 pm
Posts: 5
Unfortunately that did not work. :cry:


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Sat Jun 15, 2019 6:14 am 
Offline
Forum All-Star
User avatar

Joined: Fri Nov 27, 2009 5:11 am
Posts: 2645
Location: Emaculation.com
It should get you your flashing disk back.

You'll also want to fix these:

Code:
ignoresegv false
ignoreillegal false


They need to be set to true.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Sat Jun 15, 2019 8:43 am 
Offline
Expert User
User avatar

Joined: Thu Feb 09, 2006 10:24 pm
Posts: 5461
Location: Amsterdam, Netherlands
Editing the prefs file directly is not advisable, unless you know what you are doing.

When using the built-in SheepShaver Preferences (Virtual Machine Settings window), make the settings like this:

In the Setup tab (the one with the volumes list):
For "ROM File": Browse to and choose your "Mac OS ROM" file.

In the Miscellaneous tab:
Enable at least "Ignore Illegal Memory Accesses" (essential)
You can also enable "Ignore Illegal Instructions" (usually not needed)


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Sat Jun 15, 2019 6:57 pm 
Offline
Space Cadet

Joined: Thu Jun 13, 2019 9:20 pm
Posts: 5
That did it! Thank you! I had the OS9 ROM as the ROM file, but I needed the newworld86 ROM there instead!


Top
 Profile  
Reply with quote Post a reply  
Display posts from previous:  Sort by  
Post new topic  Reply to topic Page 1 of 1 [ 10 posts ]


Who is online

Users browsing this forum: No registered users and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
 

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group