E-Maculation
https://www.emaculation.com/forum/

I was unable to find the file. Please move the file...
https://www.emaculation.com/forum/viewtopic.php?f=20&t=10266
Page 1 of 1

Author:  Gidoza [ Sun Jul 14, 2019 1:38 pm ]
Post subject:  I was unable to find the file. Please move the file...

Hi there.

So when attempting to move files using the file transfer for SheepShaver by dropping the file onto the MacOS9 shortcut on my Windows desktop, OS9 will often give me the following message:

"I was unable to find the file. Please move the file to a different Windows folder and drop it again."

I do move the file to different folders, and it makes no difference.

Any thoughts on what I can do?

I got SheepShaver from here:

http://www.columbia.edu/~em36/macos9win.html


Thank you!
-Gidoza

Author:  emendelson [ Sun Jul 14, 2019 4:25 pm ]
Post subject:  Re: I was unable to find the file. Please move the file...

Try moving the file to your Windows desktop, and then drop it on the MacOS9 icon. The file may e in a folder where my app doesn't have permission (from Windows) to access it.

[Ronald - this probably belongs in the Alternate SheepShaver Configurations folder, because it's about my MacOS9 system for Windows. But perhaps leave it here until the OP gets a change to read it?]

Author:  Gidoza [ Mon Jul 15, 2019 8:17 pm ]
Post subject:  Re: I was unable to find the file. Please move the file...

Hi,

I have moved it to the desktop - it makes no difference.

Cheers,
-Gidoza

Author:  Gidoza [ Mon Jul 15, 2019 8:52 pm ]
Post subject:  Re: I was unable to find the file. Please move the file...

Hi there,

Moreover, any files I'm moving over from my real Mac OS9 computer seem not to work. They all appear as "white folders" no matter what and complain that the "file that created them" could not be found. Simple example: Master of Orion II works fine on my MacOS9, but when I move it to the emulator, it refuses to start and every file is a blank white file, but of the correct size.

Author:  emendelson [ Mon Jul 15, 2019 9:29 pm ]
Post subject:  Re: I was unable to find the file. Please move the file...

Gidoza wrote:
Hi there,

Moreover, any files I'm moving over from my real Mac OS9 computer seem not to work. They all appear as "white folders" no matter what and complain that the "file that created them" could not be found. Simple example: Master of Orion II works fine on my MacOS9, but when I move it to the emulator, it refuses to start and every file is a blank white file, but of the correct size.


Probably you're losing the resource fork when you move the file from the Mac to Windows and then to SheepShaver. That's why the files won't work. You'll need to use something like Stuffit to compress the files on the Mac, and then uncompress the Stuffit archive in SheepShaver. You can find information about this in the forum.

Basically, once you move an UNARCHIVED (not Stuffed, not binhex-ed, not Zipped, etc.) file from any Mac to a Windows machine, you make it unusable, and there's no easy way to fix it. Always archive the file on a Mac system first.

EDIT: Adespoton gave an even better answer while I was writing mine...

Author:  adespoton [ Mon Jul 15, 2019 9:30 pm ]
Post subject:  Re: I was unable to find the file. Please move the file...

Create a disk image on your OS 9 system and copy all the folders into that. Then move the image across to the emulator and mount it (either via emulator prefs, or mount it within the OS). Then copy things over.

When you move Mac files onto NTFS or FAT filesystems, they lose all the metadata associated with the files. So even if they only have a data fork and you don't lose resources, you're still going to lose the file associations.

Author:  Gidoza [ Thu Jul 18, 2019 9:28 pm ]
Post subject:  Re: I was unable to find the file. Please move the file...

emendelson wrote:
Gidoza wrote:
Hi there,

Moreover, any files I'm moving over from my real Mac OS9 computer seem not to work. They all appear as "white folders" no matter what and complain that the "file that created them" could not be found. Simple example: Master of Orion II works fine on my MacOS9, but when I move it to the emulator, it refuses to start and every file is a blank white file, but of the correct size.


Probably you're losing the resource fork when you move the file from the Mac to Windows and then to SheepShaver. That's why the files won't work. You'll need to use something like Stuffit to compress the files on the Mac, and then uncompress the Stuffit archive in SheepShaver. You can find information about this in the forum.

Basically, once you move an UNARCHIVED (not Stuffed, not binhex-ed, not Zipped, etc.) file from any Mac to a Windows machine, you make it unusable, and there's no easy way to fix it. Always archive the file on a Mac system first.

EDIT: Adespoton gave an even better answer while I was writing mine...


Ah. That's easy enough. Will have to start over again with re-plugging in my OS9 and stuffing everything, then I'll let you know what happens. :)

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/