MacOS9 Stuck on "Starting up..."

About SheepShaver, a PPC Mac emulator for Windows, MacOS X, and Linux that can run System 7.5.3 to MacOS 9.0.4.

Moderators: Cat_7, Ronald P. Regensburg, ClockWise

Post Reply
User avatar
Fallentemp
Space Cadet
Posts: 5
Joined: Mon Sep 09, 2019 6:11 am

MacOS9 Stuck on "Starting up..."

Post by Fallentemp »

Greetings. I setup my Sheepshaver emulator a long time ago and everything always worked and i never had any issue until now. Recently i came into a copy of one of my childhood games named Prime Target, managed to make an ISO file that worked inside Sheepshaver that i could use to install it, so i did! Everything worked flawlessly and nothing happened no crashes no nothing and carried on to do so for many days, until yesterday anyway.


When I started it up I left the emulator stationary on the desktop when I came back there was a window up on the top left corner. Sadly I couldn't catch what it said before it finished whatever it was doing, didn't think much of it and continued to play the game... well once i started the game the Emulator prompt up some message about Terminating the application and sheepshaver quits out. Kind of strange and this never happened before.. Starting it back up it says it was verifying OS9 and it completed the First Aid process and the "Starting up" of the OS9 thing showed up.

Well it usually loads pretty fast, almost instant.. except this time the "Starting up..." Wasn't moving at all! i waited for 5 or so minutes when decided to just quit out of it all and try again but the same thing happened.. just hangs there at "Starting up..." completly frozen..

Did something get corrupted? Am i going to have to make a whole new HFV? Or is everything fine and i should just wait it out? sheepshaver doesn't say its not responding so i should i just wait it out?

Any alternative solutions?

Oh and my Host system is Windows 7
User avatar
Cat_7
Expert User
Posts: 5019
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: MacOS9 Stuck on "Starting up..."

Post by Cat_7 »

I have no idea what might have happened.

You might try to boot with extensions off. Press the shift key as soon as the Mac OS splash screen appears.
If that gets you to the desktop, there might be a problem with an extension.
You can then also run disk first aid to see if anything needs repairing.

Further steps could be:
Install a clean Mac OS on a new disk image, and add your current image as second hard disk. Then run disk first aid.
Boot from a CD image with your current image as second disk and run disk first aid.

Best,
Cat_7
User avatar
Fallentemp
Space Cadet
Posts: 5
Joined: Mon Sep 09, 2019 6:11 am

Re: MacOS9 Stuck on "Starting up..."

Post by Fallentemp »

Appreciate the speedy reply! the thing does launch up with the extensions off which i guess would mean there is a conflict or other with one or more extensions.

I've enabled the BASE option in the extension manager but it still gives the same issue. I've then decided to go in deeper and just turn off the others that the base didn't disable itself.

BUT the same issue still occured at the launchup so i have no idea if there is an extension thats hidden out of view from the manager or if the window that had appeared while i left things running was an automatic update and it messed something up..

I did happen to catch a few errors in my attempts which were

"Illegal instruction" but didn't provide an error number
"Error type 6599"
And finally "Error type 10" which had appeared a couple times in my attempts to find the issue. I've never even heard of the 6599 error but the 10 one i have but can't quite remember which it was since its been many many years but what i can recall is it has something to do with the instruction table? i might be wrong
User avatar
Cat_7
Expert User
Posts: 5019
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: MacOS9 Stuck on "Starting up..."

Post by Cat_7 »

Error 10 might be related to 68k instructions.

Did you change anything in the prefs related to 68k emulation?
Can you paste your prefs here?

Best,
Cat_7
User avatar
Fallentemp
Space Cadet
Posts: 5
Joined: Mon Sep 09, 2019 6:11 am

Re: MacOS9 Stuck on "Starting up..."

Post by Fallentemp »

Code: Select all

disk C:\Users\Matt\Desktop\Everything\Sheepshaver\SheepShaver\macos9.hfv
extfs 
screen win/1024/768
windowmodes 3
screenmodes 63
seriala COM1
serialb COM2
rom C:\Users\Matt\Desktop\Everything\Sheepshaver\SheepShaver\CD-ROM drivers\mac_oldworld_rom4mb.rom
bootdrive 0
bootdriver 0
ramsize 1073741824
frameskip 1
gfxaccel true
nocdrom true
nonet false
nosound false
nogui false
noclipconversion false
ignoresegv false
ignoreillegal false
jit false
jit68k false
keyboardtype 5
keycodes false
mousewheelmode 1
mousewheellines 3
ignoresegv false
idlewait false
keycodes false
mousewheelmode 1
mousewheellines 3
enableextfs false
debugextfs false
extdrives CDEFGHIJKLMNOPQRSTUVWXYZ
pollmedia false
etherpermanentaddress true
ethermulticastmode 0
routerenabled false
ftp_port_list 21
portfile0 C:\B2TEMP0.OUT
portfile1 C:\B2TEMP1.OUT
User avatar
Cat_7
Expert User
Posts: 5019
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: MacOS9 Stuck on "Starting up..."

Post by Cat_7 »

Hi,

Please edit your prefs with e.g., notepad and set
ignoresegv true
ignoreillegal true

and try again.

Please note ignoresegv false appears twice, so change it twice.

Best,
Cat_7
User avatar
Fallentemp
Space Cadet
Posts: 5
Joined: Mon Sep 09, 2019 6:11 am

Re: MacOS9 Stuck on "Starting up..."

Post by Fallentemp »

Done and done but the issue persists
User avatar
Cat_7
Expert User
Posts: 5019
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: MacOS9 Stuck on "Starting up..."

Post by Cat_7 »

Hi,

Did you try to check the disk for errors?
If so, and nothing came up, I'm slowly running out of ideas here.
Can you remove the SheepShaver_nvram.dat file and try to boot again?

As a last resort, I would suggest trying another rom file. You are currently running the old world rom.
Check the redundantrobot site and find the new world rom. Add that to the preferences and try with that.

Best,
Cat_7
User avatar
Fallentemp
Space Cadet
Posts: 5
Joined: Mon Sep 09, 2019 6:11 am

Re: MacOS9 Stuck on "Starting up..."

Post by Fallentemp »

Oh hey! managed to fix it!

At first i was ready to give up and just start over from scratch since i tried the newworldrom and it still persisted but then i decided to go back into safemode and disable some of the extensions and by golly did i find it.. for some reason one of the QT extensions was part of the issue. So i just tossed it and now everything is peachy! just gotta put on a new QT

The extension(s) that were the culprit was for whatever reason QuickTime VR and Musical Instruments

Thank you so much for your assistance! it's back to nostalgia tripping for me!
User avatar
Cat_7
Expert User
Posts: 5019
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: MacOS9 Stuck on "Starting up..."

Post by Cat_7 »

Well,

That is frustrating.... I wonder why that happened.

I now assume the window you saw was about the indexer. It runs after some period of inactivity.
It should not interfere with normal operations.

Best,
Cat_7
Post Reply