Sheepshaver will not open - new install

About SheepShaver, a PPC Mac emulator for Windows, MacOS X, and Linux that can run System 7.5.3 to MacOS 9.0.4.

Moderators: Cat_7, Ronald P. Regensburg, ClockWise

Post Reply
ZenecadE
Space Cadet
Posts: 3
Joined: Tue Jan 28, 2020 1:16 pm

Sheepshaver will not open - new install

Post by ZenecadE »

I'm trying to install OS 9 using Sheepshaver on my mid 2012 MacBook Pro but cannot get it to run at all. I have followed all the guides I could find as well as tried with Sheepshaver Wrapper but nothing seems to work. I have tried every ROM I could find for the mid to late 90's but the result remains the same.

The Sheepshaver build I tried is the latest one currently available from Emaculation 2.5 (12 Jan). I put it in a Sheepshaver folder with all the other files (rom, scripts folder etc.) but when I try open, it insta closes...

My host OS is Mojave 14.6. There are no error popups so I don't know what else to give you for help.
User avatar
Ronald P. Regensburg
Expert User
Posts: 6346
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: Sheepshaver will not open - new install

Post by Ronald P. Regensburg »

Probably your rom file is not compatible and/or the rom file is not renamed "Mac OS ROM".

Get the new world ppc rom file from the redundantrobot.com site.
Rename the file newworld86.rom to Mac OS ROM. Do the renaming in the Finder Info panel for the file to be sure the .rom extension is removed and not just hidden.

Put the renamed rom file in the SheepShaver folder, together with the SheepShaver application.

Follow our setup guide: https://www.emaculation.com/doku.php/sh ... os_x_setup
ZenecadE
Space Cadet
Posts: 3
Joined: Tue Jan 28, 2020 1:16 pm

Re: Sheepshaver will not open - new install

Post by ZenecadE »

Hi Ronald. Those instructions were spelled out in many guides as well as some forum posts. I have downloaded that exact rom from redundantrobot and checked in triplicate that the file rename was correct and without any extension, caps in the right places as well as spaces. Extensions are visible on my macbook but I checked with Windows as I have enabled view extensions on that VM for good measure. I also redownloaded all roms from different connections (fibre & LTE) again using a different computer and still the same issue. I know the name is correct and that I have the correct rom because when I use Sheepshaver wrapper, one step is to drag the rom on the program icon. If it is an untested rom, the wrapper will say so but will proceed with whatever it does. If I use the redundantrobot rom, it says that the file successfully copied to the correct location. But running still is an issue :(

Program path= /user/username/desktop/classic/sheepshaver
Scripts path= /user/username/desktop/classic/sheepshaver/sheepshaver scripts
Files in folder: Build history.webloc; keycodes; Mac OS ROM; Setup Manual.webloc; SheepShaver
User avatar
Ronald P. Regensburg
Expert User
Posts: 6346
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: Sheepshaver will not open - new install

Post by Ronald P. Regensburg »

ZenecadE wrote:Program path= /user/username/desktop/classic/sheepshaver
Scripts path= /user/username/desktop/classic/sheepshaver/sheepshaver scripts
Files in folder: Build history.webloc; keycodes; Mac OS ROM; Setup Manual.webloc; SheepShaver
The location of the scripts is irrelevant.
"Files in folder". Which folder is that? Are all files in the folder /user/username/desktop/classic/sheepshaver/ ?

Maybe you moved or copied the sheepshaver folder with all files in it, including the SheepShaver application, to a different location? That may cause unexpected behaviour because of macOS security features. (That is the reason why I distribute the application and the folder separately.)

Try:
- Copy the SheepShaver application out of the sheepshaver folder to the desktop.
- Trash the original application.
- Move the application copy into the sheepshaver folder.
User avatar
Ronald P. Regensburg
Expert User
Posts: 6346
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: Sheepshaver will not open - new install

Post by Ronald P. Regensburg »

Another possible cause of a newly installed SheepShaver not opening:

Did you ever use SheepShaver before, either on this Mac or on a previous Mac from which you migrated to this Mac? Then a 'new' installation of SheepShaver will not run because the old prefs file will still be there.

Run both SheepShaver scripts to remove the old prefs and nvram files.
ZenecadE
Space Cadet
Posts: 3
Joined: Tue Jan 28, 2020 1:16 pm

Re: Sheepshaver will not open - new install

Post by ZenecadE »

Ok, all Sheepshavers were deleted and I ran the scripts. I downloaded the latest version again and moved it to the Sheepshaver folder. It seems to be working now.
Thanks for your help Ronald.
Post Reply