Login  •  Register


The time is now: Sat Jul 11, 2020 2:51 pm

Emaculation wiki  •  Delete all board cookies



Post new topic  Reply to topic Page 1 of 1 [ 5 posts ]
Print view Previous topic  |  Next topic
Author Message
PostPosted: Thu Jun 18, 2020 5:31 pm 
Offline
Space Cadet

Joined: Thu Jun 18, 2020 5:23 pm
Posts: 2
I am trying to paste from Excel (running in Catalina) into DeltaGraph (anyone remember that program?) running in SheepShaver. The first numbers I paste works, but after that, the clipboard doesn't seem to get replaced with anything else I try to copy. Every copy/paste just continues to paste the initially copied numbers. Any thoughts? Am I limited on what I can paste from OS X into OS9 via SheepShaver?


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Thu Jun 18, 2020 5:59 pm 
Offline
Forum All-Star

Joined: Tue Oct 14, 2008 12:12 am
Posts: 1194
This is just a guess, because I can't reproduce the problem:

Try clicking on the SheepShaver desktop after you copy the new material from the host and before you try to paste into SheepShaver.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Thu Jun 18, 2020 8:04 pm 
Offline
Space Cadet

Joined: Thu Jun 18, 2020 5:23 pm
Posts: 2
It appears it may be application dependent. Copy/paste works perfectly in SimpleText, but doesn't work in DeltaGraph for some reason. It just keeps pasting the first thing I copied no matter how many times I try to copy something else.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Fri Jun 19, 2020 10:21 am 
Online
Expert User
User avatar

Joined: Thu Feb 09, 2006 10:24 pm
Posts: 6017
Location: Amsterdam, Netherlands
I explored the various copy-paste options and issues in SheepShaver years ago. I forgot the details, but it does indeed work with some applications and not with other applications. This involves both applications on the host and on the guest system. Also some combinations work and some don't.

What mostly works is using a plain text editor as intermediate, either on the host or on the guest system, or on both, like SimpleText in MacOS and TextEdit (set to plain text) in OSX/macOS.

I noted some workarounds at time, but I forgot what they were as years go by without anyone complaining about copy/paste issues. I will see if I can find that old discussion.


Last edited by Ronald P. Regensburg on Fri Jun 19, 2020 10:22 am, edited 1 time in total.
 


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Fri Jun 19, 2020 10:50 am 
Online
Expert User
User avatar

Joined: Thu Feb 09, 2006 10:24 pm
Posts: 6017
Location: Amsterdam, Netherlands
Found it. The trick is to refresh the clipboard content in SheepShaver/MacOS. That can done by opening the Clipboard window in the Finder. If you leave the Clipboard window open, clicking the desktop will refresh the clipboard content. It worked in 2013, I expect it to still work now. See this post and replies:

viewtopic.php?p=46702#p46702


Top
 Profile  
Reply with quote Post a reply  
Display posts from previous:  Sort by  
Post new topic  Reply to topic Page 1 of 1 [ 5 posts ]


Who is online

Users browsing this forum: No registered users and 20 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
 

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group