SheepShaver Won't Start on 10.15.6, Even With "Mac OS ROM"

About SheepShaver, a PPC Mac emulator for Windows, MacOS X, and Linux that can run System 7.5.3 to MacOS 9.0.4.

Moderators: Cat_7, Ronald P. Regensburg, ClockWise

Post Reply
JMarshallCA
Space Cadet
Posts: 1
Joined: Sun Aug 02, 2020 8:10 pm

SheepShaver Won't Start on 10.15.6, Even With "Mac OS ROM"

Post by JMarshallCA »

So I just got a shiny new MacBook Air with macOS Catalina 10.15.6. I'm looking forward to getting SheepShaver fired up for that classic Mac OS 9 gaming goodness.

I got the latest version on this forum that's notarized to work with Catalina, downloaded the SheepShaver folder, followed all the directions, got a Mac OS ROM file to use. The setup guide explains the program will just quit if it doesn't have Mac OS ROM in the same directory.

Image

So I've got everything ready, fired up SheepShaver, and... it just quits.

I've tried everything I can to get it working. Found "compatible" ROMs everywhere I can, tried switching out Old World and New World ROMs, put the SheepShaver folder in several different directories in case certain ones have restricted file-writing privileges (Desktop, Applications, even an external hard drive), tried dropping the ROM straight into the Resource fork, ran the "delete prefs" script even though this is the first SheepShaver file I've ever put on this Mac. Nothing. Always the same result.

I even got this program called "SheepShaver Wrapper" which supposedly takes care of all this for me. But when I drop the Mac OS ROM on it, according to its instructions, I get this error:

Image

Here's some other pertinent information, if it's relevant:

Image

I've heard someone say Retina-display MacBooks make SheepShaver go crazy, but these errors seem more in line with some screw-up in the program's default options. I'm able to run SheepShaver perfectly fine on my Windows PC, since SheepShaver GUI still runs fine on it. If I could get into SheepShaver's preferences on Mac, I could tell where to find the ROM file, or fiddle with its display options so that the Retina display doesn't make it crash, but it doesn't stay open long enough for that.

What should I do? Did I screw something up, or is this an unanticipated bug? I'd rather not have to resort to QEMU for my Mac OS 9 fix, if I can help it.
emendelson
Forum All-Star
Posts: 1228
Joined: Tue Oct 14, 2008 12:12 am

Re: SheepShaver Won't Start on 10.15.6, Even With "Mac OS RO

Post by emendelson »

The SheepShaver Wrapper issue has nothing to do with SheepShaver, but about the AppleScript wrapper. You might try moving the application to another folder (like your desktop) or using a different ROM file. In fact, both the issues that you describe could result from having the wrong ROM file (or a misnamed ROM file), but that's only a guess.

EDIT: Or you might try the version of the SheepShaver Wrapper that I uploaded a couple of minutes ago. It's just possible that it fixed this problem. I can't reproduce the problem on my own system, so I'm only guessing that the one slight change I made might fix it.
User avatar
Ronald P. Regensburg
Expert User
Posts: 6329
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: SheepShaver Won't Start on 10.15.6, Even With "Mac OS RO

Post by Ronald P. Regensburg »

You will need to use either the Wrapper or a regular SheepShaver setup.

As emendelson notes, your problem could be the ROM file that is either not a compatible rom file or a not correctly named rom file.

- A compatible rom file can be downloaded from the Redundant Robot site. (New world rom best for MacOS 8.5 or 9, old world rom needed if you want to install an earlier MacOS version.)

- The rom file needs to be renamed "Mac OS ROM". From your image I cannot see if the file is correctly renamed, because the file name extension may be hidden. Select the file icon and hit command-I to view Finder Info for the file. If the extension is still there, you can remove it in the Info panel.
Last edited by Ronald P. Regensburg on Mon Aug 03, 2020 7:27 am, edited 2 times in total.
Reason:  
victor46542
Student Driver
Posts: 13
Joined: Thu Nov 28, 2013 11:09 am

Re: SheepShaver Won't Start on 10.15.6, Even With "Mac OS RO

Post by victor46542 »

Hi, I have the same problem. I made a clean install of Mac and tried to take back my sheepshaver with all the configuration and Sheepshaver quit as soon as open it, strange because I take the file from my timemachine save. So I tried to do it again by doing a reinstall. So I went to Redundant Robot site taking the New World PPC ROM and I realize that it got the extension Rom hiding, so rename it with the command I and when I wanted to remove .Rom it said would you like to remove the extension ".rom" and cancel and deleted and I do the deleted to remove the .rom

I really don't know what to do... Maybe when I said deleted the .rom change of format and became unreadable ?
victor46542
Student Driver
Posts: 13
Joined: Thu Nov 28, 2013 11:09 am

Re: SheepShaver Won't Start on 10.15.6, Even With "Mac OS RO

Post by victor46542 »

I've found a video where a person rename the file and doesn't have this problems, I mean the fact that finder warn me about deleting of the extension, so can be this maybe ?

https://www.youtube.com/watch?v=XQAf7GII9NY
User avatar
Ronald P. Regensburg
Expert User
Posts: 6329
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: SheepShaver Won't Start on 10.15.6, Even With "Mac OS RO

Post by Ronald P. Regensburg »

I am sorry, but I am not going to spend time to watch the video.

You wrote that you did a clean install on your Mac and that you took the files regarding SheepShaver from the Time Machine. I am not sure what you did, but if you did not use Time Machine to restore your Mac but instead copied the SheepShaver files over from Time Machine, then you will have lost SheepShaver configuration.

You will need to do the SheepShaver setup again using the files you copied from Time Machine.
Both the ROM file that you took from Time Machine or the one you downloaded should work, but the file needs to be (re)named "Mac OS ROM", indeed without a file name extension.

It is easy to check the file name in Finder Info: Select the file icon and hit Command-I. The Info panel will show the actual name.
victor46542
Student Driver
Posts: 13
Joined: Thu Nov 28, 2013 11:09 am

Re: SheepShaver Won't Start on 10.15.6, Even With "Mac OS RO

Post by victor46542 »

Yes that what I do copy pasting my sheepshaver files from my external harddrive that got my saving version of my mac
My ROM files got no .rom at the end I've check Command-I, it's here (the screen capture) the file I used on my computer before I have done the clean install. [Even the Redundant Robot site ROM, changing the name to Mac OS ROM and without any extension doesn't work]

Image
User avatar
Ronald P. Regensburg
Expert User
Posts: 6329
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: SheepShaver Won't Start on 10.15.6, Even With "Mac OS RO

Post by Ronald P. Regensburg »

Where did you get this file? This is not a ROM file that I know to be compatible with SheepShaver.

1. Get the new world rom file from Redundant Robot and name it "Mac OS ROM".
2. Make sure the rom file is in the same folder as the SheepShaver application.

- Which is the OSX/macOS version on the host?
- Which SheepShaver build do you use?
Last edited by Ronald P. Regensburg on Thu Aug 13, 2020 2:29 pm, edited 1 time in total.
Reason:  
victor46542
Student Driver
Posts: 13
Joined: Thu Nov 28, 2013 11:09 am

Re: SheepShaver Won't Start on 10.15.6, Even With "Mac OS RO

Post by victor46542 »

I've juste done it again and doesn't work, I make sure to modify the name of the files with command I that the extension will be there when I change the name
User avatar
Ronald P. Regensburg
Expert User
Posts: 6329
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: SheepShaver Won't Start on 10.15.6, Even With "Mac OS RO

Post by Ronald P. Regensburg »

You wrote that you did a clean install of your Mac. So I assumed that everything was erased, including your Home folder. But maybe that is not what you did. If you did not touch your Home folder, or if you brought back all of your Home folder from backup, the configuration prefs file will still be there and if the configured path to the rom file is different from the actual path, this will not work.

Exactly what did you do and how did you do it?

And again:
- Which is the OSX/macOS version on the host Mac?
- Which SheepShaver build do you use?
Last edited by Ronald P. Regensburg on Thu Aug 13, 2020 2:47 pm, edited 2 times in total.
Reason:  
User avatar
adespoton
Forum All-Star
Posts: 3068
Joined: Fri Nov 27, 2009 5:11 am
Location: Emaculation.com
Contact:

Re: SheepShaver Won't Start on 10.15.6, Even With "Mac OS RO

Post by adespoton »

Checking that file against https://docs.google.com/spreadsheets/d/ ... Dk7QDyKPY/, it appears that ROM came from a 9.1 or 9.2.2 update image. As SheepShaver only supports up to 9.0.4, this is unlikely to work. Note on that list, the 9.0.4 ROM has a note "most recent to work with SheepShaver". Any ROM later in that list will not work.
victor46542
Student Driver
Posts: 13
Joined: Thu Nov 28, 2013 11:09 am

Re: SheepShaver Won't Start on 10.15.6, Even With "Mac OS RO

Post by victor46542 »

Ronald P. Regensburg wrote:You wrote that you did a clean install of your Mac. So I assumed that everything was erased, including your Home folder. But maybe that is not what you did. If you did not touch your Home folder, or if you brought back all of your Home folder from backup, the configuration prefs file will still be there and if the configured path to the rom file is different from the actual path, this will not work.

Exactly what did you do and how did you do it?

And again:
- Which is the OSX/macOS version on the host Mac?
- Which SheepShaver build do you use?
Mac 10.15.6, Sheepshaver 2.5 the latest one
Yes I erased everything, then I copy paste some folder to my mac that was on a drive that I used from TimeMachine. I thought at first it was in a different path so download the one from Redundant Robot site, the recommended rom (New World PPC ROM (best for SheepShaver)) and renamed it and I make sure the .rom wasn't there

I have the feeling that removing the .ROM change the file and make it no a .ROM anymore as it tell me it's textedit document now
User avatar
Ronald P. Regensburg
Expert User
Posts: 6329
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: SheepShaver Won't Start on 10.15.6, Even With "Mac OS RO

Post by Ronald P. Regensburg »

victor46542 wrote:I have the feeling that removing the .ROM change the file and make it no a .ROM anymore as it tell me it's textedit document now
No, SheepShaver doesn't care about the extension. If there is no pre-existing configured setup, SheepShaver will only recognise a compatible rom file that has the exact name Mac OS ROM" without file name extension. The new world rom file from Redundant Robot is compatible.

If SheepShaver will not run when placed in the same folder with a compatible "Mac OS ROM" rom file, there are several possible causes that I can think of.

For first possible cause, try this:
- Make a copy of the SheepShaver application in a different location (can be your desktop)
- Delete the original application
- Move the copy back to where the original was
- Launch the copy
victor46542
Student Driver
Posts: 13
Joined: Thu Nov 28, 2013 11:09 am

Re: SheepShaver Won't Start on 10.15.6, Even With "Mac OS RO

Post by victor46542 »

Oh fantastic ! It works !

Many many many many thanks !
Post Reply