Page 1 of 1

Sheepshaver and a bag of problems :(

Posted: Thu Aug 27, 2020 11:14 pm
by pumpkinspacelatte
Hi there! I'm new to Mac emulations so this is all like Portuguese to me. Hold on its a bumpy ride. :lol:

I'm currently on Mac OS 10.14.16, I've been attempting to play Jumpstart 4th grade haunted island, and run it on OS 7.5 (which I'm starting to wonder may be the problem). I first downloaded basilisk II but for the life of me I couldn't get the game to play, it wouldn't mount. I tried placing the game in the hard drive and have stuffit open the .sit file, took a whole hour and nothing happen. I did it twice. This took 8 hours lmfao.

This morning I tried Sheepshaver with more luck, I was able to have the game properly mount on my desktop, but got frequent error 10s whenever I launched the game. When I loaded the "jumpstart update" in the folder, it let me proceed with the game. Played the game for an hour, and at certain points of the game it would crash. In three play attempts, it crashed in two spots, one spot twice. Okay whew. Tried to do what I did on basilisk, got the game in the hard drive, and again attempted to have stuffit open it, and did the same as basilisk. I'm guessing its the file, or I'm doing something obscenly wrong.

TLDR: Game keeps crashing at certain points, frequent Error 10s, also can't get the game to properly download in the system, it's just a disc on the "desktop".
Can anyone help me out? :(

Re: Sheepshaver and a bag of problems :(

Posted: Fri Aug 28, 2020 7:43 am
by Ronald P. Regensburg
1. Did you install SheepShaver from the downloads here and did you follow our setup guide?

2. From where did you download the game?

3. Exactly how (step by step) did you get the game into SheepShaver?

Re: Sheepshaver and a bag of problems :(

Posted: Fri Aug 28, 2020 9:57 pm
by pumpkinspacelatte
1. Installed Sheepshaver from this forum and followed the e-maculation Sheepshaver guide this website, yes! It does run, and I can install stuffit 5.5 and I was able to install Mac OS 7.5 as well.

2. I have downloaded it from Macintosh Garden, and wondering if that was funky I downloaded a copy from Macintosh Repository as well. The Macintosh Garden SIT file will not "unstuff" when I'm in Sheepshaver. But I am able to mount the ISO file from the Macintosh Repository, with finagling, but it crashes midgame.

3. The first way: I was able to mount the ISO file in sheepshaver preferences under add, clicked on the CD rom checkoff. Ran Sheepshaver, the game was on my desktop, there was no "install" option, so I just ran the game at first and got the error. 10 message. I looked through the folder that opened to see if perhaps I just missed the install option, and there was just "install updates" which contained jumpstart 2nd grade and 3rd grade, those updated just fine and said I needed to create a new game or something, and that it was unable to run it on the disc alone. Went through with it. Then I was able to run the game? But as I said it crashed at a certain point, three times. (as I write this out I'm starting to think was I suppose to drag the stuff from this disc onto my "hard drive"?)

The second way was the way I attempted on basilisk, and had seen various youtubers do. Put the .sit file in my shared folder, booted up Sheepshaver, moved the sit file to my hard drive. My stuffit has been downloaded and is apart of my "hard drive", opened the .sit through stuffit, and it takes an hour for it "unstuff" and literally nothing happens. The files are nowhere to be found. I tried it again and nothing to be found.

Hope this made sense!!

Re: Sheepshaver and a bag of problems :(

Posted: Fri Aug 28, 2020 10:36 pm
by Ronald P. Regensburg
The "first way" is the right way, also for BasiliskII. When software comes on an archived (stuffed) disk image, you unstuff the sit archive on the host and then you add the image file to the volumes list in SheepShaver preferences or in BasiliskII GUI.

I tried the one from Macintosh Garden in SheepShaver.
There is no installer and there are no instructions to install it in any other way to your HD image. I did not see updaters on the disk.

The way it looks, it is a game on CD that you are supposed to run from the CD as it is. I tried that and it started fine. I did not get an error message, but maybe that would have come later.