Page 1 of 1

X-Wing CD crashes upon entering space flight

Posted: Wed Oct 28, 2020 11:42 pm
by sndwv01
I am trying to get X-Wing Collector's CD-ROM running on SheepShaver on W7x64 (I know performance will be an issue). I added a read-only .toast file of the game CD as a volume for SheepShaver, and copied an install folder (tried all sizes) from the mounted .toast to a System 7 hard disk. So far so good, the game starts. But as soon as I enter the space flight part of the game I get an error stating that my installation has become corrupt, and the game exits. Does anyone recognise this issue and know a solution? TIE Fighter CD-ROM does work fine using this method.

In case it matters: I do own both games games (sealed boxes- would be happy to provide evidence), but have no way to use the actual discs anymore. Above has been tried with the .toast file from Macintosh Garden, and also a couple of others I was able to find online.

Re: X-Wing CD crashes upon entering space flight

Posted: Thu Oct 29, 2020 12:23 pm
by 24bit
I did copy over the .toast to a emulated Mac HDD and mounted it with ... cd-utility
Using the X-Wing Max Install folder, I can get onto the X-Wing fighter for training - is that where the game quits on your side?

You nay know that SheepShaver for Windows accepts CD/DVD media in your optical drive again.
The Vritual DVD/CDROM Utility should serve the same purpose though.
Usually it should suffice to check the .toast file as read only in the SheepShaver prefs, but this game seems to be picky.

On a side note, as you happen to own the original media, would you consider uploading the manual(s) to Macintoshgarden, please?

Re: X-Wing CD crashes upon entering space flight

Posted: Fri Oct 30, 2020 7:44 pm
by sndwv01
Thanks for your reply!

Ok, it was basically user error... Sections like the training course were indeed where it was crashing for me. Reason I tried adding the .toast as a volume to SheepShaver directly was because I thought Virtual DVD did not recognize the image. Turns out it does, but it needed opening via it's GUI explicitly- I was used to dropping images on the program icon, which usually works, but not with (this) .toast. Game works just fine now, if a bit choppy of course.

If I ever open up my Mac copy I'll be sure to add scans of the manual, but for now I'm keeping it sealed as part of the collection.