Mac OS 9 Connections CD Images Won't Mount

About SheepShaver, a PPC Mac emulator for Windows, MacOS X, and Linux that can run System 7.5.3 to MacOS 9.0.4.

Moderators: Cat_7, Ronald P. Regensburg, ClockWise

Post Reply
mrcow
Space Cadet
Posts: 2
Joined: Thu Nov 19, 2020 6:53 pm

Mac OS 9 Connections CD Images Won't Mount

Post by mrcow »

Downloaded Connections CD 1 and 2 from Macintosh Garden (https://macintoshgarden.org/games/connections) also tried other main repository, forgetting its name.

I can't mount either CD image in toast -- couldn't complete the last command because there was an I/O error. Result code = -36.

I can't mount either CD image from the volumes list in the sheepshaver GUI -- nothing happens. No CDs are mounted when I boot up.

I tried locking the files from Finder. That changed nothing.

I can't mount either CD image in Virtual CD/DVD-ROM Utility -- there are insufficient system resources to mount this image.

Any ideas? Has anyone gotten Connections to run successfully on Mac OS 9.0.4 (or other versions of 9)?

Has anyone gotten Connections to run in any way on SheepShaver?
mrcow
Space Cadet
Posts: 2
Joined: Thu Nov 19, 2020 6:53 pm

Re: Mac OS 9 Connections CD Images Won't Mount

Post by mrcow »

I went and created and installed 7.6, and managed to mount the images by the SheepShaverGUI menu. The game started, but any animation instantly crashed SS.

Then, I took what I learned, and managed to make the images mount from the SheepShaverGUI menu alongside my 9.0.4 disk/image/OS. There is some crazy thing in Windows 10 where the SheepShaverGUI.exe that you load from the Start menu is NOT the same as the SheepShaverGUI.exe that you load from Windows Explorer. How bizarre.
User avatar
adespoton
Forum All-Star
Posts: 3105
Joined: Fri Nov 27, 2009 5:11 am
Location: Emaculation.com
Contact:

Re: Mac OS 9 Connections CD Images Won't Mount

Post by adespoton »

mrcow wrote: Thu Nov 19, 2020 7:55 pm I went and created and installed 7.6, and managed to mount the images by the SheepShaverGUI menu. The game started, but any animation instantly crashed SS.

Then, I took what I learned, and managed to make the images mount from the SheepShaverGUI menu alongside my 9.0.4 disk/image/OS. There is some crazy thing in Windows 10 where the SheepShaverGUI.exe that you load from the Start menu is NOT the same as the SheepShaverGUI.exe that you load from Windows Explorer. How bizarre.
Where are you getting your copy of SheepShaver from?
User avatar
Cat_7
Expert User
Posts: 5103
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: Mac OS 9 Connections CD Images Won't Mount

Post by Cat_7 »

You might check where the entry in your start menu is actually pointing to. Is it pointing to the GUI in a old SheepShaver folder?
I have no recollection of any SheepShaver package containing an installer that would put an entry in the start menu. Did you put it there yourself?

If you are now using the september 2020 download, you might update the start menu entry.
Or, if things work to your satisfaction from the SheepShaver folder remove the entry in the start menu completely.

The Connect_1 and Connect_2 isos are working fine with my SheepShaver OS9 installation on my Windows system. I just add them as second and third entries in the volumes list.
How did you unpack them? I see the first one is a zip file containing a 7zip file so I had to unpack it twice.

Best,
Cat_7
Post Reply