Gene

About SheepShaver, a PPC Mac emulator for Windows, MacOS X, and Linux that can run System 7.5.3 to MacOS 9.0.4.

Moderators: Cat_7, Ronald P. Regensburg, ClockWise

Post Reply
Rachel
Space Cadet
Posts: 2
Joined: Sun Mar 14, 2021 10:47 pm

Gene

Post by Rachel »

I have used Sheep Shaver to run Gene on every machine I've owned since OS9.
https://www.ics.uci.edu/~eppstein/gene/release.html

Today I have a MacBook Pro running Big Sur (11.2.2).

I have successfully installed and run Sheep Shaver.

I have transferred Gene 4.3.4 to the OS9 hard drive and I can successfully launch Gene 4.3.4 and create new files.

I cannot get Gene to open my existing Gene files. This has never been a problem with previous computers/OS's. I can't even get Gene to see the files, even when I uncheck "Only show Gene files".

The workaround I came up with was to open a new Gene file, type in one person name, and save the file. I then used a text editor to copy all my data into that file overwriting the one name. When I try to open that file, the error says "No Field Description (-306); Line: 2. File read aborted; creating a new database." I also tried importing but I get an GEDCOM error.

Is anyone aware of what might have changed with my current machine or OS that is causing me to be unable to read the Gene files I've been using since 1997? Is there a fix please?
User avatar
Cat_7
Expert User
Posts: 5380
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: Gene

Post by Cat_7 »

Hi,

I gather you did a new and clean installation of SheepShaver and Mac OS 9 on your current machine?
Which SheepShaver version are you using?

How did you transfer your data (gene) files to the new machine? Where are they now?
How are you trying to access them from within Mac OS in SheepShaver? Are they perhaps on the Unix drive?

Do you still have the old installation on your earlier machine? If so, can you not copy the whole old SheepShaver hard disk to the new machine?

Best,
Cat_7
Rachel
Space Cadet
Posts: 2
Joined: Sun Mar 14, 2021 10:47 pm

Re: Gene

Post by Rachel »

I did a clean install. My files are not on the Unix drive. I copied them into the Mac HD folder and onto the desktop. I tried every variation I could think of. SheepShaver works fine. Gene works fine. Only reading my old files does not work. I thought people might know of what problem is causing this and have a workaround. I will see if I can copy the whole folder, thanks.
User avatar
Ronald P. Regensburg
Expert User
Posts: 6781
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: Gene

Post by Ronald P. Regensburg »

Were the old files always saved and kept on HFS or HFS+ formatted disks?
Post Reply