SheepShaver crashing on launch

About SheepShaver, a PPC Mac emulator for Windows, MacOS X, and Linux that can run System 7.5.3 to MacOS 9.0.4.

Moderators: Cat_7, Ronald P. Regensburg, ClockWise

Post Reply
jondesu
Space Cadet
Posts: 1
Joined: Wed Mar 17, 2021 9:00 pm

SheepShaver crashing on launch

Post by jondesu »

I'm running SheepShaver 2.5 in macOS Big Sur, and I got it set up and functioning great for a little while, running some games in OS 9 (my main purpose for setting it up in the first place). Then, it crashed, and now it doesn't display a window on launch and automatically crashes. I zapped the PRAM with the script in the folder, no change, and then deleted the prefs and got it to open but of course not boot. I pointed it back to the ROM and hard drive image (OS9.dsk) and it went back to crashing at startup, no window ever displayed. Below is my prefs file contents, but of course it was working with the same prefs I think before (I don't believe I changed anything when it crashed):

Code: Select all

disk OS9.dsk
cdrom /dev/poll/cdrom
extfs share
screen win/640/480
windowmodes 0
screenmodes 0
seriala 
serialb /dev/null
rom Mac OS ROM
bootdrive 0
bootdriver 0
ramsize -2147483648
frameskip 8
gfxaccel true
nocdrom true
nonet true
nosound false
nogui false
noclipconversion false
ignoresegv true
ignoreillegal true
jit true
jit68k false
keyboardtype 5
hardcursor true
hotkey 0
scale_nearest false
scale_integer false
cpuclock 0
yearofs 0
dayofs 0
mag_rate 0
swap_opt_cmd false
ether 
keycodes false
keycodefile 
mousewheelmode 1
mousewheellines 3
dsp /dev/dsp
mixer /dev/mixer
idlewait true
Appreciate any help!
User avatar
Ronald P. Regensburg
Expert User
Posts: 6674
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: SheepShaver crashing on launch

Post by Ronald P. Regensburg »

Something went completely wrong with the settings for RAM Size. I do not know how this could have happened.

It is a negative value, but if the minus is removed it is still tot right, something like 2000MB, much too large.

Open the prefs file in TextEdit and carefully change the line

Code: Select all

ramsize -2147483648
to

Code: Select all

ramsize 536870912
then close and save the file.
Post Reply