Page 1 of 1

Nothing boots...

Posted: Tue Jan 11, 2005 3:22 am
by DittoBox
Not my old B2 DSK's, not my OS 8.0 CD, nothing!

I'm using new world rom(s) from tomes found under newer 8.6+ updates.

When using the CD to boot it stops spinning entirely after a little while and sits there at the "Welcome to Mac OS" screen, it won't even show the scroll bar.

Any ideas? Thanks!

EDIT: I've got a Mac Performa 5215cd, but there's no way to get the ROM off of it (no ethernet, only a 1.44mb floppy), and I don't have dial up access anymore so I screw my chances of uploading a file via ftp...besides the fact that nubus (I think this is a nubus mac) roms aren't supported. :(

Posted: Tue Jan 11, 2005 4:33 am
by ataxy
post the content of your pref file

Posted: Tue Jan 11, 2005 7:01 am
by DittoBox
disk /home/nallworth/MAC/Os8.1.dsk
extfs /home/nallworth/MAC
windowmodes 3
screenmodes 0
seriala /dev/tts/0
serialb /dev/tts/1
rom /home/nallworth/MAC/1.6.rom #I've used a 1.0.rom, and an iMac.rom
bootdrive 0
bootdriver -62
ramsize 33554432
frameskip 1
gfxaccel true
nocdrom false
nonet false
nosound true
nogui false
noclipconversion false
ignoresegv true
jit true
jit68k true
keyboardtype 5
keycodes false
mousewheelmode 1
mousewheellines 3
dsp /dev/sound/dsp
mixer /dev/sound/mixer
ignoresegv true
idlewait true

Posted: Tue Jan 11, 2005 8:26 am
by Cat_7

If you are trying to run sheepshaver for windows, then you should use mac os 8.5 to 9.0.4 and the rom file from the mac rom update 1.0

others don't work.


Posted: Tue Jan 11, 2005 11:46 am
by TheBigB
well i try to figur out sheepshaver myself but he doesn't have the windows version unless he's a complete n00b because he has unix paths in his config and he seems to know where they go so he has the linux version. anyway this is my best help effort. as i said i try to figure it out myself.
EDIT: i actually can help more. i looked up your mac on and, unlike the performa 6116CD under my monitor your mac has a pds slot., not a nubus slot. it has a 4mb rom too and can run up to 9.1 so i think this is the rom sheepshaver supports. your problem isn't a rom problem though.
EDIT2: try setting the boodriver command to 0 if you want to boot from a hard disk image.

Posted: Tue Jan 11, 2005 8:56 pm
by DittoBox
I'm on Gentoo Linux with Kernel 2.6.9 with gentoo patchset, and I've tried using the gui to set booting from disk or CD, both freeze up at the "welcome to mac os" screen (before it loads the background image and begins loading extensions and such...that means the progress bar underneath where it says "welcome to mac os" in the chicago font doesn't show up yet).

And when I read this after searching for linux and performas (I wanted to see how well linux would work on it, then I decided to just use it as-is with os8.1), that's what made me think it was a nubus based mac.

Anyway, thanks I'll play around some more. BTW, I'm using a CVS grab from yesterday afternoon, though I did grab CVS about a month and a half ago and it acted the way.

I tried booting the following OS disks built under Basilisk-II(one with JIT if that makes any difference)

8.0 (very minimal)
8.0 (full)
And after an update to 8.1 of the last two such luck.

I then tried the CD of 8.0 and it didn't work there either.


Posted: Tue Jan 11, 2005 11:29 pm
by Slice
You could format a floppy using HFS (even use the PowerMac to format it), copy to it the software required to grab the ROM from the PowerMac, run said software on said PowerMac, saving to the floppy the extracted ROM from said PowerMac, then copy the ROM back from the floppy to your PC.

Since you're running Linux you should be able to simply specify the file system when mounting the diskette.*

* I have never actually tried using HFS-formatted media on Linux before though, so please excuse me if it is not this simple. ;)

Posted: Wed Jan 12, 2005 7:18 pm
by DittoBox
Alrighty, I've compiled the kernel to support (just module actually) HFS and HFS+ disks, we'll see how it does now. My only problem is that the ROM file is 4 meg, but I think I can use some sort of disk tool to span the file over multple disks.

My only problem is I've only got one disk (we moved into a rental temp. so most of my crap is packed at a storage garage) :lol:

EDIT: Can anyone point me in the direction of disk image-like app that splits files so that they can span more than one disk? It's a 4 meg rom so 3 disks is sufficiant, I just need something to spilt it!

Posted: Wed Jan 12, 2005 10:00 pm
by Cat_7

Before you try to run that rom file, you could check here: ... ow_to.html

to see if the rom file is supported in the Linux version of SheepShaver

Best wishes

Posted: Wed Jan 12, 2005 10:52 pm
by DittoBox
So Old-world rom files won't work?

I was able to zip the 4mb rom file to 1.6mb, then spilt it using zip-it, I'm going to unzip it in a sec here...crap it doesn't want to unzip with "unzip" or tugzip under windows. :S

Keeps asking me for the last disk even when it's in, these are fat disks too.

Posted: Wed Jan 12, 2005 11:00 pm
by DittoBox
I get this when turning off JIT:

$ ./SheepShaver
SheepShaver V2.2 by Christian Bauer and Mar"c" Hellwig
Reading ROM file...
Detected CPU features: MMX SSE
PowerPC CPU emulator by Gwenole Beauchesne
pc 0x80be515
ea 0x10372004
r0 00000000 r1 217f7afc r2 00000000 r3 21800400
r4 00002278 r5 00006604 r6 00004e75 r7 ffffffe8
r8 00000000 r9 00000028 r10 0000006c r11 210074b2
r12 ffffffff r13 00000000 r14 200031c4 r15 20ffec00
r16 200c2cb8 r17 000013ff r18 200c1fd8 r19 40814c1e
r20 217f7b0e r21 21800190 r22 21800400 r23 00000000
r24 00001401 r25 00000020 r26 00000000 r27 ffff876e
r28 00000000 r29 40df1200 r30 40c60000 r31 68fff000
f0 0.00000 f1 0.00000 f2 0.00000 f3 0.00000
f4 0.00000 f5 0.00000 f6 0.00000 f7 0.00000
f8 0.00000 f9 0.00000 f10 0.00000 f11 0.00000
f12 0.00000 f13 0.00000 f14 0.00000 f15 0.00000
f16 0.00000 f17 0.00000 f18 0.00000 f19 0.00000
f20 0.00000 f21 0.00000 f22 0.00000 f23 0.00000
f24 0.00000 f25 0.00000 f26 0.00000 f27 0.00000
f28 0.00000 f29 0.00000 f30 0.00000 f31 0.00000
lr 40df1200 ctr 00000000 cr 40501c22 xer 00000000
pc 40df1200 fpscr 00000000

Posted: Thu Jan 13, 2005 7:37 am
by DittoBox
I copied the 4 meg rom file off my Performa and SS complains that the rom is "unsupported".

New World roms will have to do I 'spose.

EDIT: is it possible to use a new world rom, with old world software (8.0/8.1)?

Also, if my old world rom isn't supported under linux-SS (Performa 5215cd), can I get a list of machines that do work? Or am I better off finding an 8.6-9.0.4 disc?

Posted: Fri Jan 14, 2005 3:39 pm
by PPC_Digger
DittoBox wrote:EDIT: is it possible to use a new world rom, with old world software (8.0/8.1)?
No, since new world ROMs rely on the OS to provide the routines they lack, and no Mac OS version before 8.5 (except the special-version original iMac OS 8.1) does.

Posted: Sat Jan 15, 2005 6:29 pm
by DittoBox
I guess I'll have to grab 8.5 or 6 somewhere, maybe 9 eh?

Thanks for the info!

Posted: Sun Jan 16, 2005 2:21 am
by DittoBox
Another question, I've used getrom to grab the rom off my oldworld PPC mac (4mb rom) but it doesn't seem to work. When I did this I didn't disable extensions on boot, so that may be my problem. That or the zip application I used to get zip it 1.6 meg, and then split it into two files that I could write to two floppies didn't work correctly...or something. I'll try it again a little later but...

Since my mouse (maybe it's the keyboard, since ADB mouse runs through keyboard) crapped out a couple of days ago I ordered a used mouse+keyboard off ebay (I couldn't find any new keyboards anywhere!).

So once my new mouse and keyboard come I'll grab the rom again with extenstions off and see if that works.

If there's any OldWorld/PPC rom retrieval instructions, let me know!!