E-Maculation
https://www.emaculation.com/forum/

SheepShaver on OSX
https://www.emaculation.com/forum/viewtopic.php?f=20&t=2501
Page 1 of 1

Author:  Fred_Dagg [ Wed Jan 19, 2005 11:08 am ]
Post subject:  SheepShaver on OSX

I have installed SS v2.2 binary (Gwenole) on my eMac running OS 10.3.7.
I followed Howard Spoelstra's user guide advice and extracted the ROM file from MacOS ROM Update 1.0. I got a named file but its icon was missing.

Double clicking the SS icon produced no noticeable result but if I opened the package and double clicked the unix executable of SS I got the following "Completed Command" report but no persistent SS window.

My-eMac:~] Mine% /Users/Mine/SheepShaver.macosx/SheepShaver.app/Contents/MacOS/SheepShaver; exit
SheepShaver V2.2 by Christian Bauer and Mar"c" Hellwig
Paranoia checks...
...passed
Reading ROM file...
[ at this point a small black screen appeared and then disappeared followed by the text below]

VOSF acceleration is not profitable on this platform, disabling it
### No appropriate blitter found
R/G/B mask values : 0x007c00, 0x0003e0, 0x00001f (depth = 16)
R/G/B shift values : 10/5/0
Abort
logout
[Process completed]


Can anyone advise me what to do now?

Author:  gb [ Wed Jan 19, 2005 8:12 pm ]
Post subject: 

Try this binary:
<http://gwenole.beauchesne.free.fr/sheepshaver/files/SheepShaver.macosx.20050119.tar.bz2>

Are the colors OK?

Author:  gb [ Wed Jan 19, 2005 8:31 pm ]
Post subject: 

Well, it appears to work, at least on my PBG4.

Author:  trexplorer [ Thu Jan 20, 2005 1:30 am ]
Post subject: 

I can't get it to start (app starts and then quits - no window). Using same hard file and new world rom as on my PC ...

Can you post your config file and does the file need to be named as ".sheepshaver_prefs" or should the "period" be removed.

Do any special packages need to be installed on OSX 10.3.7 ... ?

Thanks.

Author:  trexplorer [ Thu Jan 20, 2005 4:45 am ]
Post subject: 

Got it working - preference file was not placed in user root ...

Works great very stable ... and pretty quick on iMac G4 1.33 mHz.

Only problem I had was monitor res set to 800 x 600 (gave garbled screen at boot - had to figure out how to change res "the hard way").

Works fine now in 1024 x 768 (used windowmodes 7)

cheers ...

Author:  Fred_Dagg [ Thu Jan 20, 2005 10:14 am ]
Post subject:  SheepShaver on OSX

Thank you gb for your quick response, the new download improved things.javascript:emoticon(':)')
But it is still not working well.
Here is what happened:
On startup a black screen followed by a gray screen then a message "SS has unexpectedly quit".
With an OS 9.0.4 cd in the drive the OS9 booted up anyway in full colour behind the "......quit" error message." (which could be cancelled).
I was able to install OS9 onto the designated "Hard Drive" but could find no way to make it the start up drive.
There was no SheepShave preference selection window as per Spoelstra's user guide.
Once again I'm stuck.javascript:emoticon(':?:')
What must I do to set my hard drive as startup?
and why can I not get the preference window? [/b]

Author:  Fred_Dagg [ Fri Jan 21, 2005 4:40 am ]
Post subject:  Sheepshaver on OSX

Updating my questions.
SheepShaver is running brilliantly when booted off the OS9 CDRom. its speed is impessive.

I've found the Read Me for Basilisk II and now think I understand the configuration file.
But where can I find a list of the possible settings ??

i still have not figured how to get SheepShaver booting of my system HD instead of the CD. Am I missing something obvious?

:)

Author:  Cat_7 [ Fri Jan 21, 2005 8:36 am ]
Post subject: 

Fred,

Maybe this helps:
http://www.ou.nl/open/hsp/Engels/SheepS ... ttings.htm

To change the order sheepshaver boots just place the image you want to boot from first in the config file.

You could also try to disable the cdrom.

Best wishes
Cat_7

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/