SheepShaver for Windows #3 -Test Build!

About SheepShaver, a PPC Mac emulator for Windows, MacOS X, and Linux that can run System 7.5.3 to MacOS 9.0.4.

Moderators: Cat_7, Ronald P. Regensburg, ClockWise

Mac Emu
Forum All-Star
Posts: 1217
Joined: Mon May 20, 2002 11:50 am
Location: Ouraion

SheepShaver for Windows #3 -Test Build!

Post by Mac Emu »

Gwenole posted a test build of SheepShaver 2.2 (release #3) for Windows. For the first time, I have JIT working on my Athlon XP and it is 400%+ faster (see quick APD benchmarks on the OS Emulation forum). And it's responsive too!

Download the test beta here: http://gwenole.beauchesne.online.fr/she ... .win32.zip (edited to reflect newer binary)
Last edited by Mac Emu on Wed Mar 23, 2005 11:36 am, edited 3 times in total.
Neospy
Mac Mechanic
Posts: 186
Joined: Mon Jul 05, 2004 10:49 pm
Location: Woodway, Texas, USA
Contact:

Post by Neospy »

YES!!!! New sheepshaver edition with JIT that isn't buggy. It's like a dream come true. Too bad it isn't an official release yet... just a test


>neospy 8)

*rushes off to tinker with SheepShaver 3!
AZEnigma
Student Driver
Posts: 19
Joined: Tue Nov 16, 2004 10:43 pm

Post by AZEnigma »

The random crashes have gone away on my Pentium-M laptop, and the speed is pretty good (although video is a bit laggy, even when skip set to 0).

Any one else having problems when using Quicktime. If I try to play the sample clip, or even use the quicktime picture application, sheepshaver closes without an error. Also CD's do not seem to load correctly if inserted after OS 8.6 boots, but mount fine if inserted before starting sheepshaver (It tells me the disc needs to be formated).
ataxy
Master Emulator
Posts: 377
Joined: Sun Jan 25, 2004 3:49 pm
Location: Canada
Contact:

Post by ataxy »

wow nice at last i can use jit with no bug havent tried QT so cant say yet if it bugs
AZEnigma
Student Driver
Posts: 19
Joined: Tue Nov 16, 2004 10:43 pm

Post by AZEnigma »

Downgraded to quicktime 2.5 and that works fine.

I had the same CD issue with the old Basilisk II win32 ver. The solution was to enable the CD Rom as a SCSI device. No such option on Sheep Shaver though....
trexplorer
Tinkerer
Posts: 47
Joined: Mon May 24, 2004 9:05 pm

Post by trexplorer »

Finally a stable build ... hasn't crash yet on my 3.2 Ghz P4.

Bench mark tests are about 4x faster than previous build using APD, but speedometer tests run about 3 times slower ... ?

However, GUI, scrolling and opening applications is significantly slowewr and less responsive (jit true and frameskip 0)

keep up the great work !

cheers ...
Last edited by trexplorer on Sun Mar 20, 2005 10:22 pm, edited 1 time in total.
ivanhasyou
Student Driver
Posts: 23
Joined: Wed Jan 08, 2003 2:26 am
Location: Right behind you!

Post by ivanhasyou »

wow, this works on an AMD too with JIT on

however, im getting a weird mouse issue where when i click anywhere, it can only click on the apple menu
Neospy
Mac Mechanic
Posts: 186
Joined: Mon Jul 05, 2004 10:49 pm
Location: Woodway, Texas, USA
Contact:

Post by Neospy »

ivanhasyou wrote:however, im getting a weird mouse issue where when i click anywhere, it can only click on the apple menu
Ok, that is weird. I have not had this problem, but has anyone noticed the number 3 key is not mapped except on the number pad?

>neospy 8)
User avatar
PPC_Digger
Forum All-Star
Posts: 1053
Joined: Thu Jul 22, 2004 9:02 am
Location: Israel

Post by PPC_Digger »

trexplorer wrote:Bench mark tests are about 4x faster than previous build using APD ...
If only PearPC could get faster so fast ::dreams about pearpc 4x faster:: :lol:
ivanhasyou
Student Driver
Posts: 23
Joined: Wed Jan 08, 2003 2:26 am
Location: Right behind you!

Post by ivanhasyou »

Neospy wrote:
ivanhasyou wrote:however, im getting a weird mouse issue where when i click anywhere, it can only click on the apple menu
Ok, that is weird. I have not had this problem, but has anyone noticed the number 3 key is not mapped except on the number pad?

>neospy 8)
well, i got rid of the problem by disabling unused extensions... wow, this speed is very usable :mrgreen:
User avatar
Cat_7
Expert User
Posts: 5256
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Post by Cat_7 »

There is a new zip package available at gwenole's site with some basic information and a newly build executable.

Works great!

Cat_7
ataxy
Master Emulator
Posts: 377
Joined: Sun Jan 25, 2004 3:49 pm
Location: Canada
Contact:

Post by ataxy »

wow cat that new build in the zip file shows some great improvement in speed now if only the was web support how by the way i havent tried the quick time player yet
ivanhasyou
Student Driver
Posts: 23
Joined: Wed Jan 08, 2003 2:26 am
Location: Right behind you!

Post by ivanhasyou »

it doesnt seem to work with the mac os update rom or a PCI mac rom, on my computer it just runs for a second then disappears
ataxy
Master Emulator
Posts: 377
Joined: Sun Jan 25, 2004 3:49 pm
Location: Canada
Contact:

Post by ataxy »

weird i have the rom from the mol site and it runs perfect
gb
Real Swell Guy!
Posts: 116
Joined: Tue Jun 22, 2004 4:20 am

Post by gb »

ivanhasyou wrote:it doesnt seem to work with the mac os update rom or a PCI mac rom, on my computer it just runs for a second then disappears
Is there anything worth mentioning from stdout.txt and stderr.txt files available in the same directory where you launched SheepShaver.exe?

BTW, I noticed a bug where if you have an invalid "disk" entry, with e.g. a path to an inexistent file, SheepShaver will silently exit.
gb
Real Swell Guy!
Posts: 116
Joined: Tue Jun 22, 2004 4:20 am

Post by gb »

ataxy wrote:wow cat that new build in the zip file shows some great improvement in speed now if only the was web support how by the way i havent tried the quick time player yet
Ethernet support in Windows is trickier because it requires significant changes to the native ethernet driver to get it clean. Besides, even under Linux I couldn't get it working fully for a long period of time yet. So, the plan is to first first under Linux and then Windows.

The advantage of Windows is that you have Lauri's NAT/Router which doesn't require any extra driver to install. That's equivalent to a user-space network stack implementation I was working on for Basilisk II (from QEMU's slirp) but it was sub-optimal, performance-wise.

BTW, does sound work within Windows? Under Linux? I can't test on the x86-64 system because it has no sound card. ;-)
Neospy
Mac Mechanic
Posts: 186
Joined: Mon Jul 05, 2004 10:49 pm
Location: Woodway, Texas, USA
Contact:

Post by Neospy »

Sound is working for me just fine.

>neospy
ataxy
Master Emulator
Posts: 377
Joined: Sun Jan 25, 2004 3:49 pm
Location: Canada
Contact:

Post by ataxy »

gb wrote: Ethernet support in Windows is trickier because it requires significant changes to the native ethernet driver to get it clean. Besides, even under Linux I couldn't get it working fully for a long period of time yet. So, the plan is to first first under Linux and then Windows.
cool
ivanhasyou
Student Driver
Posts: 23
Joined: Wed Jan 08, 2003 2:26 am
Location: Right behind you!

Post by ivanhasyou »

gb wrote:
ivanhasyou wrote:it doesnt seem to work with the mac os update rom or a PCI mac rom, on my computer it just runs for a second then disappears
Is there anything worth mentioning from stdout.txt and stderr.txt files available in the same directory where you launched SheepShaver.exe?

BTW, I noticed a bug where if you have an invalid "disk" entry, with e.g. a path to an inexistent file, SheepShaver will silently exit.
oh, thanks, that was the problem...

btw, what will happen if i try to book os 9.2.2?
dragonfly
Student Driver
Posts: 23
Joined: Sun Mar 06, 2005 9:24 pm

SheepShaver-3.exe download gone ?

Post by dragonfly »

This post in no longer valid since download link has been corrected above.

This download link you provided above is no longer working.
and I looked for SheepShaver-3.exe.bz2 .. here ..
Do you have a new download link?

p.s.

just found this link ..SheepShaver 2.2-20050321 which seems up to date. But still no link to version 3.0.


p.p.s

I have now used the above version of SheepShaver-2.2-20050321 to install Mac OS 8.5 on Win XP Pro for the first time. Earlier versions failed. Thanks.
Last edited by dragonfly on Wed Mar 23, 2005 4:55 pm, edited 1 time in total.
ataxy
Master Emulator
Posts: 377
Joined: Sun Jan 25, 2004 3:49 pm
Location: Canada
Contact:

Post by ataxy »

here is where you will get all official release from gb
http://gwenole.beauchesne.free.fr/sheep ... loads.html
khawkins98
Space Cadet
Posts: 2
Joined: Wed Dec 22, 2004 12:45 am

Post by khawkins98 »

I take it the 3.0 release has been pulled for now? Can't seem to find it anywhere ...
yyyc186
Student Driver
Posts: 11
Joined: Sat Nov 27, 2004 5:53 am

cool bananas

Post by yyyc186 »

jit works!
stuff is smooth and fast!
seems to crash on exit (maybe because i didn't load cdenable.sys)

Hopefully Lauri's networking driver gets integrated next.

Fabulous stuff.

Thanks GB!!!
User avatar
Cat_7
Expert User
Posts: 5256
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Post by Cat_7 »

@khawkins

You should search for the win32.zip file in GB's directory.

Cat_7
CFran2
Mac Mechanic
Posts: 160
Joined: Tue Mar 15, 2005 6:55 pm

Post by CFran2 »

"Downgraded to quicktime 2.5 and that works fine. "

lol, QuickTime 5 works too. by the way, there is many graphical bugs, mostly with QuickTime 5, and um, as for the sound, there's conflicting extension abd control panels that dont conflict on my performa and that make sheepshaver instantly shut down. btw, why is it now more stable with JIT on than off? good thing tho. i also got problems launching netscape 4.79, basically sheepshaver shuts down when i start it
Post Reply