Login  •  Register


The time is now: Sat Mar 28, 2020 5:54 pm

Emaculation wiki  •  Delete all board cookies



Post new topic  Reply to topic Page 1 of 1 [ 4 posts ]
Print view Previous topic  |  Next topic
Author Message
PostPosted: Wed Dec 21, 2005 7:40 pm 
Offline
Space Cadet

Joined: Sun Dec 18, 2005 3:50 pm
Posts: 7
Hello,

I'm trying to run SS on my Dual G5/2.0 GHz-Mac running MacOS X 10.4.3 (roaring Tiger ;-), but unfortunately it doesn't work. :(

First I downloaded the pre-compile binaries (as of March 15th, 2005), but after double-clicking the SS icon, it appeared only for an instant in the dock, only to disappear again right on the spot.

So I did some research on 'The Net', and tried out everything I came across but to no avail.

Okay, let's play it the hard way: download the CVS tree as of Dec.20th, 2005 for both SS and BasiliskII, perform a 'make links' in the root of the SS source tree, change to src/Unix and do a './autogen.sh' and....configure throughs some errors.

After removing 'GTK' and 'GTK2' from configure it went through smoothly, and so did a 'make'.

But when running SS with preferences like

rom /Volumes/Working/BasiliskII/rom/MacOS85.rom
disk /Volumes/Working/SheepShaver/MacOS/9.0.4/MacOS904.vol
cdrom /Volumes/Working/SheepShaver/MacOS/9.0.4/MacOS904.iso
extfs /Volumes/Working/install
screen win/1024/768/16
windowmodes 3
screenmodes 0
bootdrive 0
bootdriver 0
ramsize 268435456
frameskip 0
gfxaccel true
nocdrom false
nonet false
nosound true
nogui true
ignoresegv false
jit false
ether slirp
keycodes true
keycodefile /Programs/os/SheepShaver/keycodes.sdl
mousewheelmode 1
mousewheellines 3
idlewait true

some messages appear in my xterm

MH-Dual-G5:~ heinm$ cd /Volumes/Data/download/os/emulator/SheepShaver/2005.12.20/SheepShaver/src/Unix/
MH-Dual-G5:/Volumes/Data/download/os/emulator/SheepShaver/2005.12.20/SheepShaver/src/Unix heinm$ ./SheepShaver
SheepShaver V2.3 by Christian Bauer and Mar"c" Hellwig
WARNING: Unknown preferences keyword ''
Paranoia checks...
[emul_thread] waiting for tick thread to initialize
[tick_thread] waiting for emul thread to initialize
[emul_thread] filling in registers and waiting for interrupt
[tick_thread] trigger interrupt
SIGUSR2 caught
...passed
Reading ROM file...
WARNING: Cannot find vendor 'MacX' in keycode translation file /Programs/os/SheepShaver/keycodes.sdl.
SIGSEGV
pc 40c610b4 lr 40c91440 ctr 40c6c410 msr 0200f030
xer 00000000 cr 40101840
r0 00000000 r1 203ffefe r2 00000000 r3 40812474
r4 203fff32 r5 40c66144 r6 00000000 r7 00000007
r8 ffffffff r9 0000a013 r10 ffffffff r11 0002001c
r12 00010000 r13 0002001c r14 0000a71e r15 00020030
r16 203fff32 r17 00000366 r18 ffffffff r19 20000000
r20 20000ce0 r21 2fffff88 r22 203fff9a r23 00000000
r24 4081247c r25 00000027 r26 00000000 r27 0000245f
r28 00000000 r29 40c91440 r30 40c60000 r31 68fff000
^C
MH-Dual-G5:/Volumes/Data/download/os/emulator/SheepShaver/2005.12.20/SheepShaver/src/Unix heinm$

a black window appears, and...nothing! :(

The same happens when trying to boot MacOS 8.5.

Btw. using the pre-compiled binaries results in a message like 'Wrong kernel? Try different one!'.


Top
 Profile  
Reply with quote Post a reply  
 Post subject: Solved! :))
PostPosted: Wed Jan 11, 2006 8:08 pm 
Offline
Space Cadet

Joined: Sun Dec 18, 2005 3:50 pm
Posts: 7
Okay, I just checked out the latest binaries of BasiliskII and SheepShaver, configure & compiled both of them--unfortunately this was a little bit tricky due to no GTK or ESD available, and I'm not willing to install them, so I have to modify 'main...cpp', got Apple MacOS ROM Update Tome 1.0 and extracted 'Mac OS ROM' with TomeViewer, et voilá my SheepShaver is running, and currently MacOS 9.0.4 is being installed.

As mentioned in another post, only the Tome ROM seems to be working.


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Thu Jan 12, 2006 9:40 am 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 4809
Location: Sittard, The Netherlands
Good to read you solved your problem! And thanks for sharing the solution.

Cat_7


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Thu Jan 12, 2006 10:06 am 
Offline
Space Cadet

Joined: Sun Dec 18, 2005 3:50 pm
Posts: 7
One last thing--at least it applies to my special environment: Dual G5/2GHz, MacOS X 10.4.4--: when updating the disk drivers during MacOS 9 installation, the setup runs forever trying to update the drivers.


Top
 Profile  
Reply with quote Post a reply  
Display posts from previous:  Sort by  
Post new topic  Reply to topic Page 1 of 1 [ 4 posts ]


Who is online

Users browsing this forum: Google [Bot] and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
 

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group