Login  •  Register


The time is now: Sat Mar 28, 2020 5:42 pm

Emaculation wiki  •  Delete all board cookies



Post new topic  Reply to topic Page 1 of 1 [ 13 posts ]
Print view Previous topic  |  Next topic
Author Message
 Post subject: not working..
PostPosted: Wed Jan 11, 2006 2:51 pm 
Offline
Space Cadet

Joined: Wed Jan 11, 2006 2:33 pm
Posts: 7
Ok, heres the situation. I have SheepShaver 2.3 installed (on Windows XP Pro), i got my Power PC Rom (4096 kb) and System 7.5.5.dsk. Everything has been configured in sheepGUI....

SheepShaver starts and after 2-3 seconds it displays Welcome to Macintosh ...but then it just Quits. Just closes itself. Any information on this? many thanks

stderr.txt:
SIGSEGV
pc 02223456
ea 42000000
r0 00000000 r1 22ffa0f0 r2 00000000 r3 4084a340
r4 408031a0 r5 00006706 r6 ffffd3ce r7 00001efc
r8 00000002 r9 2005ac40 r10 ffffffff r11 00001f00
r12 ffff0000 r13 00020000 r14 00000020 r15 00000020
r16 2005ac40 r17 40000000 r18 408031a0 r19 40849862
r20 00001f6c r21 23000190 r22 20000000 r23 00000000
r24 40849840 r25 00000020 r26 00000000 r27 ffff9481
r28 00000000 r29 40ce2488 r30 40c60000 r31 68fff000
f0 0.00000 f1 0.00000 f2 0.00000 f3 0.00000
f4 0.00000 f5 0.00000 f6 0.00000 f7 0.00000
f8 0.00000 f9 0.00000 f10 0.00000 f11 0.00000
f12 0.00000 f13 0.00000 f14 0.00000 f15 0.00000
f16 0.00000 f17 0.00000 f18 0.00000 f19 0.00000
f20 0.00000 f21 0.00000 f22 0.00000 f23 0.00000
f24 0.00000 f25 0.00000 f26 0.00000 f27 0.00000
f28 0.00000 f29 0.00000 f30 0.00000 f31 0.00000
lr 40ce2488 ctr 00000000 cr 40501f2f xer 00000000
pc 40ce2488 fpscr 00000000

stdout.txt:
SheepShaver V2.2 by Christian Bauer and Mar"c" Hellwig
WARNING: Unknown preferences keyword 'screen'
WARNING: Unknown preferences keyword 'etherpermanentaddress'
WARNING: Unknown preferences keyword 'ethermulticastmode'
WARNING: Unknown preferences keyword 'routerenabled'
WARNING: Unknown preferences keyword 'ftp_port_list'
WARNING: Unknown preferences keyword 'portfile0'
WARNING: Unknown preferences keyword 'portfile1'
Reading ROM file...
Detected CPU features: MMX SSE SSE2
PowerPC CPU emulator by Gwenole


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Wed Jan 11, 2006 6:15 pm 
Offline
Forum All-Star
User avatar

Joined: Mon May 20, 2002 11:50 am
Posts: 1217
Location: Ouraion
I can't tell you the exact problem by looking at the stderr dump, but here's some additional info needed by us to help you.

Which PowerPC Rom are you using? (From what Mac model?)

Is the System 7.5.5.dsk something you created in Basilisk II, or something you downloaded?

Oh ... you need to use the new SheepShaverGUI.exe that comes with SheepShaver 2.3, not the SheepGUI by Don Kelly. SheepShaver appears to be choking on the older pref settings.


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Thu Jan 12, 2006 7:51 am 
Offline
Space Cadet

Joined: Wed Jan 11, 2006 2:33 pm
Posts: 7
Mac Emu wrote:
I can't tell you the exact problem by looking at the stderr dump, but here's some additional info needed by us to help you.
Which PowerPC Rom are you using? (From what Mac model?)
Is the System 7.5.5.dsk something you created in Basilisk II, or something you downloaded?
Oh ... you need to use the new SheepShaverGUI.exe that comes with SheepShaver 2.3, not the SheepGUI by Don Kelly. SheepShaver appears to be choking on the older pref settings.


I got ROM from old Power Macintosh 8600 / 200. Also i have downloaded system disk 7.5.5. (its system 7.5.5.dsk file) - 15.500 Kb.

Could mac os 7.5.5. be the problem? perhaps i should get Mac Os 9? or put the whole thing on Windows 98?

**Supplementary: since ive copied ROM from PowerMac 8600 wich runs on Mac OS 9, in GUI preferences i removed volume: system 7.5.5.dsk. Now SheepShaver manages to open, but all i get is floppy disk icon with question mark. I can buy Mac Os 9 CD, but how do i boot/install it so SheepShaver can run?

I apologise for such "noob" questions, but im new in emulation world so..Many thanks in advance


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Thu Jan 12, 2006 3:42 pm 
Offline
Space Cadet

Joined: Wed Jan 11, 2006 2:33 pm
Posts: 7
I managed to get Mac OS 9 install CD. I can read it in HFVExplorer.

Please, how should i make SheepShaver work/ boot using this macOS9 CD?


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Thu Jan 12, 2006 4:10 pm 
Offline
Space Cadet

Joined: Wed Jan 11, 2006 9:31 am
Posts: 9
Hi Clouseau

What worked for me was to recover the Mac Rom from the update file as was desribed in a previous thread, and then you can use HFVExplorer to create an empty disc to use as your hardrive, and set up SheepShaver to use your CD image as the CD rom.

edit: For this last step you may need something like Virtual DAEMON manger (freeware) which allows you to mount any image as a CD drive ( excellent software by the way)

seond edit: What worked for me for the ROM was the operation described here http://www.open.ou.nl//hsp/engels/SheepShaver_help/rom_file_how_to.html
I used the Extrace from downloaded update file.



Your preferences should specify to boot from CD ( or any ) if you like.


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Thu Jan 12, 2006 5:28 pm 
Offline
Space Cadet

Joined: Wed Jan 11, 2006 2:33 pm
Posts: 7
OMG..:) I managed to run Basilisk II, everything works fine. I even updated Performa.rom (1024 Kb) using Tomeviewer >> MACOSROm.bin 2172 Kb.. Basilisk works fine.

SheepShaver - im getting floppy disk with ? icon. thats all. not working.

Again, i've added System 7.5.5.dsk and SheepShaver starts to boot, but all i get is _ Welcome to Macintosh > MacOS starting up........ then nothing. it just quits.

--- Since i got MacOS 9 install CD (examined it in BasiliskII) how can i boot / install MacOS 9 so SheepShaver can start?

obviously it wont work on System 7.5.5... I even tried to install MacOS 9 in Basilisk - on sheepHD.dsk (1 Gb) ... all i get is error 192.


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Thu Jan 12, 2006 6:36 pm 
Offline
Forum All-Star
User avatar

Joined: Mon May 20, 2002 11:50 am
Posts: 1217
Location: Ouraion
Since you have cdenable.vxd installed (right?), you should be able to boot off the Mac OS 9 CD-ROM.

Set up the SheepShaverGUI's Volumes tab similar to this (your CD-ROM drive letter may be different of course, as will the path\name to your blank hard file\drive volume\file (HFV\HDF).

Image

Note: not all Mac OS 9.x.x are directly compatible with SheepShaver. You need a Universal Mac OS 9.0.x CD (i.e. the CD should not be for a specific Mac model or family of models). There are tricks to getting a proper installation setup if you have a non-Universal CD (like "for G3 only"s).


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Fri Jan 13, 2006 8:12 am 
Offline
Space Cadet

Joined: Wed Jan 11, 2006 2:33 pm
Posts: 7
Ive tried your instructions..but its not working. I've inserted MAC OS 9 CD, and set up SheepShaverGUI with your instr. (p.s. i have cdenable.sys cause im working in Windows XP pro).

SheepShaver starts and floppy icon appears (without ? mark), cd-rom starts running but after 5 seconds SheepShaver ejects MacOS 9 CD....not working.

Here are the contents of my Mac OS 9 CD (root folder, explored via HVF explorer):
| Adobe Software| 3 items
| CD Extras | 22 items
| Desktop Folder| 0 items
| Software Installers| 14 items
| System Folder| 13 items
| Trash| 0 items
| Utilities| 7 items
Before You install 8 KB
Install Mac OS 9 275 KB
Installing Mac OS 9.pdf 354 KB
Mac OS Install 140 KB

What in the earth am i doing wrong? :) Perhaps Windows XP is the problem ? (partitions are NTFS)...Windows 98 SE maybe??


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Fri Jan 13, 2006 11:05 am 
Offline
Forum All-Star
User avatar

Joined: Mon May 20, 2002 11:50 am
Posts: 1217
Location: Ouraion
Doh! Yeah, I meant cdenable.sys.

What color is your CD-ROM? Grey? White?


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Fri Jan 13, 2006 12:54 pm 
Offline
Space Cadet

Joined: Wed Jan 11, 2006 2:33 pm
Posts: 7
Mac Emu wrote:
Doh! Yeah, I meant cdenable.sys.
What color is your CD-ROM? Grey? White?


Its white! Contents on Mac OS CD date from September 1999.

I really dont know what else to do..


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Fri Jan 13, 2006 7:17 pm 
Offline
Forum All-Star
User avatar

Joined: Mon May 20, 2002 11:50 am
Posts: 1217
Location: Ouraion
O.K. Go ahead and copy\paste the contents of your SheepShaver_prefs. Here is mine for example.

disk D:\MacEmu\HDFs\Sheep86.HFV
extfs
screen win/640/480
windowmodes 3
screenmodes 63
seriala FILE
serialb FILE
rom D:\MacEmu\ROMs\ROM.rom
bootdrive 0
bootdriver 0
ramsize 134217728
frameskip 1
gfxaccel true
nocdrom false
nonet false
nosound false
nogui false
noclipconversion false
ignoresegv false
jit true
jit68k false
keyboardtype 5
keycodes false
mousewheelmode 1
mousewheellines 3
ignoresegv false
idlewait true
keycodes false
mousewheelmode 1
mousewheellines 3
enableextfs true
debugextfs false
extdrives CDG
pollmedia false
etherpermanentaddress true
ethermulticastmode 0
routerenabled true
ftp_port_list 21
tcp_port
portfile0 C:\B2TEMP0.OUT
portfile1 C:\B2TEMP1.OUT


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Fri Jan 13, 2006 7:50 pm 
Offline
Space Cadet

Joined: Wed Jan 11, 2006 2:33 pm
Posts: 7
SheepShaver_prefs:

disk D:\MacEmu\HDFs\200.HFV
cdrom E:\
extfs
screen win/640/480
windowmodes 3
screenmodes 63
seriala COM1
serialb COM2
rom C:\SheepShaver\POWER.ROM
bootdrive 0
bootdriver -62
ramsize 134217728
frameskip 2
gfxaccel true
nocdrom false
nonet false
nosound false
nogui false
noclipconversion false
ignoresegv false
jit true
jit68k false
keyboardtype 5
keycodes false
mousewheelmode 1
mousewheellines 2
ignoresegv false
idlewait true
keycodes false
mousewheelmode 1
mousewheellines 2
enableextfs false
debugextfs false
extdrives CDE
pollmedia true
etherpermanentaddress true
ethermulticastmode 0
routerenabled false
ftp_port_list 21
portfile0 C:\B2TEMP0.OUT
portfile1 C:\B2TEMP1.OUT

please help ...im startin' to feel slightly desperate :)


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Fri Jan 13, 2006 8:00 pm 
Offline
Forum All-Star
User avatar

Joined: Mon May 20, 2002 11:50 am
Posts: 1217
Location: Ouraion
On the SheepShaverGUI's Volumes tab:
1. Change boot from CD-ROM to Any. (If your HDF is blank, SheepShaver will try the CD-ROM.)
2. You have a blank hard drive file called 200.HFV located at D:\MacEmu\HDFs?
3. Your CD-ROM drive is E:\?

On the Graphics/Sound tab:
Enable QuickDraw acceleration

On the Memory/Misc tab:
1. Enable Ignore Illegal Memory Accesses
2. You are using the 1.85 MB New World ROM?

On the JIT/Compiler tab:
Check the Enable JIT Compiler

BTW: All I do to quickly see what's wrong with your prefs is to replace my prefs with your prefs, then launch the GUI from which I can go from tab to tab to see what looks wrong. I've been doing this technique with the BasiliskII_prefs for years. :idea:

You might get the error message you need by launching SheepShaver.exe via a command prompt. I bet it's your hard drive file that's the problem (or JIT not being enabled).


Top
 Profile  
Reply with quote Post a reply  
Display posts from previous:  Sort by  
Post new topic  Reply to topic Page 1 of 1 [ 13 posts ]


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
 

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group