Login  •  Register


The time is now: Sun Aug 09, 2020 8:31 am

Emaculation wiki  •  Delete all board cookies



Post new topic  Reply to topic Page 1 of 1 [ 14 posts ]
Print view Previous topic  |  Next topic
Author Message
PostPosted: Fri Jan 05, 2007 3:07 pm 
Offline
Space Cadet

Joined: Fri Jan 05, 2007 2:49 pm
Posts: 5
When I try and run Prosoniq Studio Power Bundle, downloaded from http://products.prosoniq.com/cgi-bin/register?service=showdetail&refno=9, I either get a system freeze if I use a PowerMac 7200 ROM or it complains it can't find any sound driver if I use a Mac OS8.6 supplied ROM.

I am using a dual-Athlon64 PC. I have Sheepshaver installed on Mandriva 2007 64-bit from the supplied SheepShaver-2.3-0.20051130.1mdk rpm. I have installed Mac OS 8.6 with all default options.

I use the "Sound" control panel to enable the sound when using the Mac OS 8.6 ROM. Speech and system beeps work but there doesn't seem to be any sound input device, only output, and Prosoniq complains it can't find any sound device.

With the 7200 ROM, sound works and the Sound control panel also shows an input device, but as soon as Sonic Worx loads the ASIO driver, the MacOS system freezes and one of my CPUs maxes out at 100% load. I have to kill Sheepshaver.

I tried removing the ASIO driver to see if I could coax Sonic Worx to function without it but alas, it insists on using it.

Anyone know how I might be able to get this thing to work? Do I need to try another ROM (I haven't found any others yet)? Are there other ASIO drivers I can try?

Regards


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Fri Jan 05, 2007 10:35 pm 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 4921
Location: Sittard, The Netherlands
Hi,

There is no audio hardware available in SheepShaver. All devices are emulated, so it's "normal" a driver can't find a real device.

But I downloaded your application and tried it. It seems to run well. I can copy f.e. an audio track from a cd in OSX to MacOS 9 and edit it with SonicWorX. After saving it, I can copy it to OSX (in my case) and run it in i-Tunes. So editing and moving the file twice didn't break the format.
I can, however, not play the file inside MacOS9.

Hope this helps somehow,

Best wishes,
Cat_7


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Sat Jan 06, 2007 8:36 am 
Offline
Space Cadet

Joined: Fri Jan 05, 2007 2:49 pm
Posts: 5
Hmmm. But shouldn't an emulator pretend to be the hardware with enough cunning that the guest software & drivers can't tell it apart from the real thing?

I'll try one or two other ROMs then the next step in this quest is to try MacOS X on PearPC. However I am less keen on that idea since it is a much larger resources overhead on the host OS to get Prosoniq working.


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Sun Jan 07, 2007 6:11 am 
Offline
Granny Smith

Joined: Mon Dec 25, 2006 4:09 am
Posts: 109
simonb wrote:
Hmmm. But shouldn't an emulator pretend to be the hardware with enough cunning that the guest software & drivers can't tell it apart from the real thing?


Sure. Feel free to submit the necessary code changes to SheepShaver to achieve this behaviour. ;)


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Mon Jan 08, 2007 9:05 am 
Offline
Space Cadet

Joined: Fri Jan 05, 2007 2:49 pm
Posts: 5
Myrd wrote:
Sure. Feel free to submit the necessary code changes to SheepShaver to achieve this behaviour. ;)


Thanks.

I was just questioning what appeared to me to be the notion that emulation was somehow inherently unable to emulate.

I don't know why I don't feel so free to submit the code to fix it. I mean, what's stopping me? It's as easy as falling off a log ;-)


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Sun Feb 25, 2007 4:59 pm 
Offline
Space Cadet

Joined: Sun Feb 25, 2007 4:50 pm
Posts: 1
get this, it is a driver that is supposed to be for Classic under OS X - but it works with SheepShaver! :)

http://www.prosoniq.com/pub/unsupported ... sio090.zip


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Tue Feb 27, 2007 1:37 pm 
Offline
Space Cadet

Joined: Fri Jan 05, 2007 2:49 pm
Posts: 5
tomax wrote:
get this, it is a driver that is supposed to be for Classic under OS X - but it works with SheepShaver! :)

http://www.prosoniq.com/pub/unsupported ... sio090.zip


Thanks. I downloaded it but when I uncompress the zip using Stuffit I get some weird split directories with the driver being 0 bytes and a shadow of it (starting with a double-underscore) in another directory. When I copy the double-underscore version into the Prosoniq ASIO driver folder I get a system error bomb and Mac OS restarts.

Is there some new way that MacOS handles resource forks that Mac OS 8.6 doesn't understand? How do I extract the driver in a way that Mac OS 8.6 can use it?

Regards...


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Tue Feb 27, 2007 2:35 pm 
Offline
Expert User
User avatar

Joined: Thu Feb 09, 2006 10:24 pm
Posts: 6081
Location: Amsterdam, Netherlands
The zip archive does decompress normally in MacOSX, but apparently not with Stuffit in MacOS.

I changed it into an archive that should decompress correctly using Stuffit in MacOS and I added a SimpleText version of the included rtf ReadMe to the archive.

http://www.xs4all.nl/~ronaldpr/sheepsha ... er.sit.hqx


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Tue Feb 27, 2007 6:25 pm 
Offline
Space Cadet

Joined: Fri Jan 05, 2007 2:49 pm
Posts: 5
Well what d'ya know, it works!

Much appreciation to Ronald and Tomax for helping me get up and running with this :-)


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Wed Jun 15, 2011 2:25 am 
Offline
Tinkerer

Joined: Mon Jun 13, 2011 9:37 am
Posts: 65
Ronald, thank you very much for that upload, as the Prosoniq site no longer hosts or supports any of those files. I still haven't been able to get Sonicworx playback fully working in Classic in 10.4, but this allowed me to try, so thanks.

Edit: It is still quite useful for applying effects/plugins inside the app, exporting, then playing the file outside it.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Sat Aug 01, 2020 3:46 pm 
Offline
Space Cadet

Joined: Sat Aug 01, 2020 3:28 pm
Posts: 2
The link is not working anymore. Does the file still exist?

Thx
Arnie


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Sat Aug 01, 2020 6:53 pm 
Offline
Expert User
User avatar

Joined: Thu Feb 09, 2006 10:24 pm
Posts: 6081
Location: Amsterdam, Netherlands
Which of the three links in this topic, which software, are you interested in?
The prosoniq site does not exist anymore and I apparently removed the asio driver file from my downloads, probably years ago.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Sat Aug 01, 2020 9:14 pm 
Offline
Inquisitive Elf

Joined: Sun Jul 31, 2016 11:58 pm
Posts: 33
Have no fear, for the Wayback Machine is near.

http://web.archive.org/web/20160626162317/https://ronaldpr.home.xs4all.nl/sheepshaverforum/prosoniq_asio_driver.sit.hqx

Extracts fine using BetterZip.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Sun Aug 02, 2020 9:50 am 
Offline
Space Cadet

Joined: Sat Aug 01, 2020 3:28 pm
Posts: 2
Perfect!
:smile:
Thank you very much!


Top
 Profile  
Reply with quote Post a reply  
Display posts from previous:  Sort by  
Post new topic  Reply to topic Page 1 of 1 [ 14 posts ]


Who is online

Users browsing this forum: No registered users and 30 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
 

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group