Cursor out by about 6 pixels

About SheepShaver, a PPC Mac emulator for Windows, MacOS X, and Linux that can run System 7.5.3 to MacOS 9.0.4.

Moderators: Cat_7, Ronald P. Regensburg, ClockWise

Post Reply
spacific
Student Driver
Posts: 20
Joined: Sat Apr 12, 2008 10:35 pm
Location: New Zealand

Cursor out by about 6 pixels

Post by spacific »

I have SS working really well now and it is so useful. Therefore this post is not as critical as the "help me get SS working" type. However this problem affects all text editing so is not too minor: when I click on text the editing cursor gets positioned about 6 pixels to the left of the click point -- so usually a couple of characters out of place for smallish text.

Anyone seen that? It happens on both Macs I have with SS.

I have just tried MacDraw and the same thing happens: in fact it is out by about 6 pixels both to the left and to the top of the window. So clearly it is in the mapping of cursor position between the two OSs.

Thanks.
Stephen Coates
Expert User
Posts: 872
Joined: Sat Aug 30, 2003 4:15 pm
Location: UK
Contact:

Post by Stephen Coates »

That sounds similar to a problem I have. I was using SheepShaver on Windows 2000 to try and do some drawing in ClarisWorks 4 and it was a bit awkward because the mouse pointer was a bit out.

I never bothered trying to find out why though.
spacific
Student Driver
Posts: 20
Joined: Sat Apr 12, 2008 10:35 pm
Location: New Zealand

Post by spacific »

Good to know I'm not alone 8)

I'm working through lots (and lots) of WriteNow files, gradually converting them to RTF, but occasionally I need to do a quick edit still in WriteNow.
User avatar
Ronald P. Regensburg
Expert User
Posts: 6458
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Post by Ronald P. Regensburg »

If you are running SheepShaver on Intel Mac, you can try the latest unofficial build by "kelvin31415":
http://www.emaculation.com/forum/viewto ... 6856#26856
spacific
Student Driver
Posts: 20
Joined: Sat Apr 12, 2008 10:35 pm
Location: New Zealand

Post by spacific »

Thanks! Didn't see that discussion about the cursor. (In fact I've just discovered something: this forum's search facility. I was convinced that there wasn't one, but have just noticed those strange outlines at the top of the page: they aren't just for show! Right, now I can search properly...)

I'll try that latest build and report back...
Post Reply