Switch to full style
About SheepShaver, a PPC Mac emulator for Windows, MacOSX, and Linux that can run System 7.5.3 through MacOS 9.0.4.
Post a reply

SheepShaver for Windows

Thu Aug 07, 2008 11:06 pm

Most recent build:
SheepShaver for Windows (01-03-2015) available here for testing:
https://surfdrive.surf.nl/files/index.p ... V/download

Current fixes:
-You can now again boot from and access real CD's in 64 bit Windows hosts, and the cdenable.sys driver is no longer needed in 32 bit hosts (but can still be used).
-Changing CD's is supported (use the polling option in the GUI)

Known issues:
-SheepShaver might crash with low memory settings.
-SheepShaver might crash when an audio CD is in the drive at start.
-SheepShaver will only boot from CD when no Mac OS system is found on any hard disk image attached, even when set to boot from CD.
-Audio CD's start play automatically, but without sound. Turn auto play off in Quicktime settings to prevent SheepShaver taking control over the drive and not release it when shutting down.
-For hybrid Audio/Data CD's only the audio part shows.

Please report you experiences with this build in the forum.

Recommended build
SheepShaver for Windows (06-05-2013) available here:
https://surfdrive.surf.nl/files/index.p ... Y/download
-You can now switch between windowed and full screen modes by using the Ctrl+Enter key combination. All thanks go to our member vasi.

SheepShaver for Windows (28-03-2012), fixed for certain Ambrosia games.
https://surfdrive.surf.nl/files/index.p ... R/download

SheepShaver for Windows (30-08-2010), with startup sound is available here:
https://surfdrive.surf.nl/files/index.p ... 0/download
Just unzip and replace your current SheepShaver.exe. Make sure the file "boing.wav" is in the same folder! More startup sounds can be found here (partly thanks to katoll):
https://surfdrive.surf.nl/files/index.p ... c/download

To get started, always download this:
SheepShaver (05-05-2010), SheepShaver GUI and other files (HFV-Explorer, SDL.dll, drivers, documentation, etc) are included is this download: https://surfdrive.surf.nl/files/index.p ... k/download
If the included sheepshaver.exe gives you memory problems on i5 or i7 processors, replace it with the sheepshaver version from the 30-08-2010 download.

-Gamma ramp patch to allow running certain Ambrosia (and possibly other) games.

Previous fixes:
(30-08-2010):Startup sound has been enabled for a file called "boing.wav" in the SheepShaver folder.
(05-05-2010):(taken from CVS change messages, but not a far back as the original 2006 windows build):
-The timer code has been changed to allow running software that requires more timer slots like the AppleShare IP server sofware.
-Cursor placement.
-Mouse lock-up after frequent movement in and out the SheepShaver window
-Multi-mouse button support through e.g., TheMouse2B
-CD-rom support improved
-Fix file corruption experienced when doing random-access
file I/O to the external filesystem
-Cope with assembler updates in emulated CPU
-Support for 64 bit Intel/ia64
-FPU instructions added
-SSE and MMX optimizations
-SSSE3 optimizations (Intel Core 2 CPUs and newer)
-Update to slirp sources from QEMU 0.9.0

In case you would want to download the older official version, go here:
http://www.emaculation.com/sheepshaver/ ... .win32.zip

Best wishes,
Last edited by Cat_7 on Mon Mar 02, 2015 7:38 am, edited 26 times in total.

Fri Aug 08, 2008 5:31 am


I'm trying it right now... but it would be nice to know what are some of the major changes you've made to this update, that way we can all skip right ahead to trying those aspects out.

So far:

1) ZOMG!!!!! FREAKING HELL YEAH!!! Choosing a color from the swatches in Photoshop actually works correctly now! The color I want is the color I get (and not the color underneath it, as in previous builds)! I LOVE YOU!

2) Doing a Mac OS restart from within SheepShaver causes the emulator to abort (Windows Vista Home Premium 32-bit)


Fri Aug 08, 2008 6:12 am


Please try the latest build linked to in the first post and see if there is any improvement related to the restart error.


Fri Aug 08, 2008 6:57 am

Well, everything works so far. There was just-in-time error when I tried to shutdown with Pause/Break keyboard key (which is set as Mac "Power" key in my keycodes.txt), but I found it's a SDL.dll (1.2.13) issue. Changing sdl.dll back to 1.2.10 resolved this problem.

Windows XP SP3
Sheepshaver in fullscreen mode (1280/1024)
MacOS 9.0.4

Thank you Cat_7 for this new Windows release! There was no such thing in last two years.
Last edited by boyanml on Fri Aug 08, 2008 8:14 am, edited 1 time in total.

Fri Aug 08, 2008 7:47 am

Cat_7 wrote:Kikkoman,

Please try the latest build linked to in the first post and see if there is any improvement related to the restart error.


Sorry Cat_7, the error is still there :(

Fri Aug 08, 2008 8:18 am

I have now included SDL.dll 1.2.10 in the download package.

Best wishes,

Fri Aug 08, 2008 7:29 pm

I have swapped the old sdl and exe files from my current install. Mac OS 9.0.4 starts to boot but as soon as the Mac background appears, right before the desktop icons appear, Sheepshaver just quits with no error message at all. I have tried starting without extensions, zap pram, 256 to millions of color, no change. I even called up my backup fresh install of Mac OS 9.0.4 still same issue. This is happening on Vista sp1 and XP sp2.

If I put the old sdl and exe files back, it boots fine.

Is there anything else I should try :?:


Fri Aug 08, 2008 8:32 pm


That is the same error I had before, but only when restarting (also in Vista SP1). It was fixed using the correct SDL.dll.
I don't believe the error is in the pram file or your mac os install.

You might try some different versions of SDL.dll.

Best wishes,

Fri Aug 08, 2008 9:58 pm

Hi Cat_7,

I have tried many sdl versions, same thing. I put back to the one in your download. After some testing, I was able to finally boot by one of these two options:

1. Disable JIT. This works but emulation becomes too slow.

2. Set memory to 512 or above. It now boots up but cannot restart within Mac OS (Sheepshaver just quits).

BTW Thank you again for working on the new builds :P

Sun Aug 10, 2008 8:09 am

Cool! Microsoft Office (Word, Excel) works under Mac OS 9.0.4. I can create and save documents.

But I have to turn JIT off to get SS to go all the way to the desktop without crashing.

Thu Aug 14, 2008 1:42 pm

Hey there,

Me too I get the same bug ! I've tried using differend SDL packages ! But I am obliged to disable JIT to get OS9 booting !
Without JIT SS is useless as it is too slow ! Maybe there's still another version of SDL that bypasses this bug, but none I tried were succesfull !
Pitty though, cause would be terrific ss running stable on windows !
Oh and framemaker used to work early version sheep, now i get an Visual C++ error at startup !

Keep up good works anyway Thanks

Thu Aug 14, 2008 2:00 pm


have you tried setting memory to 512 Mb? It should allow booting and restart with JIT enabled.

Best wishes,

Tue Aug 26, 2008 10:32 am

Thx Cat, setting memory to 512 did the trick even with JIT enabled, but as said before when I try running framemaker 7.0 it gives me a microsoft visaul c++ error en sheep quits, the application worked with the earlier sheep version though!

But thx again for your reply

Best regards

Thu Aug 28, 2008 5:18 pm

My screenshots for the new 0808 SSWin, all using a rom from a 8500.
Using Mac OS ROM from 8.6 or Mac OS ROM Update 1.0 with 9.0 or 9.0.4 will crash SS when starting Finder.

System 7.5.3
Mac OS 8.1s
Mac OS 8.6
Mac OS 9.0.4
however If you try to start 9.0.4 with Mac OS ROM.... Bang! What a terrible crash to have Jobs' curse!

Mon Oct 20, 2008 10:36 pm

I had a similar problem mentioned above about SS closing for no reason during boot-up.

Using Basilisk II, I created a boot 7.6 image (no extensions, no control panels, etc., which I use with SS to install OS 7.6 to another image. I am able to boot to the boot image no problem, and install 7.6 no problem.

However, when booting from the image where I fully installed 7.6, Mac OS loads about third/half way with the extensions before closing for no reason and with no error message. The same occured for both the previous SS build and this one.

And no, I can't switch to 512 MB of RAM, since I only have 512 MB of RAM on my computer.

Any other ideas?

Emulator error

Sat Dec 06, 2008 4:03 am

I need help with my emulator. I know alot about computers, but have never seen this nessage before. I needed to download a bunch of DLL's for it to come up with the error. It comes up saying "The procedure entry point gtk_file_selection_get_filename_utf8 could not be located in the dynamic link library libgtk-win32-2.0-0.dll." Please help. :x :x :x

Sat Dec 06, 2008 4:16 am

Did you install the GTK +2 runtime:

http://www.emaculation.com/sheepshaver/ ... -setup.exe

There are further setup notes here:


That will tell you what you need to install to make the emulator work.

If you have further questions, maybe start a new thread (so that members in the future can learn from your questions!)

Emulator Help

Sat Dec 06, 2008 4:44 am

Thanks. It was missing.

Mon Jan 05, 2009 2:35 pm


I have linked a new build (of 17-09-2008 :oops: ) to the first post in this thread. It possibly solves the restart/memory problem with Mac OS 9.0.4 in Windows

Happy New Year,

Fri Jan 09, 2009 7:30 am

Can I use this latest version, even if I am under MacOS 8.6 in SheepShaver?

In the archive, with the new version of SS, there is two other files:

- a 258048 octets "SDL.dll" file; this one is intended to replace the 1702125 one I already have in my Sheepshaver folder?

- a "Mac OS ROM_iMAC" file; is it a Macintosh ROM file I must use with this version of SS, in replacement of the ROM file I currently use?

Fri Jan 09, 2009 7:55 am


You can use all files in the download. But please keep a backup of the old ones in case things go wrong...


Fri Jan 09, 2009 9:00 am

OK, thank you, all has booted fine with no problem detected, just after renaming the ROM file "ROM" like in my SS folder, and replacing those 3 files:-)

Under is my current System Info, now, for those able to point me out anything being potentially wrong...

¥¥¥¥¥¥¥¥¥¥ TechToolª System Information Report ¥¥¥¥¥¥¥¥¥¥
©1994-96 MicroMat Computer Systems
All Rights Reserved

For more information on MicroMat Utilities and
Hardware products, call for our free Catalog.
800-829-6227 : Toll Free
707-837-8012 : International
707-837-0209 : FAX
707-837-0444 : Technical Support

Machine Type:
PM 9500
Gestalt ID:
System Version:
Physical RAM Size:
Logical RAM Size:
ROM Version:
ROM Size:
MMU Type:
Emulated MMU Type 1
Keyboard Type:
Extended ISO ADB
TextWidthHook Available
Time Manager:
Extended Manager Present
Country Code:
QuickTime Version:
Appletalk MPP Driver Version:
Appletalk Version:
Open Transport Version:
Audio CD Access Version:
Component Manager Version:
Text Services Manager Version:
Communication Toolbox Version:
AppleScript Version:
Control Strip Version:
Size of Low Memory Area:
OS Trap Table Base:
Toolbox Trap Table Base:
Script Manager Version:
Number of Active Script Systems:
Addressing Mode:
32-bit Mode Active
32-bit Compatible System Zone
32-bit Capable
Alias Manager:
Is Present
Knows about Remote Appletalk
Connection Manager:
Is Present
Fix to CMAddSearch
Has CMGetErrorString()
Has Multi-Async IO
Comm Resource Manager:
Is Present
Fix for Persistent Tools
Has Tool Resource Calls
Database Access Manager:
Is Present
AppenDITL Calls From CTB:
Are Present
Edition Manager:
Is Present
Apple Events:
Is Present
Folder Manager:
Is Present
Font Manager:
Outline Fonts Supported
Disk Cached Fonts Available
File System:
Has HFSDispatch Dispatcher
Has FSSpec Calls
Has a File System Manager
File Transfer Manager:
Is Present
Supports FTSend and FTReceive
Supports FTGetErrorString
VIA1 Exists
SCC Exists
Capable of Software Power Off
53C96 SCSI Controller on Internal Bus
53C96 SCSI Controller on External Bus
Has Universal ROM
Help Manager:
Is Present
Scrolling Throttle On
Standard NBP:
Is Present
Notification Manager:
Is Present
Operating System:
System Heap is Growable
Can Return from Launch
Can Launch from Full File Spec
Launch Control Support
Temp Memory Supprt
Real Temp Memory Handles
Tracked Temp Memory Handles
IPC Support is Present
System Debugger Support
PPC Toolbox:
Supports Real-Time Delivery
Quickdraw Features:
Has Color Quickdraw
GWorlds Deeper than 1-bit
PixMaps Direct (16 or 32 bit)
Text Mode grayishTextOr
Popup cdef:
Is Present
Resource Manager:
Partial Resources Exist
GPIa Connected to DCDa
GPIa Connected to RTxCa Clock Input
GPIb Connected to DCDb
Hardware has Stereo Capability
Stereo Mixing on External Speaker
Sound I/O Manager Present
Built-in Input Hardware Present
Built-in can Play and Record Simultaneously
Can Play and Record 16-bit Samples
Can Record Stereo
Input Port Requires Line Level
Play Double Buffer
Multiple Channel Support
16-bit Audio Data Supported
Standard File:
Has StandPutFile-CustomGetFile
Terminal Manager:
Is Present
Error String Capable
Dictionary Manager:
Is Present
Icon Utilities:
Is Present
Remote Access Connection Interface:
Serial Port Arbitration:


Volume Name:
Mac OS 8.6 vF
Mount Result:
Volume Status:
Volume Busy
SFW Write Attribute:
Not Locked
HDW Write Attribute:
Not Locked
Number of Files:
Number of Folders:
Files in Root:
Used Bytes:
Available Bytes:
Total Bytes:
Creation Date:
9/12/08 23:15:14
Last Modified:
9/01/09 9:42:32
Last Volume Backup:
No Vol B/U
Write Count:
Drive Number:

Volume Name:
Mount Result:
Volume Status:
Volume Busy
SFW Write Attribute:
Not Locked
HDW Write Attribute:
Not Locked
Number of Files:
Number of Folders:
Files in Root:
Used Bytes:
Available Bytes:
Total Bytes:
Creation Date:
9/12/08 21:57:27
Last Modified:
9/01/09 9:42:33
Last Volume Backup:
No Vol B/U
Write Count:
Drive Number:

Volume Name:
HC-Dentiste 2009
Mount Result:
Volume Status:
Volume Busy
SFW Write Attribute:
Not Locked
HDW Write Attribute:
Not Locked
Number of Files:
Number of Folders:
Files in Root:
Used Bytes:
Available Bytes:
Total Bytes:
Creation Date:
5/01/09 13:30:07
Last Modified:
9/01/09 9:40:21
Last Volume Backup:
No Vol B/U
Write Count:
Drive Number:

Fri Feb 27, 2009 2:31 pm

I downloaded this build and tried to use it on the MacBook. I renamed the ".exe" ".dmg" but that didn't work. The finder tells me that there is no volume to mount.

Fri Feb 27, 2009 8:11 pm

See the subject of this thread. This is SheepShaver for Windows, not SheepShaver for MacOSX.

Mon Sep 07, 2009 3:32 am

I'm using XP Pro SP3. Having the same problem with SheepShaver as others.

It launches, gets to the Welcome to Macintosh splash then quits.

I'm using the latest build from the post at the top of this thread with the iMac ROM and the SDL dll from the older release.

I have the GTX setup from here http://emaculation.com/doku.php/sheepshaver_setup installed. I've also tried this one gtk2-runtime-2.16.5-2009-08-06-ash.exe

Prior to this I tried the old 'official' build from 2006, same exact launch and die issue.

If I don't have any disk images selected, it *doesn't die*. It just sits there with the blinking ? on a floppy. It won't quit, I have to use Task Manager to kill it. It doesn't respond to the close button or Alt+F4 or rightclicking its taskbar button then clicking Close. (Looks like a bit of a bug, eh?)

Does it just not work at all with a System for any Mac install of 8.1? I don't have a PPC bootable CD for any versions other than 9.1 and various versions of OS X, so I used my Apple Legacy Recovery CD-ROM to install a FAT 8.1 to an HFS+ image using Basilisk II.

Both the old Lauri Pesonen build and the JIT builds of Basilisk II run just fine. I could try using that to update the GigaSheep (it's a 1 gig HFV) image to Mac OS 8.6.
Post a reply