Switch to full style
About SheepShaver, a PPC Mac emulator for Windows, MacOSX, and Linux that can run System 7.5.3 through MacOS 9.0.4.
Post a reply

Mon Sep 07, 2009 3:46 am

Did you try setting the memory to 512 Mb, which worked for some people in the thread?

Mon Sep 07, 2009 4:19 am

Yup. Didn't make a difference. The only change disabling JIT did was make it take a few seconds longer to quit.

Mon Sep 07, 2009 4:39 am

The September 17 build (a bit older) has the same problems?

Mon Sep 07, 2009 5:18 am

Same problem every build I've tried.

Finally got it to boot using MacStartup.img and mac_oldworld_rom4mb.rom from redundantrobot

Edit: That Image has 7.5.5 on it.

Edit Mark II: With that ROM it boots from the 8.1 install on a 500 meg HFS Standard image I use with Basilisk II. I never knew that in addition to stuffing on a ton of stuff useless to the Mac you're updating to 8.1, that updater also installed a FAT System no matter what. (Retroactive Nerf Cluebat to Apple!) I copied the contents of that image to the HFS+ GigaSheep image within SheepShaver and it works.

When I tried that old world ROM with my FAT 8.1 system installed to an HFS+ image using Basilisk II, it'd un-bless the system folder then flash the ? and sit there until I killed it.

Using any other ROM and that same 8.1 install, it'd do the welcome splash and die. If I held shift, it'd show the splash with Extensions Disabled, then die.

Looks like SheepShaver just does not like a FAT 8.1 install made with Basilisk II. :(

Anyway, booting now so I'll nuke and pave the GigaSheep image with a fresh install from within Sheep Shaver.

Mon Sep 07, 2009 11:25 am

Thank you for taking the time to post the solution to your problem. This will be most helpful to people in the future.

Many posters just sort of disappear after solving their problems on their own.

Tue Sep 08, 2009 1:50 am

Ohhhh yeah, I *hate* that on forums. It's even worse when they post "I fixed it!" but don't say HOW they fixed it, especially when I'm trying to cure the same problem. Grrrr.

That Old World rom will NOT work with 8.5 and later with SheepShaver.

The iMac ROM works with 8.5 and later but NOT 7.5.2 through 8.1.

Dunno why, on a real PPC Old World Mac any version from 7.5.2 through 9.1 works, though for 9.x they have to be booted from the CD-ROM to install.

If I had a 9.0 CD (only have a 9.1) I'd try it to see if SheepShaver would boot from it and install with the Old World rom.

Tue Sep 08, 2009 7:16 am

After 'obtaining' 9.0.4 International English, I did some testing VS different ROMs.

Tests with no mounted disk image, just the CD, set to boot from 9.0.4 CD.

Old World ROM = completes boot from the CD.
(I didn't try installing 9.0.4 with the Old World ROM.)

New World iMac ROM = completes boot from the CD.

New World ROM from ROM Update 1.0 = boots from CD until extensions begin to load then dies.

Tests with an HFV mounted, set to boot from 9.0.4 CD.

Old World ROM with HFV with 8.1 installed = completes boot from the CD.

New World iMac ROM with HFV with 8.1 installed = does the splash and die just like it does trying to boot from any 8.0 or 8.1 with this ROM.

Apparently it will not boot from CD with that New World ROM if any mounted volume has a blessed 8.0/8.1 System Folder, even when it's set to boot from a CD. It starts the boot from the CD, so why does it crash??? Tried this one a few times to be sure it wasn't a random crash.

New World iMac ROM with HFV that has 9.0.4 and HFV that has 8.1 (bootable with Old World ROM) both mounted. Boots from 9.0.4 and *doesn't die!* It didn't do any weirdness like un-blessing the 8.1 System Folder.

Same as above, Old World, put the 8.1 HFV first in the list and it boots normally. Would be nice to just be able to select which disk image to boot from or at least have up/down buttons to shift the boot one to the top.

Shall I repeat these tests using an 8.6 CD?

P.S. It won't copy and paste icons from Get Info on hard drives. :( Basilisk II can.

Sat Nov 07, 2009 10:02 pm

Hello. I'm new here and from Germany I had also same problems with crashes of the newest releases by booting.
Had tried different sdl.dlls. Today I tested the sdl.dll (Version unknown) with is in the Install-directory of Virtualbox. Newest Version 3.0.8. I copied this dll in the sheepshaver-directory.
With disabled JIT the Mac OS 9.0 boots complete. The Emulator seems useable. Some programs however cause a crash. For Example, I installed Opera Version 6.02 for PPC-Mac and by loading new sides in the Browser the Emulation died.

Trying to start with JIT enabled kills the Emulatur with a Runtime-Error.

Sorry if my English is not so good.

Greetings Andy (Germany/Bavaria)

Edit: Sometimes it runs yet with JIT-enabled. One Start-Trial of 5 succeeded.

Sun Nov 08, 2009 8:35 am


What host OS are you using? XP/Vista/7 ?

Is your install clean? Did you install it yourself or did you download a pre-installed image? It would be best to start out with a clean install of a system from a universal MacOS 9 CD.

You have networking enabled. Which networking method did you choose? Networking with Slirp can be unstable. Please try to disable it during your trails. And perhaps Opera is not the best browser around. Have you tried Netscape 7? To me, that is the most stable browser.

SDL.dll versions 1.2.10, 1.2.13 and 1.2.14 should all work.
You can download the dll straight from http://www.libsdl.org/download-1.2.php


Sun Nov 08, 2009 8:29 pm

I use Win XP Home SP3.

The Crashes were only with the newest builds. With the Version from 14.05.2006 are no Problems.
The new Versions run in my System only with the SDL.dll from Virtualbox.

I tested Opera because i use this Browser under XP as standard.
Have now downloaded ICab. It runs more stabil.

I use this day only a downloaded image. Have yesterday ordered a MacOS-System-CD from Amazon, Will test again when the CD is here.


Sun Nov 08, 2009 8:48 pm

andy1200 wrote:Have now downloaded ICab. It runs more stabil.

You may also want to try Classilla: http://www.floodgap.com/software/classilla/

Sun Nov 08, 2009 10:52 pm

Ronald P. Regensburg wrote:
andy1200 wrote:Have now downloaded ICab. It runs more stabil.

You may also want to try Classilla: http://www.floodgap.com/software/classilla/

Thanks, seems to be good. How to install other languages here?

Mon Nov 09, 2009 1:38 am

andy1200 wrote:Thanks, seems to be good. How to install other languages here?

Do you mean other language versions of Classilla? Classilla is in English only.

Thu Nov 12, 2009 12:23 pm

Hello, iam french people, so first, excuse me if there are mistakes in my text...

I would you you help me to understand what's wrong with sheepshaver.

i installed the sheepshaver 2.3, then the 3, and i've always the same errors so i dont understand what's happening.
I want to use sheepshaver to emulate old games.
I have windows XP sp2

The errors with sheepshavers:

1/ FIRST ERROR when i launch it:

the cdrom driver file "C:/WINDOWS/system32/drivers/cdenable.sys" is missing

i saw in sheepshaver file, that there is a file named cdrom drivers with cd enable, i put it where it asked to me (c:/ ...) and now i dont have the error anymore.

2/ "cannot open rom file" appears when i click on "sheepshaver "now...

3/ ive intalled sdl and gtk2, as asked... so i dont think there issue with that.

4/ error when i click on sheepshaverGUI: in french: translation by me...

"this program cant start because LIBGLIB-2.0-0.dll cant be found. the re-installation of this program can fix this issue"

so what's wrong with sheepshaver?

Thu Nov 12, 2009 1:32 pm


If you start SheepShaverGUI.exe to configure SheepShaver and GTK is not installed correctly, that error will occur.

SheepShaver uses a file called SheepShaver_prefs in the SheepShaver folder to store the preferences. If the SheepShaverGUI doesn't work you can manually edit the file.

Mine looks like this, please adjust the paths and names to your disk and rom file etc.:

disk D:\Program Files\SheepShaver\Mac Hard Disk\MacOS_9_HD.hfv
rom D:\Program Files\SheepShaver\Rom file\Mac OS ROM update
cdrom E:\
screen win/1024/768
windowmodes 3
screenmodes 63
seriala COM1
serialb LPT1
bootdrive 0
bootdriver 0
ramsize 536870912
frameskip 0
gfxaccel true
nocdrom true
nonet false
nosound false
nogui false
noclipconversion false
ignoresegv false
jit true
jit68k false
keyboardtype 5
keycodes false
keycodefile D:\Program Files\SheepShaver\Keycodes\BasiliskII_keycodes
mousewheelmode 0
mousewheellines 3
ignoresegv false
idlewait true
enableextfs false
debugextfs false
pollmedia false
etherpermanentaddress true
ethermulticastmode 0
routerenabled false
ftp_port_list 21
portfile0 C:\B2TEMP0.OUT
portfile1 C:\B2TEMP1.OUT

Good luck,

Thu Nov 12, 2009 2:40 pm

iam sure gtk is correctly installed, i dont understand what happens

can you help me to see if gtk is installed correctly and why i cant launch the gui

Thu Nov 12, 2009 4:18 pm

Does the GTk demo that got installed with GTK work OK? Can you select GTK themes?

Maybe it has something to do with your language settings?


Mon Nov 16, 2009 10:48 am

The Problem: my gtk+2 was already auto-installed with a software called PIDGIN.

So, i tryed to uninstall it, and re-install it after but actually, i think it was a mistake, because, both PIDGIN and SHEEPSHAVER don't run...

So, can you help me? step by step, giving link to download gtk2+ good installation software, and latest udpate
and then , after this clean installation of this damned gtk2+, could you help me with sheepshaver and pidgin ( how can i do to install them without problem???)

Can't start Sheepshaver under Vista

Sun Jan 03, 2010 11:20 pm

I've tried all the suggestions and available downloads here, and I still get "Cannot map second Kernel Data area" 487". I execute Sheepshaver, and it goes straight to the error, no activity or display whatsoever between. I've tried all available compatibility modes with no luck. Since Sheepshaver ran fine on this very system under XP, and there have been no hardware changes, I feel it must be a Vista problem, since that's the only thing that's different.

Could someone please post a solution that even an idiot can understand, since this situation is rapidly making me feel like one. That error message might as well be in Greek for all it tells me.



Thank you !!

Tue Feb 23, 2010 4:00 pm

Hi Cat7,
thanks a lot for your splendid work!
The files you included will be very helpful for beginners.
Perhaps you might include a keycodes file as well.
One would only need a Mac-OS image to get things going.
Those may be found searching the web for "macgeek417 uni.cc"
for a 7.52 system or "redundantrobot sheepshaver" for OS9.
Personally I still prefer my 7.6 and 8.6 systems in german.
Your release is running fine with 8.6 and a XP-pro 32bit
host sytstem, though I didn't see any difference to your 30.03.2009

Best wishes!

Tue Feb 23, 2010 10:46 pm

Thanks for the heads up and suggestion. I will include a keycodes file.


How to boot with OS 9

Fri Feb 26, 2010 12:32 am

I've made some tests with Windows Vista, and I have some suggestions. Use the OldWorld ROM to boot, even in OS 9. This is the only way it doesn't crash for me. I decided to go on a whim and try that instead of re-installing everything for the thirtieth time. Well, it works. Just do that, use your OS 9 install CD, and you're good to go.

Sun Mar 14, 2010 3:42 pm

I've actually been able to boot with OS 9.0.4 and the regular ROM just fine, I think I may have disabled some other options as well. My wish is that the internet gets working. First an XP driver would be nice, because the only driver I can use on XP is the 2K driver, and AFAIK it causes SheepShaver to "quit unexpectedly", according to MS C++.

Sun Mar 21, 2010 2:15 am

Does this work with 64-bit windows 7? It won't run on my acer aspire 5532.

Mon Mar 22, 2010 1:17 am

Try running it in 32 bit mode, along with making sure you run it as an administrator.
Post a reply