Switch to full style
About SheepShaver, a PPC Mac emulator for Windows, MacOSX, and Linux that can run System 7.5.3 through MacOS 9.0.4.
Post a reply

Tue Mar 23, 2010 12:07 am

tgp1994 wrote:Try running it in 32 bit mode, along with making sure you run it as an administrator.

it needs administrative rights? Won't it say "This program wants to make changes to this computer"? I will try.
EDIT:Wow, it worked.

Tue Mar 23, 2010 7:47 pm

Ya, windows can be silly sometimes :P That's gone to the top of my list for things-to-do-when-something-doesn't-work-on-windows.

Tue Mar 23, 2010 10:39 pm

tgp1994 wrote:Ya, windows can be silly sometimes :P That's gone to the top of my list for things-to-do-when-something-doesn't-work-on-windows.

same here.

Tue Mar 30, 2010 6:24 am

hey man i know whats wrong with your gtk....sheepshaver isnt looking in the right place for the files.
here is what you do, find the folder you installed gtk to (default is C:\Program Files\Common Files\GTK\2.0) and either write down or copy (if you have show full path in address bar turned on in folder options) the location, then right click my computer -> properties -> Advanced -> then click the environment variables button. in the lower box(should say system variables) there is an entry for path...click it and then click edit. now at the end of the txt in the next box put a ";"(no quotes) and then put in your gtk path. click ok untill you hit your desktop. tada! sheepshaver will now run! :mrgreen:

ya i know its silly, but it happened to me on my win2k machine...couldnt get basilisk or sheepshaver to run even after installing gtk.... :roll:

Tue Mar 30, 2010 6:55 pm

I think it may actually be easier to copy the DLL files to the sheepshaver directory. I was kind of hoping that the interface could be switched over to windows-native WinForms, rather than us having to download these extra libraries.

SheepShaver with 9.0.2 on Win 7 professional

Fri Apr 02, 2010 1:29 pm

Thanks A LOT to everybody in the forum, especially Cat_7 - you were of great help !

:P Just successfully set up a virtual successor for my beloved but outdated and defunct G3 Pismo - on a Dell e6400 with Win 7 Pro (my present employer requires use of Win machines).

Download and installation of the files provided at the indicated places was straightforward, the instructions are mostly excellent. One bit of information could use a more prominent place: How to very easily get a running system from the >PowerBook HD.img< on the recovery CD (just mount the image and copy all contents to the designated virtual SystemVolume). Before I found that hint in some older threads, I spent some hours with the installation CD - which, meant for different hardware, was not useful.

But there was and still is some trouble:
1) With the most recent version (Jan 2010) setting RAM to 256MB or more prevents the start of SheepShaver, and Win displays an Alarm >Cannot map RAM: No error<. With 128MB, SheepShaver starts, but crashes while booting MacOS. 64MB sometimes work, merely 32MB are stable - but then the OS will only run without extensions, and working with any application is nearly impossible, so that doesn't make sense. The 2006 version is much better: It is mostly stable up to 128MB - not luxurious, but quite good for what I need to do. With 4GB of physical RAM I would like to give more of that to the emulator - maybe eventually somebody finds a way...
2) The most recent version (Jan 2010) booted with the installation disk but reliably crashed on opening ANY application (SimpleText, System installer, ...). The 2006 version made no such trouble and installation was successful once I learnd the trick with the image file from the recovery CD. After the installation, the 2010 version runs, too - however, with the memory restrictions mentioned before.

The result makes me quite happy - I even found good old FileBuddy in the Web, so I can restore Type and Creator information on files that at one stage resided on FAT or NTFS disks.

Thanks again for a nifty peace of software!


piece of software giving me peace of mind

Fri Apr 02, 2010 1:37 pm

F... typos! Of course I meant that SS is a great [u]piece [/u]of SW.

Piece to everybody! :wink:


GTK runtime on flash drive

Wed May 05, 2010 10:26 pm

i'm trying to run sheepshaver from my flash drive and i installed gtk runtime on E:\Program Files\Common Files\GTK (my flash drive, but it still says failed to start because some glib2.0.dll or something like that cant be found.

Thu May 06, 2010 6:51 am


That can happen when the path to the installation of GTK is not added to the general path in Windows.
You can manually add the path to GTK by editing the advanced settings under Computer.


Wed May 19, 2010 1:46 pm

SheepShaver really craps! It always crashes in both builds . Anyone can give an official build from last time? I think it's safer .

Wed May 19, 2010 4:08 pm

Please don't call SheepShaver crap. It "Saved a lot of peoples lives" (tm), but isn't perfect. But that was never promised.


Wed May 19, 2010 7:06 pm

I agree! This is most useful to me for getting old applications that I used to love up and running. I find it very helpful.

Wed May 19, 2010 8:16 pm

SheepShaver seems to me mostly magnificent. It does a seemingly impossible job impressively well. It's an amazing achievement.

Fri May 21, 2010 9:58 pm

Kudos to you Cat_7 for another build! It's great that you're keeping the project alive. :)

First time I ran it I had an audio CD in the drive which OS 9 successfully mounted and started playing but which immediately caused a C++ runtime error causing a crash. I booted without the CD and it seems fine (just started using the new build with SDL v1.2.14.0 incidentally) and the CD will play when inserted post-boot. However and I don't know why but the CD player menu in the launcher strip at the bottom of the screen (whatever it's called) shows a mixed up list where some selectable options are repeated and the track listing is out of order. I can still select other tracks with no problem though.

The mouse pointer moving bug is still present but is not as intrusive now. The pointer no longer gets stuck to the top left corner of the screen but moves back to where it was a few seconds ago when there's a prolonged period of emulated HDD access but like I said an improvement from before.

I'll post more if I come across anything else but I'm no Mac expert in the slightest so I won't be testing anything 'professional' but rather games, scene demos and suchlike.

Many thanks again!
PS: To the guy who said that SS is crap- Have patience child; emulating a whole desktop computer from not that long ago can be a bit of a painstaking job to get right but read around and with trial and error you'll get things to work. I did and I've laid my hands on a real Mac TWICE in my whole life for less than an hour.

Mon May 24, 2010 8:01 am

For a record, Settlers 2 runs better on SheepShaver (and 9.0.4) than on DOS-emulator (can't recall the name of the DOS-emu). 8)

Cat_7, is it possible to disable Start-menu popping up when pressing Win-key, if SheepShaver is running? I know there's a way to disable Win-key thru Windows, but then it doesn't work with SheepShaver either (I'd believe). With my laptop, Win-key worked as alt. Or is there a way to edit the keymap for SheepShaver? If I don't remember wrong, SheepShaver doesn't handle Alt Gr as command-key (as it does for Alt), thus it could be a "poor man's solution" for the Win-key problem. Most annoying this problem gets when running in fullscreen.

Tue Aug 31, 2010 10:43 am

Just posting here so this thread will be "unread."

So that you can all see the new build that Cat_7 posted.

Wed Sep 01, 2010 10:56 am

Even I've opened the SheepShaver new build, I heard the startup sound is incorrect (it plays the Quadra chime). Here is the PowerMac startup chime boing.wav: http://www.mediafire.com/download.php?g8f35lul8waije0

Wed Sep 01, 2010 11:54 am


When you read the explanation with the download above, you'll see that any sound file called "boing.wav" will be played. So, if you download your own file, name it "boing.wav" and place it in the Sheepshaver folder, it will be played.


Sheepshaver on windows through virtualbox

Wed Oct 13, 2010 6:06 am

Tried to have Sheepshaver work on fedora 13. After several attempts I still get seg fault errors on launch (even with the sysctl fix). So I'm trying to get it working in a Windows 7 evaluation version running in VirtualBox (I'm going to get mad !).
I managed to have it launch with the disk icon with interrogation mark on the mac-emulated-window.
In fact I can't manage to create a hard drive file in the windows version. I've tried to create it in the windows guest : it does nothing.
I've tried to create it on the fedora host (as the seg fault appears at launch time only), and then use it in the windows guest. it fails.
Do you have any idea to have it work on fedora (would be better) or have the possibility to create a drive file (would be easier) ?

Wed Oct 13, 2010 10:38 am

Would our guides help you?

We have one for linux:

http://www.emaculation.com/doku.php/ubuntu (this is not ubuntu-specific, despite the URL)

and one for Windows:


If you can point out where along the guide you fail, that might help.

Wed Oct 13, 2010 6:47 pm

Thanks for answering.
Yep they did help but not enough !
I finally managed to have it start on a windows 2000 through Virtualbox.
I started OS9 but it suddenly quits after loading some extensions, just before loading the desktop, I think. Maybe he can't load the disk file image created with the SheepShaver GUI, don't know ....
On Fedora natively, I can't get ride of this segmentation fault. Depending on the ROM I use it quits immediately or it issues a GTK warning, then the seg fault :

SheepShaver V2.3-Pre (Apr 12 2009) by Christian Bauer and Mar"c" Hellwig

(SheepShaver:19179): GLib-GObject-WARNING **: gsignal.c:3079: signal name `depressed' is invalid for instance `0x784556d8'
Erreur de segmentation (core dumped)

Wed Oct 13, 2010 7:34 pm

Ypeee !
got it work finally on w2k in VirtualBox. Just had to uncheck the "enable My Computer icon".

Mon Dec 06, 2010 2:24 am

Please add 64-bit support to the b2ether driver!!!

Thu Dec 09, 2010 5:34 pm

I did not manage to run the version with startup sound as well.
SheepShaver version 2010-01-15 is working perfectly.

@Galane: The above version does boot an 8.0 image made with BII, if the option "System for all available.." is checked.
Do you use some kind of harddisk utility for XP? You will know, that Windows is creating a horrible mess on your "C" drive.
See http://www.webisee.com/2009/12/06/full- ... erial-key/
for an utility, that should be running on every Windows OS.

Best wishes!

Sun Mar 06, 2011 5:27 pm

HELP! Everytime I try to start sheepshaver it gives me an error that says "The CD-ROM driver file C:/WINDOWS/system32/drivers/cdenable.sys is missing." And immediately after I hit ok it comes up with another error that says "Cannot open ROM file." Sheepsaver doesn't boot or anything, as soon as I click on the icon it does this. Can somebody please tell me what cdenable.sys is and how I can get it? And why I can't open the ROM file?
Post a reply