Switch to full style
About SheepShaver, a PPC Mac emulator for Windows, MacOSX, and Linux that can run System 7.5.3 through MacOS 9.0.4.
Post a reply

Sun Mar 06, 2011 5:36 pm

I used Mac_OS_ROM instead of oldworld, and it got a little bit farther. It still gives me the cdenable.sys error, but after I hit ok it opens a black sheepshaver window instead of not doing anything, but then throws an error at me that says "Unsupported ROM type." Then sheepshaver crashes. What am I doing wrong? :?:

Sun Mar 06, 2011 6:41 pm

Hello,
what is your host system exactly, Wikwoo?
Did you read the setup guide the second time :-) already?
Best wishes!

Instalado

Sat Apr 16, 2011 10:56 pm

He instalado SeepShave en varias PC. Funciona correctamente en WinXp 32.
En Win 7 todo Ok menos la red, puede ser por el driver Ethernet, estoy buscando la solucion.
Cunado la tenga la comento en este foro porque es el mejor emulador que he visto. Ademas corre el MacOs 9 que sin duda es el mejor de todos, ya que mantiene el formato nativo de Mac.

Un saludo a todos.
Zurdosoft desde Argentina

Sun Apr 17, 2011 12:48 am

En Espanol.

http://translate.google.com/translate?js=n&prev=_t&hl=en&ie=UTF-8&layout=2&eotf=1&sl=en&tl=es&u=http%3A%2F%2Fwww.emaculation.com%2Fdoku.php%2Fsheepshaver_online_guide

Sin embargo, yo uso la opción "Basilisco II router" en lugar y funciona bien para mi instalación. No sé por qué.

Tue May 03, 2011 6:32 pm

Wikwoo wrote:HELP! Everytime I try to start sheepshaver it gives me an error that says "The CD-ROM driver file C:/WINDOWS/system32/drivers/cdenable.sys is missing." And immediately after I hit ok it comes up with another error that says "Cannot open ROM file." Sheepsaver doesn't boot or anything, as soon as I click on the icon it does this. Can somebody please tell me what cdenable.sys is and how I can get it? And why I can't open the ROM file?


Wow, missed the one line to fix it.

Copy cdenable into the wow/sys64 whatever folder it is, under windows.

However, I still get issues about it not being able to read the ROM file, and I've tried three different versions of the OS (OS 8.6, OS9.2, and OS7.6) is this just bad luck with ROMs or what?

OK, so the problem with 9.2 is support is apparently not...good, but 8.6 should be supported, yes?

Tue May 03, 2011 7:47 pm

Yes,

Not being able to read the rom file only happens when you don't point to the correct place where it is located or perhaps when the rom file is damaged.
Search redundant robot for a sure to work rom file and check you sheepshaver_prefs file for the current and correct location.

Best,
Cat_7

Wed May 04, 2011 12:03 am

cdrom.sys is the driver that enables CD-ROM access to SheepShaver . Just copy it from the corresponding folder that came with your SheepShaver version to your system32 folder .

"Cannot read ROM file" is an error where SheepShaver cannot read the ROM file . The only time I see that is when the path to the ROM file is incorrect . Make sure the ROM file and the path is exactly right , and try again . If that doesn't work , just get another ROM file .

Wed May 04, 2011 6:24 am

I guess I just had really bad luck with the iso's I was getting, tried another one and got it running. The last set had all come from the same source, and I think it had just been errors with ripping/writing the iso. Tried one I found though BT and it's running just fine now.

Now the only issue is figuring out where I put all my old mac games last time I moved. There are some I can't find roms for that I'm dying to play.

Also, anyone know why Disk Copy won't work? I tried both 4.2 and 6.3.3 and it says that this kind of mac doesn't provide certain required support. :/ All I want to do is mount a damn image to play the Secret Island of Dr. Quandry for the first time in a decade and a half.

OK, nvm, there's a workaround, apparently mounting the image through the GUI works just as well.

Fri Sep 02, 2011 8:05 am

I have some issues with DC6.3/6.4 and DC4.2 on the Shaver too.

Try DC6.1 for handling IMG, it seems to be the last version working for us.
Of course http://macintoshgarden.org/apps/virtual ... cd-utility will mount lots of images too.
It also makes some games playable that wont run with CD images mounted via GUI.
Last edited by 24bit on Mon Sep 19, 2011 4:11 pm, edited 1 time in total.

Cannot map SheepShaver data area: No Error.

Mon Sep 19, 2011 3:26 pm

Hi

I getting the following error:
"Cannot map SheepShaver data area: No Error."

I'm using
- Windows 7 - 64bits
- SheepShaver_05_05_2010
- GTK2 runtime 2.22.0-2010-10-21-ash

I tried the installation steps and I get the same error message. I tried making remaking the configuration file, changing the ROM, etc. But the result is the same error.
I also tried SheepShaver_startupsound_30_08_2010, but it give me the same message.

I also tried the same configuration inside a VM (Windows Virtual PC - Windows XP Mode), running on Win764bits in the same machine and SheepShaver worked fine.

Any ideas, pointers or tips of what can be the error on Windows 7 - 64bits?

Thanks

Mon Sep 19, 2011 11:18 pm

Hello,

Welcome!

Some piece of software is taking up memory space SheepShaver wants to use.
Please try SheepShaver after a fresh start, and decrease the memory you allow SheepShaver to use.
And please try to close other programs running in Windows. If you find the program not co-existing peacefully with SheepShaver, please let us know.

Best,
Cat_7

Tue Sep 20, 2011 7:40 pm

I just ran into the same error.
Cannot map SheepShaver data area: No Error

I am suspecting Firefox and/or Thunderbird, because they were the only apps I started myself.
(I´m not sure about all those things going on in the background)
Quitting both did not cure the error, only restarting host (W7-64 Ultimate) did.

Sat Apr 07, 2012 12:44 am

Where can I get a copy of the SheepShaver for Windows sources?
I'm trying to get an old piece of hardware to work through the serial port and it, well, doesn't.
I'd like to have a look at the part that talks to the Windows side of the COM port.

Re: SheepShaver for Windows

Sat Apr 07, 2012 6:00 am

Hi and welcome!

Please look here for compile instructions:
http://www.emaculation.com/doku.php/com ... r_basilisk
Under "Actions for all environments" the cvs commands to download the source are listed.

http://www.cebix.net/viewcvs/cebix/SheepShaver/ allows you to browse the code. Please remember that SheepShaver shares a lot code with BasiliskII. That code can be viewed here:
http://www.cebix.net/viewcvs/cebix/BasiliskII/

Best,
Cat_7

Re: SheepShaver for Windows

Sun Apr 22, 2012 2:23 am

Cat_7,
Could you post a copy of the latest CVS code with Basilisk source files combined? SS's configure cannot combine them for me as for some reason Mingw's ln command doesn't work in my environment.

Re: SheepShaver for Windows

Sun Apr 22, 2012 6:54 am

Hi,

There you go: http://www.open.ou.nl/hsp/downloads/BII ... 4-2012.zip
A copy of the sources after the "make links" command in the SheepShaver folder.

Can I ask what you are planning?

Best,
Cat_7

Re: SheepShaver for Windows

Mon Apr 23, 2012 5:57 am

"make links" does not work without a working ln command.
I have to copy BII's files manually one by one in order to build SS in my environment.

I think a better solution would be merging Basilisk II and Sheepshaver into one unified source tree with different build scripts.

Re: SheepShaver for Windows

Mon Apr 23, 2012 12:01 pm

Hi,

What I linked to in my previous post is a copy of the source after I issued the " make links" command. So, it is what you asked for ;-)

Best,
Cat_7

Re: SheepShaver for Windows

Wed Apr 25, 2012 5:54 pm

You may not be able to help me, but for sure I won't get any help if I don't ask.

I'm trying to play my favorite Mac-only MMORPG (Oberin) through Sheepshaver on a Toshiba laptop running XP. After a few little glitches, I've got everything working and the Oberin client even runs .. but it won't connect to the server.

The thing is, the whole reason I even need to try to do this is because I'm at work at a lady's house who has no internet access for 3 days at a time. So I bought a Verizon USB mobile broadband modem and it works great! (expensive, but actually pretty fast). All my Windows side stuff works great, but Sheepshaver won't connect to the internet even after setting up the slirp as directed. I also tried checking my internet settings on the Windows side (PPP) and putting the IP addresses that Windows showed for my computer into the TCP/IP control panel, but that didn't work either.

Is it hopeless?

Re: SheepShaver for Windows

Wed Apr 25, 2012 9:06 pm

Heike wrote:I also tried checking my internet settings on the Windows side (PPP) and putting the IP addresses that Windows showed for my computer into the TCP/IP control panel, but that didn't work either.
That will indeed not work. If it can work at all, it can only do so with values in TCP/IP as shown in the manual:
http://www.emaculation.com/doku.php/she ... line_guide

This slirp networking assumes the host to be connected to a network. So the internet connection should be established in Windows first, possibly even before you start SheepShaver.

Re: SheepShaver for Windows

Thu Apr 26, 2012 2:30 am

Yes sir, I tried that first. Set the GUI to "slirp" and entered the numbers as shown (the 10.0.2.x numbers and the 255.255.255.0 subnet mask, and it did not work. After that didn't work was when I started trying other things, but none of them have worked, either. :cry:

The modem works through a Verizon proprietary program called "VZAccess," and the computer is indeed connected to the internet via the broadband USB modem before I start Sheepshaver.

Thank you for your reply.
Heike

Re: SheepShaver for Windows

Tue May 22, 2012 5:30 pm

I have a problem with my sheepshaver...
If I start it, there won't happen ANYTHING.
No black screen, no error, nothing.

Do you know what's wrong with it?

Re: SheepShaver for Windows

Tue May 22, 2012 7:28 pm

Hi,

Can you give us a bit more information? I assume you are using SheepShaver in Windows, as you are posting in a windows topic.
Which Windows version are you using?
Did your SheepShaver installation work before?

Best,
Cat_7

Re: SheepShaver for Windows

Tue May 22, 2012 7:32 pm

Cat_7 wrote:Hi,

Can you give us a bit more information? I assume you are using SheepShaver in Windows, as you are posting in a windows topic.
Which Windows version are you using?
Did your SheepShaver installation work before?

Best,
Cat_7



Yes, I'm using SheepShaver in windows. I'm using Windows 7 Ultimate 64 BIT.
And no, This is the first time I'm using SheepShaver.

Thanks,
Zannaza

Re: SheepShaver for Windows

Tue May 22, 2012 7:45 pm

Hi,

Did you follow our guide to set up SheepShaver?
http://www.emaculation.com/doku.php/sheepshaver_setup Please read the 64 bit windows comments at the end.
And are you using the 2010 build from http://www.open.ou.nl/hsp/downloads/She ... 5_2010.zip ?

My windows installation sometimes doesn't start because of conflicts with software already running or using memory SheepShaver wants to use. Please stA fresh start might help.
Also, on 64 bit systems, make sure you have no CD rom in the drive. CD rom access isn't supported on 64 systems.

Best,
Cat_7
Post a reply