Switch to full style
About SheepShaver, a PPC Mac emulator for Windows, MacOSX, and Linux that can run System 7.5.3 through MacOS 9.0.4.
Post a reply

Cannot map SheepShaver Data Area: No Error

Mon Dec 28, 2009 7:55 pm

I have my volume set up and my OS 9 setup disc in and all the settings the way I want them, I try to start SheepShaver and get this error. I've already tried a number of things to fix it.
- Tried the newer executable, didn't change anything
- Tried disabling networking, didn't change anything
- Tried using a different volume, didn't change anything
- Tried disabling CD, nothing changed
- Tried with no volumes and only CD, nothing changed
- Tried with different memory values, ignore illegal access, and JIT disabled, nothing changed
- Tried setting disablegui to true in prefs, which got rid of the error but nothing else happened

The ROM was obtained from the iMac update. I am using Windows Vista 32-bit. Here are my prefs (the drive letters are correct, I have a lot of partitions):

disk F:\os9.hfv
cdrom H:\
extfs
screen win/1024/768
windowmodes 3
screenmodes 63
seriala COM1
serialb COM2
rom D:\SheepShaver-2.3\mac.rom
bootdrive 0
bootdriver 0
ramsize 67108864
frameskip 0
gfxaccel true
nocdrom false
nonet false
nosound false
nogui false
noclipconversion false
ignoresegv false
jit true
jit68k false
keyboardtype 5
keycodes false
mousewheelmode 1
mousewheellines 3
ignoresegv false
idlewait true
keycodes false
mousewheelmode 1
mousewheellines 3
enableextfs false
debugextfs false
extdrives D:\temp
pollmedia true
etherpermanentaddress true
ethermulticastmode 0
routerenabled false
ftp_port_list 21
portfile0 C:\B2TEMP0.OUT
portfile1 C:\B2TEMP1.OUT

If anyone can help me with this, I would greatly appreciate it.

Mon Dec 28, 2009 8:01 pm

Hi,

Did you install the cdenable.sys driver in windows/system32/drivers?
And did you try to start SheepShaver as administrator? First set you config with the GUI, and after the start error, right click sheepshaver.exe and chose "run as administrator".
Your config file looks ok to me.

If it doesn't work, search the redundantrobot site and find a rom file that would be best for SheepShaver.

Best,
Cat_7

Mon Dec 28, 2009 8:16 pm

Cat_7 wrote:Hi,

Did you install the cdenable.sys driver in windows/system32/drivers?
And did you try to start SheepShaver as administrator? First set you config with the GUI, and after the start error, right click sheepshaver.exe and chose "run as administrator".
Your config file looks ok to me.

If it doesn't work, search the redundantrobot site and find a rom file that would be best for SheepShaver.

Best,
Cat_7

Thank you for the quick response!

Running as administrator didn't make a difference, I already had cdenable installed, and using the New World ROM didn't make a difference, either.

Mon Dec 28, 2009 9:59 pm

What version of SheepShaver are you using? the one from this forum? If so, please download the original version from the developer's website:
http://gwenole.beauchesne.info and find the original download.
Otherwise, please try our version.


Best,
Cat_7

Mon Dec 28, 2009 11:05 pm

I used the developer's version (May 14), but I also tried the executable in the floated post (March 30); both throw the same error.

Re: Cannot map SheepShaver Data Area: No Error

Tue Dec 29, 2009 6:54 am

twocows360 wrote:ramsize 67108864


You can try more than 64 Mb ram size selection.

twocows360 wrote:- Tried setting disablegui to true in prefs, which got rid of the error but nothing else happened


Did you try in this case to run the executable (SheepShaver.exe) as administrator?
And what's in "stdout.txt" (located in SS directory)?

twocows360 wrote:enableextfs false


Did you try with "true"?

twocows360 wrote:cdrom H:\


Try without "" - "cdrom H:"
Last edited by boyanml on Tue Dec 29, 2009 7:13 am, edited 2 times in total.

Tue Dec 29, 2009 6:57 am

I've already tried more and less. I've gone down to 4 and up to 512.

Wed Dec 30, 2009 5:15 am

twocows360
Did you read my edited post?

Wed Dec 30, 2009 5:28 am

boyanml wrote:twocows360
Did you read my edited post?

Running as admin with nogui just gave me no window like before, and the other two suggestions didn't change anything with or without nogui.

Wed Dec 30, 2009 7:47 am

Hi,

What version of SDL.dll are you using?
Can you please try some different versions of SDL.dll?
Like this one, or perhaps the 1.2.13 version also available from that site
http://www.libsdl.org/release/SDL-1.2.10-win32.zip

Best,
Cat_7

Wed Dec 30, 2009 9:54 am

Cat_7 wrote:Hi,

What version of SDL.dll are you using?
Can you please try some different versions of SDL.dll?
Like this one, or perhaps the 1.2.13 version also available from that site
http://www.libsdl.org/release/SDL-1.2.10-win32.zip

Best,
Cat_7

I was using the version off SDL's website (1.2.14). I tried the 1.2.10 version just now and it didn't affect anything. The 1.2.13 version also didn't change anything.

Wed Dec 30, 2009 10:32 am

Ok,

Please try to reinstall the GTK runtime enviroment, also trying some older 2.10.x version.

Best,
Cat_7

Thu Dec 31, 2009 10:42 pm

Cat_7 wrote:Ok,

Please try to reinstall the GTK runtime enviroment, also trying some older 2.10.x version.

Best,
Cat_7

Tried 2.10.14, 2.16, and 2.18, but still got the error.

Sun Jan 03, 2010 4:31 am

lol i just got this error too.. did all the above...

hmmm help


lost

Sun Jan 03, 2010 4:50 am

lost_loven wrote:lol i just got this error too.. did all the above...

hmmm help


lost


nevermind.. reboot of the computer fixed it....

Sun Jan 03, 2010 8:01 am

@twocows:

I have no suggestions left in relation to SheepShaver. :oops:
Earlier reports of your error seem to indicate a memory conflict between SheepShaver and an already running application. You might try to shut down as many background applications you have running in Windows as possible.

If you want, you can send me your SheepShaver.exe and rom file (zipped) to "hsp dot cat7 at gmail dot com"

Best,
Cat_7

Sun Jan 03, 2010 4:24 pm

seems to be working ok now, I have been shutting down background tasks as I run sheepshaver.. some snags I am still having but slowly working thur them.. I have tried a few times to update from 9.04 to 9.1 and just end up corrupting the hard disk image having to reinstall os9 each time.. icab and netscape 7 working fine for internet browsing ( using icab right now). Just gonna keep tweaking back and forth from vista and sheepshaver and see what conflicts I can either work out or work with too keep a smooth emulation going.. thanks for the help... I am sure you will hear something from me soon rather it be good or bad lol...

lost

Sun Jan 03, 2010 4:28 pm

9.0.4 is the highest verson of Mac OS that can be used in the emulated system. You cannot upgrade.

Sun Jan 03, 2010 4:39 pm

dang it

Mon Jan 04, 2010 1:49 am

Cat_7 wrote:@twocows:

I have no suggestions left in relation to SheepShaver. :oops:
Earlier reports of your error seem to indicate a memory conflict between SheepShaver and an already running application. You might try to shut down as many background applications you have running in Windows as possible.

If you want, you can send me your SheepShaver.exe and rom file (zipped) to "hsp dot cat7 at gmail dot com"

Best,
Cat_7

Ah! That turned out to be it, actually. I shut down Avast! Home Edition, and suddenly it started! I should have thought of that sooner, I guess it just slipped my mind. Thanks for the help!

Re: Cannot map SheepShaver Data Area: No Error

Thu Oct 06, 2016 4:19 am

Reboot fixed it for me. I used gtk+-2.10.13-setup.exe BTW.

Re:

Sat Oct 22, 2016 3:51 pm

lost_loven wrote:
lost_loven wrote:lol i just got this error too.. did all the above...

hmmm help


lost


nevermind.. reboot of the computer fixed it....


Worked for me too.

Re:

Sun Jan 27, 2019 4:22 pm

twocows360 wrote:
Cat_7 wrote:@twocows:
Earlier reports of your error seem to indicate a memory conflict between SheepShaver and an already running application. You might try to shut down as many background applications you have running in Windows as possible.


A decade later, this memory conflict is still an issue with SheepShaver. It's funny how closing and launching apps causes and/or fixes this issue momentarily. The most hilarious part is the "NO ERROR" message on the error dialog. Launching SheepShaver right after booting up your computer most often works and the trick is to leave it running the whole time. If you close SheepShaver and try to launch it again later on, chances are you will run in this memory conflict issue. Leaving it running, even for hours, is the only way to go for me. Unfortunately, it constantly jacks up the CPU usage, so the computer fans are all spinning super loud for nothing. What a shame.

Hopefully QEMU becomes faster in the near future so we can finally get rid of this buggy emulator! :D
Post a reply