Switch to full style
About SheepShaver, a PPC Mac emulator for Windows, MacOSX, and Linux that can run System 7.5.3 through MacOS 9.0.4.
Post a reply

Sheep Shaver, can't access internet/ethernet devices

Sun May 09, 2010 8:42 pm

Hi All,
I have installed sheepshaver on a mac mini (intel) and cannot get it to access any internet, or network items. I can't seem to get OS 9 to recognize the ethernet port on the mini...Does anyone have any suggestions.

I have tried usign the "slirp" as the ethernet device as well as en0 and /dev/en0


Mon May 10, 2010 6:17 am


The setting should read "slirp" (without qoutes). It's no use try "en0" or other settings, these are not recognized. (except for tap0 if you want to use appletalk, but that's another story).

So, if you use "slirp" SheepShaver gives you a small DHCP server of it's own. In the TCP-IP control panel you need to set networking to get a ip-address automatically.
Once you start a internet application like a browser, Mac OS should get an IP-address. (you can check the TCP-IP control panel again).

Please also see our guide here: http://www.emaculation.com/doku.php/she ... _functions


Tue May 25, 2010 3:16 am

What if your Mac is connected to the Internet via AirPort rather than Ethernet? (I tried it anyway, but Mac OS 9.0.4 within SheepShaver couldn't connect.)


Tue May 25, 2010 5:39 am


It shouldn't matter whether you have a wired or wireless ethernet connection.
If you set the connection method to slirp, SheepShaver should get an IP address from it's own DHCP server.

If you now have settings in the TCP/IP control panel set to receive an IP address automatically and can't connect when you run a browser (which one did you try?) you can also try to set the entries manually:
http://www.emaculation.com/sheepshaver/ ... nline2.jpg


Still Need Help w/ Ethernet

Tue Jun 29, 2010 2:21 am

Hi Cat_7,

I hope you can help me. I too am having network difficulties. I have done a clean install of SheepShaver, installing 9.0.4 from a Mac retail installation disk. I have set the TCP/IP Control Panel both ways (automatic and manually, as detailed above). No matter what I try, I can't get access to the internet from OS 9. I have Network set to slirp in the SS preference pane of SS.

I am on:
Intel MacBook Pro
Running Snow Leopard
SL has access via Airport
SS version 2.3
Browsers are iCab & IE for Mac (v. 4.5)

I also tried using a downloaded, preconfigured SS (Classic on Intel) same result.

Is there some setting that I am missing? Any help is greatly appreciated.


Tue Jun 29, 2010 6:21 am


For starters, can you tell me the internet configuration of your mac?


Some More Info

Tue Jun 29, 2010 12:50 pm

Hi Cat_7

On the MacbookPro/OSX side, Airport is set to DHCP. At home, the router is password protected, at work it is not. I have tried with "Computer-to-Computer Networking" checked on and off. In the Sharing pref pane, I have Printer Sharing, Web Sharing and Internet Sharing all checked off. What other settings should we be looking at? I almost never use an Ethernet cable to connect, but I tried that too with no help.

Also, I copied my SS folder (including disk file and ROM) from the Intel Mac to an old PPC PowerBook running 10.4 Tiger and the network and browsers worked immediately upon booting SS - so I'm convinced that my problem is on the MacbookPro side (not an incorrect setting in SS). This was using the manual settings as shown in your jpeg file a few posts above.

Much thanks for your help!


Tue Jun 29, 2010 7:18 pm

I cannot imagine what the problem could be or how to solve it, but here are a few notes:

- If you did not do that, use the 25 October 2009 build (see sticky topic) and follow the setup manual that is referred to by the webloc file in that download. We have little experience with other builds on Intel and Snow Leopard.

- After using 'Classic on Intel', you cannot reliably use the normal version of SheepShaver in the same user account on the same machine without first deleting the ~/.sheepshaver_prefs file. (Note the dot in front of the name, the file is invisible in the Finder). When COI is launched, it overwrites existing settings in the prefs file with its own configurations, some of which cannot be changed using preferences in SheepShaver preferences (or using the stand-alone SheepShaverPrefs). After deleting the prefs file, SheepShaver needs to be set up again from the start.

A script that deletes the prefs file can be downloaded here: http://www.xs4all.nl/~ronaldpr/sheepsha ... cripts.zip

- The slirp networking should normally work when the host machine has a working internet connection, no special settings are needed. A problem would be if the Airport DHCP server would provide addresses in the same range as the addresses that SheepShaver uses (10.0.2.x). When your MacBook Pro is connected to the Airport network, you can find the provided IP address in System Preferences -> Network -> Advanced -> TCP/IP. Airport usually provides 10.0.1.x addresses. That does not interfere with SheepShaver's slirp networking.

- You do not use unusual firewall settings or additional firewall software?

More Info

Wed Jun 30, 2010 1:54 am

Hi Ronald, thank you for also answering. I'll try to answer your questions in order.

Yes, I am using SS 2.3 (25 Oct 2009 version).

I deleted the invisible prefs file and set up SS again. I deleted the file manually and also tried using the script. Both times it deleted, but no help with the networking. I also zapped the PRAM just for good measure.

I confirmed the slirp setting. I get the correct IP address in the TCP/IP Control Panel.

The network at my work assigns "10 Series" IP addresses (i.e. IP=, subnet=, router=

My router at home assigns "192 Series" IP addresses (i.e. IP=, subnet=255,255,255,0, router=

I tried with the Mac OS X firewall off and on (it's usually on).

Lastly - and this is strange - I can successfully hit the router's "home page" by entering into a browser address bar. So it appears that I can connect as far as the router, and I was also able to access another PPC machine running 8.6 using AppleShare in Chooser and selecting Server IP Address, then manually typing in the address of the 8.6 machine. But still no access to the Internet. In contrast, when I copied the same SS folder over to my PPC PowerBook (Tiger) everything worked fine upon booting without any changes.

Normally, I would exclude the router as the problem since SS on the PPC PowerBook can get on the internet, but just to be sure, I disabled the WEP encryption temporarily to see if that helped but it made no difference. SS on my Intel MacBookPro still cannot get on the internet.

Lastly, when I try to access www.google.com (or any other site) in iCab the error message I get is "Server "www.google.com" is currently inaccessible. (Network Error #-3264)"

Any ideas? I'm stumped, and I've been using networked Macs for over 20 years!

Much thanks.

P.S. Do Appletalk settings matter?

Wed Jun 30, 2010 6:19 am


Have you tried entering some external ip-address like google's ip-address so we can check whether the problem is DNS related?

Appletalk doesn't work without some tricks, so it's settings should not interfere with networking. I sooner guess it's a routing issue.

You might also try to set tcp/ip to manually, and enter these values:
subnet mask
router address
Name server: the dns your host machine uses



Wed Jun 30, 2010 11:39 am

Hi Cat_7,

Entering Google's IP address worked! So I guess we have a DNS issue. I'll try the manual entries you suggested and post back shortly.

Once again. much thanks for all of your help.



Wed Jun 30, 2010 12:55 pm

Well, after changing the manual settings of SS TCP/IP to the DNS servers that were in Mac OS X's Network System Prefs, there was no change.

But I decided to try using OpenDNS IP addresses ( and in SS TCP/IP control paned and these worked!!!

Thank you SO MUCH for your help - it is greatly appreciated. You'll also be pleased to know that once I was able to see my old Performa 6360 which runs 8.6, I was also able to print to the LaserWriter 320 that is attached to it via LPR printing from SS. I use the 6360 as a print server with Print66 running on it so that it can still accept print jobs. This became necessary when Snow Leopard stopped supporting AppleTalk. Fortunately, I found a way to keep my circa 1993 laser printer going - and why not? It still prints an amazingly sharp page!

Wed Jun 30, 2010 5:14 pm


Thanks for the feedback. Let's hope it will also help others that have problems with networking through the airport.


Re: Sheep Shaver, can't access internet/ethernet devices

Sat Aug 25, 2012 4:08 am

This helped me, I had the same issue, although the IP address for google I think is outdated. I used

I am on OSX 10.7.4
MPB 13 inch mid 2010

thanks from Michigan, U.S.A.

Re: Sheep Shaver, can't access internet/ethernet devices

Wed Jul 25, 2018 2:31 pm

i cannot connnect sheep shaver to my internet im using windows and it dosent work i click install and select the inf file and it types it that it didnt find anything in the ile i think that file is dead i need help :sad:

Re: Sheep Shaver, can't access internet/ethernet devices

Thu Jul 26, 2018 7:20 am

I don't know what you are trying to do. To get internet access, you do not need to install a driver.
Just follow the guide: set the network preference to slirp and set tcp/ip in Mac OS to automatically receive an IP address. Only if that doesn't work, enter the tcp/ip manually as indicated above.


Re: Sheep Shaver, can't access internet/ethernet devices

Fri Jul 27, 2018 9:26 am

ok i will try :sad:
Post a reply