Startup disk difficulty

About SheepShaver, a PPC Mac emulator for Windows, MacOS X, and Linux that can run System 7.5.3 to MacOS 9.0.4.

Moderators: Cat_7, Ronald P. Regensburg, ClockWise

Post Reply
xeper
Student Driver
Posts: 18
Joined: Tue Aug 25, 2009 2:09 am

Startup disk difficulty

Post by xeper »

Hi all. I'm running Sheepshaver 10/25/09 build on a MacBook w/ Snow Leopard (OS 10.6.3), using the New World Rom. It runs smoothly when I booted from an OS 9 startup CD, but I recently got an OS 8 startup CD (it's definitely legit), and when Sheepshaver tries to boot from it I get the following error message:
"This startup disk will not work on this Macintosh model. Use the latest Installer to update this disk for this model."
Already tried zapping the old prefs file. Any ideas? Different Rom file maybe?
User avatar
Cat_7
Expert User
Posts: 5099
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Post by Cat_7 »

Hi,

The most obvious reason for this message is that the disk is not a universal install disk, but is meant for a specific type of Mac. Those install disks don't work in SheepShaver (unless they are copied to hard disk and edited).

Running systems below 8.5 requires an old world rom.

Best,
Cat_7
xeper
Student Driver
Posts: 18
Joined: Tue Aug 25, 2009 2:09 am

Post by xeper »

Switching to the old world rom got me slightly farther (no error message), but when it says Welcome To Mac OS and begins to boot up off the OS 8 disc, suddenly Sheepshaver quits. Any idea why this might be happening?
User avatar
Ronald P. Regensburg
Expert User
Posts: 6388
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Post by Ronald P. Regensburg »

You can use a new world rom only with MacOS 8.6 through 9.0.4, so if the system install disk is MacOS 8.0 or 8.1, switching to the old world rom is indeed the solution.

The crash could be the "known issue" mentioned in the setup manual, see that chapter in the manual for description and solution: http://www.emaculation.com/doku.php/she ... own_issues
xeper
Student Driver
Posts: 18
Joined: Tue Aug 25, 2009 2:09 am

Post by xeper »

Thanks for the known bug tip, although unfortunately that didn't fix the issue. I'll keep fiddling around with it, let me know if you have any ideas! Thanks guys!
xeper
Student Driver
Posts: 18
Joined: Tue Aug 25, 2009 2:09 am

Post by xeper »

Although interestingly, that SIGSEGV string is present when I check the Console log. It probably is that bug, guess I'm one of the rare cases.
xeper
Student Driver
Posts: 18
Joined: Tue Aug 25, 2009 2:09 am

Post by xeper »

Out of curiosity, has anyone gotten OS 8 to run successfully on Sheepshaver?
User avatar
Cat_7
Expert User
Posts: 5099
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Post by Cat_7 »

Yes,

I run MacOS 7.5.3/5, 8.0, 8.1 8.5/6 and 9.0.4 on SheepShaver.
You need an oldworld rom file to run anything below 8.5

Best,
Cat_7
Post Reply