Building SheepShaver x86 Linux

About SheepShaver, a PPC Mac emulator for Windows, MacOS X, and Linux that can run System 7.5.3 to MacOS 9.0.4.

Moderators: Cat_7, Ronald P. Regensburg, ClockWise

User avatar
javier_garza4
Tinkerer
Posts: 68
Joined: Thu Nov 28, 2002 8:59 pm
Location: El Paso

Post by javier_garza4 »

guess what i did? i learned how to extract rpms in live cds and it shoud work on all other distros.
do this in a konsole thing: {rpm2cpio whatever.rpm | cpio --extract --verbose --make-directories}
DO NOT INCLUDE THE BRACKETS AT THE BEGGINING AND THE END.
everything else is exactly the same, even the spaces.
ivanhasyou
Student Driver
Posts: 23
Joined: Wed Jan 08, 2003 2:26 am
Location: Right behind you!

Post by ivanhasyou »

has anybody had any luck compiling this on slackware 9.1? if so, which packages did you select from the dev packages when installing from the cd, and did you add any packages related to programming from the web?
User avatar
ClockWise
Site Admin
Posts: 4032
Joined: Mon May 20, 2002 4:37 am
Location: Uiwang
Contact:

Post by ClockWise »

I installed EVERY SINGLE PACKAGE from my SlackWare CDs. It was a huge install, and I had to do it twice (I'm dumb)... but SheepShaver compiled and runs very very well.
Guest

Post by Guest »

I had the same problem, only that also a AM_PATH_ESD error occured further up. After installing libesd0-dev it worked.

Robert

Ranbaz wrote:Hello,

When I tried to compile from the CVS I've got :

./configure: line 2851: syntax error near unexpected token `1.2.0,'
./configure: line 2851: ` AM_PATH_GTK(1.2.0, '

I have GTK+1.2.
An idea ?
Bye
MacNoobie
Space Cadet
Posts: 6
Joined: Sun Apr 18, 2004 10:53 pm

Post by MacNoobie »

Argh, please port it to win32, i have found that Basilisk II run incredibly well on a P4 2.8G, and this could be my only chance to run (crazy or not) old games, since the DOS emulation out there sucks big time (run worse than trying to emulate an Alpha processor, well you got the idea), and i have read that Dark Forces had better graphics on the Mac.
robojam
Forum All-Star
Posts: 780
Joined: Thu Apr 17, 2003 10:52 pm
Location: Charlotte, NC. USA

Post by robojam »

As nice as it would be to have a Windows port, I think that will be some way off. Linux has the advantage that the source code for all of the operating system files is available as open source, so it is far easier to debug something. Windows however, is very much closed source so unless someone is very adept as debugging disassembled machine code it is very difficult to program something that works on such a low level as an emulator.

Hopefully someone can port the Linux version to Windows, but it's probably better to pin your hopes on improvements in the linux version.
Guest

Post by Guest »

ShadowFox wrote:I'm having an issue compiling from CVS. The autogen script seems to run fine, and returns this:

Code: Select all

SheepShaver configuration summary:

XFree86 DGA support .............. : yes
XFree86 VidMode support .......... : yes
Using PowerPC emulator ........... : yes
Enable JIT compiler .............. : yes
Enable video on SEGV signals ..... : no
ESD sound support ................ : yes
GTK user interface ............... : yes
mon debugger support ............. : no
Bad memory access recovery type .. :

Configuration done. Now type "make".
Afterwards, running make, it stops on this:

Code: Select all

g++ -I../kpx_cpu/include -I../kpx_cpu/src -DUSE_JIT -I../include -I. -DHAVE_CONFIG_H -D_REENTRANT -DDATADIR="/usr/local/share/SheepShaver" -g -O2  -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include  -c ../kpx_cpu/sheepshaver_glue.cpp -o obj/sheepshaver_glue.o
../kpx_cpu/sheepshaver_glue.cpp:717:2: #error "FIXME: You don't have the capability to skip instruction within signal handlers"
make: *** [obj/sheepshaver_glue.o] Error 1
I sort of ran through the code quick (I'm new to C/C++, just starting to learn... hope to help out this project some day when I pick up enough to be useful), and it seems to be related to the SEGV functions. I'm running Gentoo 1.4, kernel 2.6.2, and gcc 3.2.3r3. Anything I can do? Thanks!!
User avatar
Trombone Bob
Tinkerer
Posts: 85
Joined: Mon Apr 26, 2004 3:32 pm
Location: Utah, USA

Post by Trombone Bob »

Get the cpu patch. Follow the direction at the topic "SheepShaver on Windows via coLinux". Gentoo need this for some reason.
DualC
Student Driver
Posts: 21
Joined: Wed Jul 14, 2004 3:45 pm

Post by DualC »

Hello.

I have, installed the newest Mandrake 10.2, Limited Edition 2005 today..

Now i wonder if somone can tell me and other witch, packets we have to install to make SheepShaver compile correctly on whis system.

Whis system is striped soo much libraries ans so on is not included on the 3 Cd version.. of the dist, but can be downloaded as RPM from diffrent FTP servers.

SO somone who CAN tell us, please do so.

/mattias
iMac600
Student Driver
Posts: 14
Joined: Mon May 01, 2006 12:02 pm
Location: Adelaide, SA

Post by iMac600 »

The rom with the checksum 96CD923D is from an Apple Prototype,
the Macintosh PowerExpress.

Anyone still have this file? I would be interested in testing it. AFAIK, it
may not be Warez due to the fact it never went to use or production.

If you do, can you please email it to me? (imac600x@gmail.com)
Post Reply