CD-ROM not booting: Mandrake 9.2, SheepShaver-2.2-8.i586 RPM

About SheepShaver, a PPC Mac emulator for Windows, MacOS X, and Linux that can run System 7.5.3 to MacOS 9.0.4.

Moderators: Cat_7, Ronald P. Regensburg, ClockWise

Post Reply
Kilik

CD-ROM not booting: Mandrake 9.2, SheepShaver-2.2-8.i586 RPM

Post by Kilik »

Hi,

got a problem with SheepShaver 2.2.8 (Mandrake RPM). Everything is fine with the setup and there's also no error message etc. It boots but suddenly stops at the grey screen: There seems to be some kind of a floopy booting but after this process the CD-ROM (with the OS CD) isn't responding and everythings seems to freeze.

It's the 8.6 CD (ROM included).

Thanks

Bye

Kilik
Guest

Post by Guest »

Make sure you un-mount the cd in linux

The same thing happened to me, after i did 'umount /mnt/cdrom' it worked :P
Mac Emu
Forum All-Star
Posts: 1217
Joined: Mon May 20, 2002 11:50 am
Location: Ouraion

Post by Mac Emu »

In your home directory is a hidden file, I believe called .sheepshaver_prefs. Using a text editor, what are the contents of this file (copy\paste it here)?

What ROM are you using (the one on the CD doesn't work as it's a New World ROM)?

If you run SheepShaver from a terminal prompt, are there any error messages?
Trancesphere
Space Cadet
Posts: 3
Joined: Fri Jan 23, 2004 9:47 pm

Post by Trancesphere »

What ROM are you using (the one on the CD doesn't work as it's a New World ROM)?
The ROM on the 8.6 CD does work with 2.2-8

Im using it myself :lol:
Kilik

Post by Kilik »

First of all "Thanks" for you answers. Unfortunatly it's still not working.
Tried to un-mount the drive but still no response.

My CD also isn't booting in (working) Basilisk II (8.1) / Win32

I have tried to "boot" the 8.1-HD-Image (with some stuff on it) from Basilisk II in SheepShaver. It's not working too - [maybe because of the New World Rom from the 8.6 CD for PPCs?]

Thanks again

Kilik
Thyth

Post by Thyth »

Well, my first SheepShaver test was to see if I got one of the Mac BIOS icon responses(I used a ROM from my 7500/100). This usually reports the smiling Mac if everything is working properly. If there is no disk found it will have a disk icon with a flashing "?" on it. If there is an invalid system disk it will flash an "X" on the disk. Do you get any of those icons?
Kilik

Post by Kilik »

No, i don't get any of these icons. I am not familiar with the old Mac Operating Systems (just experience with 10 / and of course Linux/Win).

What should be on the screen with a working rom in combination with a NOT installed OS (empty HD)? The "disk" icon?

There should be some reaction?! But there's just the grey screen and no Smiling Computer and there are also no errors in the console (Linux).

I don't get it. ?
Mac Emu
Forum All-Star
Posts: 1217
Joined: Mon May 20, 2002 11:50 am
Location: Ouraion

Post by Mac Emu »

In your home directory is a hidden file, I believe called .sheepshaver_prefs. Using a text editor to open it, please paste the contents of this file here.

If you run SheepShaver from a terminal prompt, are there any error messages?

./SheepShaver
User avatar
phirkel
Apple Corer
Posts: 238
Joined: Thu Feb 27, 2003 10:09 pm

Post by phirkel »

Sounds to me like automount has struck again.

I don't know whether that code is a curse or a blessing for the average user, but I tend to lean towards the curse side...I don't like having the computer do funny stuff with my media behind my back.

Recompile your kernel without Automounting support (if you're unfamiliar with the procedure, check out http://www.tldp.org for a fantastic HOWTO on Kernel Recompiling). If you still have any problems after recompiling without Automounting, PM me and I'll see what I can do.

I wholeheartedly recommend people choose a less "Pampering" Linux distro, because you learn the OS FAR better. Debian or Gentoo are good places to start. Same with LFS ;)
Kilik

Post by Kilik »

Thanks again,

i have read in this forum that the ROM from the OS 8.6 Install CD should work - but it's not working for me (right now). Maybe i'm doing something wrong?

I have installed (not compiled) the 2.2.8 RPM + Mandrake 9.2. I have 2 CD/DVD-ROMS.

Here's what the hidden prefs-File says:

disk /home/xxx/Mac OS
extfs /home/xxx/
windowmodes 3
screenmodes 0
seriala /dev/tts/0
serialb /dev/tts/1
rom Mac OS ROM
bootdrive 0
bootdriver -62
ramsize 134217728
frameskip 1
gfxaccel true
nocdrom false
nonet false
nosound false
nogui false
noclipconversion false
ignoresegv true
jit true
keyboardtype 5
keycodes false
mousewheelmode 1
mousewheellines 3
dsp /dev/sound/dsp
mixer /dev/sound/mixer
ignoresegv true

Thanks
Kilik

Post by Kilik »

What should on the screen if the rom from the OS 8.6 Install CD is used? The Smiling Mac? Or something else?

Thanks
Thyth

Post by Thyth »

Well, when I had no disks installed to SheepShaver I got the questionmark.
Kilik

Post by Kilik »

Hi Thyth,

which rom are you using? I have (like i have written before) the rom from the 8.6 CD and of course the 8.6 CD.

Which Linux Distro & which SheepShaver Versionb are you using?

Do the Icons (Smiling Mac etc.) appear before the Floppy/CD-Drives are initialized?

Thanks!
Thyth

Post by Thyth »

A rom I pulled from an old-world 7500/100 Power Mac I have sitting around. I'm using Slackware 9.0 with the 1-25-04 CVS build of SheepShaver. I'm assuming that it initializes the floppy and CD first to determine that it can't boot from the disks. Have you tried booting it without any disks at all?
Post Reply