Login  •  Register


The time is now: Wed Jun 19, 2019 8:48 am

Emaculation wiki  •  Delete all board cookies



Post new topic  Reply to topic Page 1 of 1 [ 15 posts ]
Print view Previous topic  |  Next topic
Author Message
PostPosted: Tue Feb 17, 2004 4:46 pm 
I just compiled SheepShaver from the gwenole's tarball, and when I run it is says:

claunia@zeus claunia $ SheepShaver
SheepShaver V2.2 by Christian Bauer and Mar"c" Hellwig
Reading ROM file...
claunia@zeus claunia $

What is the error?
It says nothing :s
I tried 6 different ROM files from following machines:
PowerMacintosh G3 Beige
PowerMacintosh 9500 (dated of 1995)
PowerMacintosh 9500 (dated of 1996)
PowerMacintosh 7x00/8x00/9x00
MacOS ROM 1.6
MacOS ROM 3.8

All of these makes the same behaviour.

Any idea?


Top
  
Reply with quote Post a reply  
 Post subject:
PostPosted: Tue Feb 17, 2004 5:25 pm 
- I cannot remember which roms are supported. That is well documented in other posts.

It is possible your console is set to pipe messages elsewhere. You could start by giving more information about your build as otherwise it is a bit cryptic. Which tarball? Have you tried an earlier version? Did you check your log files? Are you logging xfree86 messages? If you have run sheepshaver before have you tried removing ~/.sheepshaver_prefs?

I think the first thing I would do is su root as it may be a permissions issue. If that doesnt work try installing the binary from the rpm.


Top
  
Reply with quote Post a reply  
 Post subject: uh oh
PostPosted: Wed Feb 18, 2004 12:34 am 
tarball is SheepShaver-2.2-20040114.tar.bz2, never runt before and what log files should I check?
The XF86 and VNC ones says nothing.


Top
  
Reply with quote Post a reply  
 Post subject:
PostPosted: Wed Feb 18, 2004 11:34 am 
Quote:
I think the first thing I would do is su root as it may be a permissions issue. If that doesnt work try installing the binary from the rpm.


Top
  
Reply with quote Post a reply  
 Post subject: Uh oh
PostPosted: Thu Feb 19, 2004 12:48 am 
Tried both, same behaviour.


Top
  
Reply with quote Post a reply  
 Post subject:
PostPosted: Thu Feb 19, 2004 1:16 am 
Offline
Forum All-Star
User avatar

Joined: Mon May 20, 2002 11:50 am
Posts: 1217
Location: Ouraion
Try zapping the pram from the SheepShaver GUI.

Maybe it is a configuration problem? Could you copy\paste the contents of your hidden .sheepshaver_prefs file located in your home directory?

PS: I'm just a newbie to Linux and SheepShaver, so can't be of much help for awhile.


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Thu Feb 19, 2004 3:48 am 
Offline
Site Admin
User avatar

Joined: Mon May 20, 2002 4:37 am
Posts: 3719
Location: Uiwang
Looks like he hit the tree, Jim.


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Thu Feb 19, 2004 1:27 pm 
I had similar problems. (There was no output but "Reading ROM file...") After I started the program with the "--nogui true" option, I got something like that:

ERROR: Invalid ROM file size. SheepShaver requires a 4MB PCI PowerMac ROM.
...
Gdk-ERROR **: BadWindow (invalid Window parameter)
serial 7 error_code 3 request_code 4 minor_code 0

The first line seemed strange to me, because I am useing the MacOS-ROM from my 8.5 disk that's reported to be compatible with SheepShaver. The last line indicated some compatiblity-problems with the gtk-libraries that came with my distribution (still SuSE Linux 8.2, gtk-config --version : 1.2.10). So I compiled a new version without gtk-support (make clean && ./autogen.sh --without-gtk && make).
The "incompatible rom"-message seems to be thrown out incorrectly: Without gtk SheepShaver boots perfectly - with the same roms it refused some minutes ago...very strange, indeed...
(Sidenote: After you've disabled gtk, you either have to edit your config-file manually, set the required parameters at the command-line or - like me - build a second SheepShaver-tree with gtk enabled just for the setup-window)


Top
  
Reply with quote Post a reply  
 Post subject:
PostPosted: Thu Feb 19, 2004 8:41 pm 
I tried with --nogui true as you suggested and says me an error only when using software roms, and the same gtk+ error.
Tried to compile without gtk and then it returns an undefined reference about the PrefsEditor(), that of course, should be disabled at all.

Where did you get the source?


Top
  
Reply with quote Post a reply  
 Post subject:
PostPosted: Thu Feb 19, 2004 8:54 pm 
I tried the latest cvs-version. Don't forget the "make clean" before rebuilding (or re-checkout the cvs-code in a new directory)


Top
  
Reply with quote Post a reply  
 Post subject:
PostPosted: Thu Feb 19, 2004 10:19 pm 
Could you make a tarball of your source tree. I just checked out the CVS and it lacks some files, e.g. config.sub and config.guess.


Top
  
Reply with quote Post a reply  
 Post subject:
PostPosted: Thu Feb 19, 2004 10:46 pm 
Hm, did you create the links to BasiliskII with "make links"? Just follow the tutorial at:
http://www.emaculation.com/phpBB/viewtopic.php?t=738

I tested it with a cvs-version checked out a minute ago, the actual cvs-release seems to be complete. If there are still problems I can send you my precompiled tarball tomorrow. (I don't have any webspace, just send me your email-address to strixnerATwebDOTde)


Top
  
Reply with quote Post a reply  
 Post subject:
PostPosted: Fri Feb 20, 2004 2:26 pm 
Claunia: you are really confusing. You started off this post with:
Quote:
just compiled SheepShaver from the gwenole's tarball,

but most recently:
Quote:
Could you make a tarball of your source tree. I just checked out the CVS and it lacks some files, e.g. config.sub and config.guess.

As has been pointed out these links are made with make links. These files are part of BasiliskII so are not missing.
So you could not have compiled SheepShaver in the first place if you did not know about this. Try reading before posting and stop being so arrogant.[/quote]


Top
  
Reply with quote Post a reply  
 Post subject: Trolling
PostPosted: Fri Feb 20, 2004 4:07 pm 
I'm not arrogant, just in the website says to checkout both trees but says nothing about having to make links manually.


Top
  
Reply with quote Post a reply  
 Post subject:
PostPosted: Fri Feb 20, 2004 7:02 pm 
You have been whinging about lack of error messages when you could not have compiled SheepShaver in the first place. If you dont take on board what people are suggesting and read the posts available then lie about what you have and have not done it doesnt help anyone.
Quote:
I'm not arrogant, just in the website says to checkout both trees but says nothing about having to make links manually.

Marked in bold for your benefit.
Quote:
*****
Jackalo's "Unofficial SheepShaver Building Guide"

*****

Situate yourself in a directory from your flavor of Linux that you want to hold the SheepShaver files. In my case, I used "cd /home/jackalo". After that, you need to establish a connection with Gwenole's CVS server. The following commands will provide a login and then a clean download of the files that you need. You do need to type them out fully, as I have yet to figure out how to set the CVSROOT variable.

cvs -d :pserver:anoncvs@down.physik.uni-mainz.de:/cvs login
(asks for password) anoncvs

cvs -d :pserver:anoncvs@down.physik.uni-mainz.de:/cvs checkout BasiliskII
cvs -d :pserver:anoncvs@down.physik.uni-mainz.de:/cvs checkout SheepShaver

Next, you need to browse to the SheepShaver directory and run the Makefile there to create links to the BasiliskII source files required to build SheepShaver. Use the following commands to do that.

cd SheepShaver
make links

After that finishes, you now need to browse into the src/Unix directory, and then execute autogen.sh to create the necessary makefile dependant upon your system. Use the following commands for that.

cd src/Unix
./autogen.sh

After that finishes, it'll tell you to type "make". Well, do what the doctor orders.

make

If things go alright, you should have a compiled version of SheepShaver glaring at you with it's beady little eye. Execute the file to launch it's configurations dialog.

./SheepShaver

Configure what you will, and make sure to set the ROM name on the fourth tab. You might as well disable sound on the second tab, and clear the Ethernet box on the third tab.
[/b][/quote]


Top
  
Reply with quote Post a reply  
Display posts from previous:  Sort by  
Post new topic  Reply to topic Page 1 of 1 [ 15 posts ]


Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
 

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group