Login  •  Register


The time is now: Thu Aug 06, 2020 4:28 pm

Emaculation wiki  •  Delete all board cookies



Post new topic  Reply to topic Page 2 of 2 [ 32 posts ]    Go to page Previous  1, 2
Print view Previous topic  |  Next topic
Author Message
PostPosted: Sun Apr 05, 2020 8:35 pm 
Offline
Space Cadet

Joined: Wed Apr 20, 2016 8:56 am
Posts: 6
galgot wrote:
RaspberryPhil wrote:
galgot wrote:
@ RaspberryPhil
...
Did you try using sudo when starting sheepshaver?


!! :oops:
Of course, that is the thing I was forgetting...
It runs now with sudo.
Many thanks :)


Nice, good to hear!! Have fun!


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Fri May 22, 2020 12:24 am 
Offline
Space Cadet

Joined: Thu May 21, 2020 11:44 pm
Posts: 3
Location: New York, USA
Hi,
I am amazed at this project and wanted to bring up a MacOS to show the kids how it looked and feel back in the day.

I didn't want to resurrect this thread, but I tried absolutely everything in every single post on this thread. Tried all the values for memory from 8 to 256MB.

I'm trying to run it on a RaspberryPI 4 with 4GB of RAM. Tried on a RaspberryPi 3 V1.2 with 1GB of RAM as well. Same exact errors.
I did only move the SD card from one Pi to the other though.

After it starts succesfully and I am adding the CDROM and disk, when I click 'Start', SheepShaver crashes with:

""Cannot map Low Memory Globals: Invalid Argument.""
Then throws this error in the terminal.
++++++
pi@raspberrypi:~ $ sudo SheepShaver
SheepShaver V2.4 by Christian Bauer and Mar"c" Hellwig
The program 'SheepShaver' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
(Details: serial 9 error_code 2 request_code 105 minor_code 0)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)
pi@raspberrypi:~ $
+++++

I did compile it from source from https://github.com/cebix/macemu and followed the instructions outlined here -- https://www.emaculation.com/doku.php/co ... r_basilisk

Building SheepShaver in Linux flavours:
SheepShaver currently suffers from issues regarding running in a window/full screen. For full screen support, follow the directions below. However, if you want a stable build for windowed use, delete “–enable-sdl-video” and “–enable-sdl-audio” from the ./configure step.
Ubuntu, Fedora, SuSE:
cd to the SheepShaver folder and:
make links
cd src/Unix
NO_CONFIGURE=1 ./autogen.sh
./configure --enable-sdl-video --enable-sdl-audio --disable-vosf
make
strip SheepShaver

The RaspberryPi 4 & 3 are running this OS:
pi@raspberrypi:~ $ cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"
VERSION_CODENAME=buster
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"
pi@raspberrypi:~ $

I would really appreciate any help or direction.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Tue May 26, 2020 6:59 pm 
Offline
Granny Smith

Joined: Thu Feb 13, 2014 3:59 pm
Posts: 101
Hi ,
have you tried with this build ? :
https://www.novaspirit.com/?smd_process ... oad_id=558
posted on the previous page by RaspberryPhil.
It's the only one I could make work on my R-PI 3. Must be run with sudo.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Wed May 27, 2020 5:15 pm 
Offline
Space Cadet

Joined: Thu May 21, 2020 11:44 pm
Posts: 3
Location: New York, USA
That worked better, Thank you!
I did download that image made by Novaspirit, was able to install MacOS9 half way but then crashes.
It is better than before when it would just crash. At least I can see it boot and launch the install.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Wed May 27, 2020 7:56 pm 
Offline
Space Cadet

Joined: Wed Apr 20, 2016 8:56 am
Posts: 6
Hi, find and use a pre-installed image on the net with google using '-inurl:htm -inurl:html intitle:”index of” os9.img':

http://jackparker.world/swamp/SheepShaver_stock/
http://newtoncity.org/NewtonFiles/Dev/


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Mon Jun 01, 2020 8:11 pm 
Offline
Space Cadet

Joined: Mon Jun 01, 2020 5:09 pm
Posts: 1
Hi there,

I am looking for current and up to date instructions for installing SheepShaver on Raspberry Pi and getting MacOS running. I have not found anything current online, many tutorials are rather dated.

Hardware: Raspberry Pi 4
OS: Raspberry Pi OS Version May 2020.

Would really appreciate any good links.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Thu Jun 11, 2020 9:53 pm 
Offline
Space Cadet

Joined: Thu May 21, 2020 11:44 pm
Posts: 3
Location: New York, USA
Thank you all, it worked in the end with MacOS9.0.4. Tried the 9.1 and 9.2 couldn't make the Sheepshaver boot from the ISO. I had to make them read-only (chmod 400) to 'trick' the emulator to boot.
Thanks to RaspberryPhil, I got the disk and ROM from here http://newtoncity.org/NewtonFiles/Dev/

Short instructions on how I made them work:
Make a directory: mkdir -p /home/pi/macOS9 and cd to it;
Download the ROM and OS9 image from http://newtoncity.org/NewtonFiles/Dev/
Unzip 'Mac OS ROM.zip' . The ROM file should be 'Mac OS ROM' do not rename it, if you want SheepShaver to automagically find it.
Download the ppc and Sheepshaver from here -- https://www.novaspirit.com/?smd_process ... oad_id=558 -- ppc is PearPC for emulating MacOSX. Very slow on RaspberryPi.
They come zipped in MacARM.7z package.
Install p7zip if you don't have it (sudo apt install -y p7zip) then 'p7zip -d MacARM.7z' It will expand/decompress 2 files - ppc and SheepShaver.
Make SheepShaver executable - 'chmod +x SheepShaver'
Launch ./SheepShaver then:
Volumes tab:
- add the OS9.img
- Boot From - Any
Graphics/Sound tab:
- Video Type = Window
- Window Refresh Rate = 30 Hz
- Width = 1024
- Height = 768
Keyboard/Mouse tab - nothing to configure;
Serial/Network - nothing to configure
Memory/Misc tab:
- MacOS RAM Size = 256
- ROM File - either leave it blank, or Browse and select Mac OS ROM
- Select 'Ignore Illegal Memory Accesses
JIT Compiler tab - nothing to configure.
Click 'Start' and you should be able to enjoy MacOS 9.


Last edited by Ronald P. Regensburg on Fri Jun 12, 2020 7:18 am, edited 1 time in total.
Removed direct links to ROM and OS9 image (not allowed on this board)


Top
 Profile  
Reply with quote Post a reply  
Display posts from previous:  Sort by  
Post new topic  Reply to topic Page 2 of 2 [ 32 posts ]    Go to page Previous  1, 2


Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
 

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group