Login  •  Register


The time is now: Wed May 27, 2020 6:12 am

Emaculation wiki  •  Delete all board cookies



Post new topic  Reply to topic Page 1 of 1 [ 5 posts ]
Print view Previous topic  |  Next topic
Author Message
 Post subject: SheepSaver won't start
PostPosted: Sun Oct 11, 2015 11:50 am 
Offline
Space Cadet

Joined: Sun Oct 11, 2015 11:09 am
Posts: 4
Hi all,

I am trying to get OS 9.1 running as I must convert legacy raw image data with an old PPC program called eyelike precision. While using Basilisk I couldn't get a proper installation, though.

By trying SheepSaver the app won't even start. I recognized that settings from Basilisk were added (could verify by using SheepShaverPrefs) for some reason so I removed the hidden files. Using SheepShaverPrefs again everything was reset. Despite using the SheepSaver manual as a blueprint for the configuration SheepSaver won't start either.

Does anyone have a suggestion?

Thanks a lot
Mike


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Sun Oct 11, 2015 12:26 pm 
Offline
Expert User
User avatar

Joined: Thu Feb 09, 2006 10:24 pm
Posts: 5961
Location: Amsterdam, Netherlands
Yes, BasiliskII emulates a 68k Mac and cannot run PPC applications.

You write about hidden files, so I suppose you are trying SheepShaver for OSX. Which OSX version on your host machine?

- Note that SheepShaver can run System 7.5.3 through MacOS 9.0.4. It will not run MacOS 9.1 or later.
- You do not need the SheepShaverPrefs application. In fact, when the settings can be accessed in SheepShaver preferences it is better to use that. When you get SheepShaver running you, can access the settings in SheepShaver preferences.
- SheepShaver will only run with a compatible ROM file available in the same folder. For first start, with no settings configured (no prefs file or blank prefs file), that ROM file needs to be named "Mac OS ROM" (without quotation marks and without file name extension).

Alle this is explained in our setup manual: http://www.emaculation.com/doku.php/she ... os_x_setup


Last edited by Ronald P. Regensburg on Sun Oct 11, 2015 12:28 pm, edited 2 times in total.
 


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Sun Oct 11, 2015 12:56 pm 
Offline
Space Cadet

Joined: Sun Oct 11, 2015 11:09 am
Posts: 4
Hi Ronald,

thanks a lot for your fast reply. Putting the ROM file in the SheepSaver folder and naming it accordingly brought me one step forward.

I am operating OS X 10.10.5 Yosemite. I have removed the preferences in ~/ again, put various ROMs in the SheepSaver folder and tried starting. So far only original ROMs copied from the System Folder in the install CD were successful. Unfortunately 9.0.4 from WinWorld didn't work.

By trying with the 8.6 ROM and install disk or image SheepSaver keeps ejecting the CD and on launch showing the disk icon with the question mark.

Kind regards
Mike


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Sun Oct 11, 2015 1:37 pm 
Offline
Expert User
User avatar

Joined: Thu Feb 09, 2006 10:24 pm
Posts: 5961
Location: Amsterdam, Netherlands
I suggest you read the setup manual closely from the beginning before you start trying all sorts of things that will not work. You will then see that:

- For MacOS 8.5 or later, you best use the newworld rom file that can be downloaded from Redundant Robot.
- OSX 10.8 and later prevent mounting of physical CDs. You will need the workaround with disk images created form the CD.
- Only general retail system install CDs (or images from such CDs) will work. CDs that were provided with a specific Mac model (usually with grey label) will not.
- A system install CD image file needs to be locked in the Finder (Finder Info), should NOT be mounted in OSX, and needs to be added to the volumes list in SheepShaver preferences.

(The 9.0.4. install CD .iso image from WinWorld works fine here.)


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Sun Oct 11, 2015 1:41 pm 
Offline
Space Cadet

Joined: Sun Oct 11, 2015 11:09 am
Posts: 4
That brings the pieces together. I sticked to your tutorial first but got stuck. Through the course of trail & error I got my mind totally messed up then. Thanks for your advices. Going to reset myself xD


Top
 Profile  
Reply with quote Post a reply  
Display posts from previous:  Sort by  
Post new topic  Reply to topic Page 1 of 1 [ 5 posts ]


Who is online

Users browsing this forum: Google [Bot] and 27 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
 

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group