Login  •  Register


The time is now: Sat Nov 18, 2017 11:20 pm

Emaculation wiki  •  Delete all board cookies



Post new topic  Reply to topic Page 1 of 1 [ 4 posts ]
Print view Previous topic  |  Next topic
Author Message
PostPosted: Thu Mar 02, 2017 7:08 pm 
Offline
Space Cadet

Joined: Tue Nov 24, 2015 2:26 am
Posts: 3
Sometimes I am able to access one website:
Image
But when I try to access another, this happens:
Image

Sometimes, I can't access any websites at all; SheepShaver just dies saying "Segmentation fault". This is with "Ignore illegal memory accesses" turned on. With it turned off, it always dies with a segmentation fault when I try to access a website. It does this in Netscape 4 and iCab.

Here is my prefs file:
Code:
disk /home/****/projects/macemu/SheepShaver/res/disks/boxhd
disk /home/****/projects/macemu/SheepShaver/res/disks/hda
extfs /home/ryan
screen win/832/624
windowmodes 0
screenmodes 0
seriala /dev/null
serialb /dev/ttyS3
rom /home/****/projects/macemu/SheepShaver/res/roms/mac_oldworld_rom4mb.rom
bootdrive 0
bootdriver 0
ramsize 67108864
frameskip 1
gfxaccel true
nocdrom false
nonet false
nosound false
nogui false
noclipconversion false
ignoresegv true
ignoreillegal false
jit false
jit68k true
keyboardtype 5
ether slirp
keycodes false
mousewheelmode 0
mousewheellines 3
dsp /dev/dsp
mixer /dev/mixer
ignoresegv true
idlewait false


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Sun Oct 08, 2017 9:07 pm 
Offline
Student Driver
User avatar

Joined: Sat Feb 04, 2017 5:12 am
Posts: 17
Location: Argentina
Which version of Mac OS are you emulating?

_________________
Compact Macs will rule supreme for all eternity! :twisted:


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Mon Oct 16, 2017 10:51 pm 
Offline
Space Cadet
User avatar

Joined: Mon Oct 16, 2017 10:06 pm
Posts: 2
Location: Iowa
It totally crashes for me when I boot using slirp. It runs fine until I try to use networking, then it crashes. It'll even crash opening up the TCP/IP control panel if it's using slirp.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Tue Oct 17, 2017 8:11 am 
Offline
Expert User
User avatar

Joined: Thu Feb 09, 2006 10:24 pm
Posts: 4828
Location: Amsterdam, Netherlands
slirp networking is known to be not very robust, but I never heard of crashes when doing nothing but opening TCP/IP control panel. You can try removing TCP/IP preferences from the Preferences folder in System Folder and launch SheepShaver again. Then make sure the control panel is set to Ethernet and DHCP.

Which are your host and guest OS versions?


Top
 Profile  
Reply with quote Post a reply  
Display posts from previous:  Sort by  
Post new topic  Reply to topic Page 1 of 1 [ 4 posts ]


Who is online

Users browsing this forum: Google [Bot] and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
 

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group