E-Maculation
https://www.emaculation.com/forum/

Can't access webpages using slirp
https://www.emaculation.com/forum/viewtopic.php?f=20&t=9235
Page 1 of 1

Author:  bigmac [ Thu Mar 02, 2017 7:08 pm ]
Post subject:  Can't access webpages using slirp

Sometimes I am able to access one website:
Image
But when I try to access another, this happens:
Image

Sometimes, I can't access any websites at all; SheepShaver just dies saying "Segmentation fault". This is with "Ignore illegal memory accesses" turned on. With it turned off, it always dies with a segmentation fault when I try to access a website. It does this in Netscape 4 and iCab.

Here is my prefs file:
Code:
disk /home/****/projects/macemu/SheepShaver/res/disks/boxhd
disk /home/****/projects/macemu/SheepShaver/res/disks/hda
extfs /home/ryan
screen win/832/624
windowmodes 0
screenmodes 0
seriala /dev/null
serialb /dev/ttyS3
rom /home/****/projects/macemu/SheepShaver/res/roms/mac_oldworld_rom4mb.rom
bootdrive 0
bootdriver 0
ramsize 67108864
frameskip 1
gfxaccel true
nocdrom false
nonet false
nosound false
nogui false
noclipconversion false
ignoresegv true
ignoreillegal false
jit false
jit68k true
keyboardtype 5
ether slirp
keycodes false
mousewheelmode 0
mousewheellines 3
dsp /dev/dsp
mixer /dev/mixer
ignoresegv true
idlewait false

Author:  macplus [ Sun Oct 08, 2017 9:07 pm ]
Post subject:  Re: Can't access webpages using slirp

Which version of Mac OS are you emulating?

Author:  Wozinator [ Mon Oct 16, 2017 10:51 pm ]
Post subject:  Re: Can't access webpages using slirp

It totally crashes for me when I boot using slirp. It runs fine until I try to use networking, then it crashes. It'll even crash opening up the TCP/IP control panel if it's using slirp.

Author:  Ronald P. Regensburg [ Tue Oct 17, 2017 8:11 am ]
Post subject:  Re: Can't access webpages using slirp

slirp networking is known to be not very robust, but I never heard of crashes when doing nothing but opening TCP/IP control panel. You can try removing TCP/IP preferences from the Preferences folder in System Folder and launch SheepShaver again. Then make sure the control panel is set to Ethernet and DHCP.

Which are your host and guest OS versions?

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/