E-Maculation
https://www.emaculation.com/forum/

Video problems in Diablo
https://www.emaculation.com/forum/viewtopic.php?f=20&t=9476
Page 1 of 1

Author:  gordie124 [ Wed Sep 13, 2017 2:05 am ]
Post subject:  Video problems in Diablo

I'm running the original Diablo Game on Mac OS 9.04 through Sheepsaver on my MacBook, running 10.7 Lion. I've managed to get the game mostly running smoothly, with one vexing problem. Midway through the game (during the Lazurus encounter), there is an unavoidable video cutscene which fails to load each time I encounter it, freezing the game and forcing me to quit. Too bad. :(

I've searched in vain for some solutions on this board, but have run out of things to try. But I'm sure there are some ideas I'm overlooking — is there any way to download additional extensions or drivers that might be needed? Names? I'm running the version of quicktime included in my Mac OS 9 install.

Some additional details — the first second of sound on the video plays, but the video doesn't load (just a black screen). A similar thing happens with the studio logo video every time I start the game, although that one can be skipped with a mouse click. No such luck with the game freezing Lazurus vid. Interestingly, the first time I opened the game after installing, the studio logo video played OK. This happened after I reinstalled the software as well — it played OK once, and then never again. Very mysterious.

If anyone can shed some light on what might be happening, or share ideas of how I might proceed, I'm game to hear them. Thanks. :)

ETA: I have an in-depth guide that mentions that in the PC version, the video files can be disabled by changing a particular file's location in the App folder (speedrunners have an incentive to do this). However this file doesn't appear in the Mac version. Maybe it's hidden? I know how to show hidden files on a modern Mac but not on OS9.

Author:  adespoton [ Wed Sep 13, 2017 4:07 pm ]
Post subject:  Re: Video problems in Diablo

You might want to crack the app open with ResEdit -- it's possible that the files are stored as resources.

Other than that, I'd recommend getting Greg's Browser and enabling "show hidden files" -- this might show you what you want, plus it gives you an OS X style file browser under OS 9.

Author:  gordie124 [ Wed Sep 13, 2017 4:58 pm ]
Post subject:  Re: Video problems in Diablo

No luck with either of those apps, although Greg's Browser is fascinating! It's a trip to see OS X design choices rendered in OS 9 graphics.

I have a few more ideas for possible solutions — maybe there's a video codec, or an extension I'm missing? I could try installing an assortment and see if any work. The aforementioned video file is a Wsmack32.dll file, which googling seems to point to as a Windows-only necessity. I'll also use the wayback machine to see if there's any help to be found on the old M.G. forums.

Author:  Jorpho [ Wed Sep 13, 2017 8:45 pm ]
Post subject:  Re: Video problems in Diablo

A quick Google suggests there is something called the Smacker Carbon Player. Maybe installing that is worth a try?
http://www.radgametools.com/smkdown.htm

Otherwise my inclination would be to try reinstalling Quicktime.

Author:  Cat_7 [ Wed Sep 13, 2017 9:39 pm ]
Post subject:  Re: Video problems in Diablo

Quote:
Otherwise my inclination would be to try reinstalling Quicktime.


If you do, please note that version 4.12 is the last version working well in OS 9.
http://macintoshgarden.org/apps/quicktime-4

Best,
Cat_7

Author:  gordie124 [ Wed Sep 13, 2017 11:40 pm ]
Post subject:  Re: Video problems in Diablo

Jorpho, good find! Although the only Mac download is just the media player. I put that into my apps folder, but it didn't have any effect within Diablo.

I'd tried reinstalling quicktime (before I posted this topic, natch) but I tried again with the "Full" installation this time, with every possible extension checked, as opposed to the "Minimum". Still no dice. :( But I appreciate the suggestion.

I'm wondering if it's equally likely it might be a problem with the OS's sound device as its video.

Author:  gordie124 [ Thu Sep 14, 2017 3:35 am ]
Post subject:  Re: Video problems in Diablo

I'm happy to report I solved my problem.

The solution turned out to be, embarrassingly, to use the latest 2014 version of Sheepshaver, rather than the 2008 app. How did that even get onto my computer!? :roll:

Thanks for the help, all. I would've given up solving the problem without new ideas to try.

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/