Page 1 of 1

Windows 10 x64 unable to recognize Mac OS Installation ISO

Posted: Fri Oct 13, 2017 1:25 pm
by ultranothing
Hi. Noob here. Fumbling through the process in SheepShaver v2.3. I'm using the New World PPC ROM ( ... as recommended by Redundant Robot.

I've gotten so far as to get the blinking question mark on the floppy icon. I know (or I think) that I need to mount an ISO of the Mac OS Installation (9.0.4 is what I'm told works well) and add it to my Hard File to boot from, but the problem I'm having -- and I assume this is a problem that is easily solved, but I can't seem to find an answer elsewhere -- is that I cannot mount any ISO image made for a Mac. I am getting an error that "Windows can't access the disc. The disc might be corrupt. Make sure that the disc uses a format that Windows recognizes."

I have tried to mount the ISO (Apple_MacOS_9.0.4_USA.iso) with Windows 10's built-in virtual disc and with Daemon Tools.

Daemon Tools gets me the closest; it will mount the disc (on drive D:) but the disc is not accessible. When I attempt to add drive D: as a volume in SheepShaver, I am given the error "Folder unreadable: Interrupted function call."

So where am I going wrong?

Edit: I should add that I have tested mounting capabilities on my PC with the built-in and 3rd party virtual drive using standard Windows ISO's to make sure it wasn't a blanket issue and those did mount successfully.

Re: Windows 10 x64 unable to recognize Mac OS Installation I

Posted: Fri Oct 13, 2017 1:57 pm
by ultranothing
And now, for some reason, SheepShaverGUI closes when I try to start the emulator...I mean...frustrating!

Re: Windows 10 x64 unable to recognize Mac OS Installation I

Posted: Fri Oct 13, 2017 3:38 pm
by Cat_7

Perhaps you fumbled the preferences.

You should not mount the Mac OS disk image in Windows at all. SheepShaver should mount the disk image when you add it to the volumes in the volumes list in the GUI.
In your SheepShaver folder there is a file called SheepShaver_prefs. Open it with Notepad and copy the content in your answer so we can see how you configured SheepShaver and perhaps point out the issue preventing you from booting.


Re: Windows 10 x64 unable to recognize Mac OS Installation I

Posted: Fri Oct 13, 2017 4:51 pm
by ultranothing
Oh, I fumbled something. I'm nearly positive I've got the right ROM and the proper volume installed. But once I click "start" in SheepshaverGUI, it cuts out and I have to restart.

Here's the info from the config file:

disk C:\Users\NZXT\Desktop\Basilisk\OS9.img
cdrom D:\
screen win/1024/768
windowmodes 3
screenmodes 63
seriala COM1
serialb COM2
rom C:\Users\NZXT\Desktop\Basilisk\ROMs\newworld86.rom
bootdrive 0
bootdriver 0
ramsize 536870912
frameskip 0
gfxaccel true
nocdrom false
nonet false
nosound false
nogui false
noclipconversion false
ignoresegv true
ignoreillegal true
jit true
jit68k false
keyboardtype 5
ether slirp
keycodes true
mousewheelmode 1
mousewheellines 3
ignoresegv true
idlewait true
keycodes true
mousewheelmode 1
mousewheellines 3
enableextfs false
debugextfs false
pollmedia true
etherpermanentaddress true
ethermulticastmode 0
routerenabled false
ftp_port_list 21
portfile0 C:\B2TEMP0.OUT
portfile1 C:\B2TEMP1.OUT

Thanks a lot for helping me with this! :)

Re: Windows 10 x64 unable to recognize Mac OS Installation I

Posted: Fri Oct 13, 2017 8:09 pm
by Cat_7

It seems you have any empty disk entry in your preferences (1st line). If you want to start from the Cd image you downloaded, add this as first disk entry in your prefs file:

disk C:\Users\NZXT\Desktop\Basilisk\Apple_MacOS_9.0.4_USA.iso

(assuming you keep the cd image in the same place as the hard disk image OS9.img).
Please note that if you want to install full Mac OS 9 on the OS9.img, this hard disk image will be too small. Best to create a new 2Gb hard disk image with the GUI.

But first things first: the rom seems OK. Fix the first line in your prefs (you can edit it in Notepad), save the file and start SheepShaver.exe (not the SheepShaverGUI.exe).

(It seems a bit strange to have SheepShaver set up in a folder called Basilisk ;-) )