Can't access webpages using slirp

About SheepShaver, a PPC Mac emulator for Windows, MacOS X, and Linux that can run System 7.5.3 to MacOS 9.0.4.

Moderators: Cat_7, Ronald P. Regensburg, ClockWise

Post Reply
bigmac
Space Cadet
Posts: 3
Joined: Tue Nov 24, 2015 2:26 am

Can't access webpages using slirp

Post by bigmac »

Sometimes I am able to access one website:
Image
But when I try to access another, this happens:
Image

Sometimes, I can't access any websites at all; SheepShaver just dies saying "Segmentation fault". This is with "Ignore illegal memory accesses" turned on. With it turned off, it always dies with a segmentation fault when I try to access a website. It does this in Netscape 4 and iCab.

Here is my prefs file:

Code: Select all

disk /home/****/projects/macemu/SheepShaver/res/disks/boxhd
disk /home/****/projects/macemu/SheepShaver/res/disks/hda
extfs /home/ryan
screen win/832/624
windowmodes 0
screenmodes 0
seriala /dev/null
serialb /dev/ttyS3
rom /home/****/projects/macemu/SheepShaver/res/roms/mac_oldworld_rom4mb.rom
bootdrive 0
bootdriver 0
ramsize 67108864
frameskip 1
gfxaccel true
nocdrom false
nonet false
nosound false
nogui false
noclipconversion false
ignoresegv true
ignoreillegal false
jit false
jit68k true
keyboardtype 5
ether slirp
keycodes false
mousewheelmode 0
mousewheellines 3
dsp /dev/dsp
mixer /dev/mixer
ignoresegv true
idlewait false
User avatar
macplus
Inquisitive Elf
Posts: 31
Joined: Sat Feb 04, 2017 5:12 am
Location: Argentina

Re: Can't access webpages using slirp

Post by macplus »

Which version of Mac OS are you emulating?
Compact Macs will rule supreme for all eternity! :twisted:
User avatar
Wozinator
Space Cadet
Posts: 2
Joined: Mon Oct 16, 2017 10:06 pm
Location: Iowa
Contact:

Re: Can't access webpages using slirp

Post by Wozinator »

It totally crashes for me when I boot using slirp. It runs fine until I try to use networking, then it crashes. It'll even crash opening up the TCP/IP control panel if it's using slirp.
User avatar
Ronald P. Regensburg
Expert User
Posts: 6329
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: Can't access webpages using slirp

Post by Ronald P. Regensburg »

slirp networking is known to be not very robust, but I never heard of crashes when doing nothing but opening TCP/IP control panel. You can try removing TCP/IP preferences from the Preferences folder in System Folder and launch SheepShaver again. Then make sure the control panel is set to Ethernet and DHCP.

Which are your host and guest OS versions?
Post Reply