Switch to full style
About SheepShaver, a PPC Mac emulator for Windows, MacOSX, and Linux that can run System 7.5.3 through MacOS 9.0.4.
Post a reply

'The procedure entry point could not be located' errors fix

Sat Dec 09, 2017 3:24 pm

I used to use SheepShaver and Basilisk II many years ago, back on my Windows XP. Then recently I tried to copy the files over to my new 64-bit Windows 10 machine, and whenever I tried to start the GUIs, I would get the error 'The procedure entry point *** could not be found in the dynamic link library SheepShaverGUI.exe' (I can't remember the exact error, and now that I've fixed it I can't seem to 'break' it again to get the error). I tried uninstalling and reinstalling every single version of GTK+ that I could find. I also searched Google and these forums, and all I could find were a couple people posting about the error and the thread then dying, or someone who posted that they had fixed it by installing GTK, which I had already tried to do.
So although the problem doesn't seem to be that common, I thought I'd post how I fixed it anyway. I went to the GTK install directory (C:\Program Files (x86)\Common Files\GTK\2.0), did a search for 'dll', then copied every single dll file present into the SheepShaver and Basilisk II directories. The GUIs then worked fine. I'm sure not every dll file was necessary, but the problem clearly seemed to be some confusion on the computer's part as to directory paths or install locations. Interestingly, I then deleted every single one of those dll files to try and reproduce the error, and the GUIs still worked. So I'm really not sure what went on there.
Post a reply