Switch to full style
About SheepShaver, a PPC Mac emulator for Windows, MacOSX, and Linux that can run System 7.5.3 through MacOS 9.0.4.
Post a reply

SheepShaver 2.4 (2014-02-01) and Mac 10.13.3

Sun Feb 04, 2018 6:30 pm

I'm trying to get the SheepShaver Environment up and running. I placed the renamed new world ROMs in the same folder as SheepShaver (next to the package). Tried to launch SheepShaver but it simply quits. I have tried both names. Mac OS ROM or ROM. Neither work. Some instructions say to drag and drop it on the application. The application won't accept the drop. I can provide any logs that you want to see or read it for you and supply in info that you want. Any help would be appreciated. I love some older 30 year old Mac applications and would LOVE to use them again. A friend had Mac OS 10.4 running on an older Mac and I saw the older application and fell in love with it again. Any help would be greatly appreciated. Thanks in advance!!

Keith

Re: SheepShaver 2.4 (2014-02-01) and Mac 10.13.3

Mon Feb 05, 2018 10:07 am

1. Did you make sure you renamed the rom file "Mac OS ROM" without the file name extension still there and hidden? (You can check this in Finder Info for the file.)

2. With a new installation, you will need to use the workaround for macOS 10.12 and later as described with the compatibility notes on the download page:
- macOS 10.12 (Sierra) and later
There is an issue with macOS 10.12 Sierra (in fact with an additional new security feature in Sierra) that prevents a newly installed SheepShaver to run. The procedure to get it running is simply to copy the program (only the SheepShaver application itself!) to the desktop, remove the old program in the SheepShaver folder and move the new copy from the desktop to the SheepShaver folder.
You can also simply delete the application from the folder and replace it with the single application download that solves a cursor issue in macOS 10.13.

Re: SheepShaver 2.4 (2014-02-01) and Mac 10.13.3

Mon Feb 05, 2018 12:17 pm

"SheepShaver Environment"? What exactly is that? Are you perhaps referring to the SheepShaver Wrapper? If so, follow the instructions exactly and it will work. If not, we'll need more accurate details of exactly what you are trying to do.

Ronald: if the original message is referring to the SheepShaver Wrapper but doesn't get the name right, then there is a confusion here between the SheepShaver Wrapper (which expects a ROM file to be dropped on it) and SheepShaver itself, which wants the ROM file in the same folder. The two sets of instructions are completely separate from each other, and each is complete in itself. But I'm only guessing here, because the original post refers to something that doesn't exist (the "SheepShaver Environment"), so we have no way of knowing exactly what the problem is.

Re: SheepShaver 2.4 (2014-02-01) and Mac 10.13.3

Tue Feb 06, 2018 6:08 am

Thanks #2 was the issue for me. Thanks for working the problem instead of complaining!!

Keith

Re: SheepShaver 2.4 (2014-02-01) and Mac 10.13.3

Mon Feb 19, 2018 3:16 am

I am currently running Sheepshaver 2.4 on my El Capitan MAC and I would like to know if I simply upgrade to OS 10.13 will it run without any problems? Note: I am a computer dummy so a very simple answer would be greatly appreciated as I rely on Sheepshaver to run a finance program(the very old Managing Your Money) that I never want to give up! I need to upgrade to 10.13 by next year because TurboTax will no longer work on El Capitan.

Re: SheepShaver 2.4 (2014-02-01) and Mac 10.13.3

Mon Feb 19, 2018 1:09 pm

SheepShaver should still work fine after a regular upgrade (default instalation over the existing OS).

In High Sierra you will see a cosmetic issue around the mouse cursor, though. That can be solved by replacing the SheepShaver application file with a patched one that is available in the SheepShaver for OSX download topic: viewtopic.php?f=20&t=7360

Re: SheepShaver 2.4 (2014-02-01) and Mac 10.13.3

Tue Feb 20, 2018 3:40 am

Ronald,
Thanks for the quick reply. I downloaded the patch and when I tried to open the Sheepshaver icon I got the flashing "?". I assume that if I move this patch icon into my Sheepshaver folder that it will then work- after taking out the existing application? I apologize for the dumb questions, but as I said above, I am a computer dummy, that spent several hours just getting Sheepshaver installed and running several years ago- and I do not want to screw up my currently well running Sheepshaver. I have not yet upgraded from El Capitan to High Sierra but am simply getting ready. I love Sheepshaver and I do thank you very much for your support of it. Thank you,
Steve

Re: SheepShaver 2.4 (2014-02-01) and Mac 10.13.3

Tue Feb 20, 2018 10:37 am

jayich wrote:I assume that if I move this patch icon into my Sheepshaver folder that it will then work- after taking out the existing application?

Yes, of course. That is what I meant with "replacing the SheepShaver application file with a patched one". Remove (delete) the old SheepShaver application and put the new patched one in its place in the folder. Then use that new patched SheepShaver application.

Re: SheepShaver 2.4 (2014-02-01) and Mac 10.13.3

Sat Feb 24, 2018 4:53 am

Thanks Ronald.
Post a reply