E-Maculation
https://www.emaculation.com/forum/

SheepShaver on Raspberry won't start
https://www.emaculation.com/forum/viewtopic.php?f=20&t=9596
Page 1 of 1

Author:  doug-doug the mighty [ Wed Feb 07, 2018 11:40 am ]
Post subject:  SheepShaver on Raspberry won't start

I'm a NOOB running SS on a Raspberry 3. It worked for about a week but now won't open. Rebuilt everything with a slick OS and reinstalled SS, nothing.

What broke? What can I fix? It worked and then doesn't so I know it *should* work again.

I'm not dumb and I know MacOS, basic programming, and electronics but I need this Barney-style as Linux is still a HUGE learning curve I struggle with.

TIA
--ddtm

Author:  adespoton [ Wed Feb 07, 2018 5:55 pm ]
Post subject:  Re: SheepShaver on Raspberry won't start

Do you have any log output to indicate what stage it failed to load at?

Author:  doug-doug the mighty [ Thu Feb 08, 2018 6:24 am ]
Post subject:  Re: SheepShaver on Raspberry won't start

I honestly do not know how to tell but if you tell me where to look I can check. Alternatively, as I am launching this from the GUI (and when attempted with Terminal mode it dies right away flashing the terminal window for like a nano second), is it possible to launch this from a terminal command vice double clicking the executable? Perhaps I could add some string to the command to give persistent feedback in a terminal windo rather than the one launched by the GUI.

Author:  adespoton [ Thu Feb 08, 2018 4:53 pm ]
Post subject:  Re: SheepShaver on Raspberry won't start

doug-doug the mighty wrote:
I honestly do not know how to tell but if you tell me where to look I can check. Alternatively, as I am launching this from the GUI (and when attempted with Terminal mode it dies right away flashing the terminal window for like a nano second), is it possible to launch this from a terminal command vice double clicking the executable? Perhaps I could add some string to the command to give persistent feedback in a terminal windo rather than the one launched by the GUI.


Try launching the terminal window first, and running it manually from inside the terminal window; this way, the error information will go directly to stdout, which in this case is the terminal window.

Alternatively, you may have something in /var/log/syslog.

Which OS are you running on the Pi3?

Author:  doug-doug the mighty [ Sat Feb 10, 2018 2:20 am ]
Post subject:  Re: SheepShaver on Raspberry won't start

I checked the staking but there was nothing in it from SheepShaver (based on the timestamps).

Running the program from a fresh terminal window was very helpful - feedback says "ERROR: Invalid ROM file size. SheepShaver requires a 4MB PCI PowerMac ROM."

The 'ppc.ROM' I'm using is the one that was included with the install and exists in the same folder as the executable.

Author:  Cat_7 [ Sat Feb 10, 2018 7:40 am ]
Post subject:  Re: SheepShaver on Raspberry won't start

Hi,

Please name that rom file "Mac OS Rom" (without the quotes). If that doesn't work, download a known-to-work rom from the redundant robot site. Find the one labeled "best for SheepShaver".
Name it "Mac OS Rom" .

That should solve the issue you experience.

Best,
Cat_7

Author:  doug-doug the mighty [ Sun Feb 11, 2018 12:44 am ]
Post subject:  Re: SheepShaver on Raspberry won't start

This worked perfectly!! Thank you.

Best I can autopsy this, when I originally added stuff for a different project, I broke my install. When I slicked my SD Card and installed again I missed the step to correct the ROM.

Thanks for your patience.

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/